diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2015-06-09 14:39:01 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-06-23 12:40:10 +0200 |
commit | 4e3fd58988b5d40bb2fb699ffdaecc8b088a4372 (patch) | |
tree | 5c3330b0f51dd62c715bce6e2719e39fe88619ab /meta-multimedia/recipes-connectivity | |
parent | 13a7f47192ffdce659da610322122d887c53b325 (diff) | |
download | meta-openembedded-4e3fd58988b5d40bb2fb699ffdaecc8b088a4372.tar.gz |
libupnp: add initial recipe, libupnp v1.6.19
http://pupnp.sourceforge.net/
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
3 files changed, 126 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-connectivity/libupnp/libupnp/avoid-redefining-strnlen-and-strndup.patch b/meta-multimedia/recipes-connectivity/libupnp/libupnp/avoid-redefining-strnlen-and-strndup.patch new file mode 100644 index 000000000..3c3f230a3 --- /dev/null +++ b/meta-multimedia/recipes-connectivity/libupnp/libupnp/avoid-redefining-strnlen-and-strndup.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | From 22fba4f2765f92cd592a58e1fe5c450b187e30e1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andre McCurdy <armccurdy@gmail.com> | ||
3 | Date: Wed, 3 Jun 2015 21:39:03 -0700 | ||
4 | Subject: [PATCH] avoid redefining strnlen() and strndup() | ||
5 | |||
6 | Rely on string.h definitions instead. Workaround for compiler errors such as: | ||
7 | |||
8 | | i686-rdk-linux-libtool: compile: i686-rdk-linux-gcc -m32 -march=atom -mtune=atom -fschedule-insns -fsched-pressure -msse3 -mfpmath=sse --sysroot=/home/andre/build/tmp/sysroots/7401 -DHAVE_CONFIG_H -I. -I/home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp -I.. -I../upnp/inc -I/home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp/inc -I/home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/threadutil/inc -I/home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/ixml/inc -I/home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp/src/inc -pthread -O2 -pipe -g -feliminate-unused-debug-types -Os -Wall -c /home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp/src/gena/gena_callback2.c -o src/gena/libupnp_la-gena_callback2.o >/dev/null 2>&1 | ||
9 | | In file included from /home/andre/build/tmp/sysroots/7401/usr/include/string.h:634:0, | ||
10 | | from /home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp/src/api/UpnpString.c:23: | ||
11 | | /home/andre/build/tmp/work/core2-32-rdk-linux/libupnp/1.6.19-r0/libupnp-1.6.19/upnp/src/api/UpnpString.c:47:15: error: expected identifier or '(' before '__extension__' | ||
12 | | extern char *strndup(__const char *__string, size_t __n); | ||
13 | | ^ | ||
14 | | make[3]: *** [src/api/libupnp_la-UpnpString.lo] Error 1 | ||
15 | |||
16 | Upstream-Status: Pending | ||
17 | |||
18 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | ||
19 | --- | ||
20 | upnp/src/api/UpnpString.c | 4 ++-- | ||
21 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
22 | |||
23 | diff --git a/upnp/src/api/UpnpString.c b/upnp/src/api/UpnpString.c | ||
24 | index 41c9898..2fa09d7 100644 | ||
25 | --- a/upnp/src/api/UpnpString.c | ||
26 | +++ b/upnp/src/api/UpnpString.c | ||
27 | @@ -32,7 +32,7 @@ | ||
28 | /* VC has strnlen which is already included but with (potentially) different linkage */ | ||
29 | /* strnlen() is a GNU extension. */ | ||
30 | #if HAVE_STRNLEN | ||
31 | - extern size_t strnlen(const char *s, size_t maxlen); | ||
32 | +// extern size_t strnlen(const char *s, size_t maxlen); | ||
33 | #else /* HAVE_STRNLEN */ | ||
34 | static size_t strnlen(const char *s, size_t n) | ||
35 | { | ||
36 | @@ -44,7 +44,7 @@ | ||
37 | |||
38 | /* strndup() is a GNU extension. */ | ||
39 | #if HAVE_STRNDUP && !defined(WIN32) | ||
40 | - extern char *strndup(__const char *__string, size_t __n); | ||
41 | +// extern char *strndup(__const char *__string, size_t __n); | ||
42 | #else /* HAVE_STRNDUP && !defined(WIN32) */ | ||
43 | static char *strndup(const char *__string, size_t __n) | ||
44 | { | ||
45 | -- | ||
46 | 1.9.1 | ||
47 | |||
diff --git a/meta-multimedia/recipes-connectivity/libupnp/libupnp/sepbuildfix.patch b/meta-multimedia/recipes-connectivity/libupnp/libupnp/sepbuildfix.patch new file mode 100644 index 000000000..cd9768d54 --- /dev/null +++ b/meta-multimedia/recipes-connectivity/libupnp/libupnp/sepbuildfix.patch | |||
@@ -0,0 +1,60 @@ | |||
1 | From e198f0a87660a048164ca0e16d18517d0aee846e Mon Sep 17 00:00:00 2001 | ||
2 | From: Andre McCurdy <armccurdy@gmail.com> | ||
3 | Date: Tue, 9 Jun 2015 12:20:45 -0700 | ||
4 | Subject: [PATCH] Fix builds when using separate source and build directories. | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | ||
9 | --- | ||
10 | configure.ac | 8 ++++---- | ||
11 | ixml/Makefile.am | 2 +- | ||
12 | threadutil/Makefile.am | 2 +- | ||
13 | 3 files changed, 6 insertions(+), 6 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index e2c3f47..11d5e22 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -714,8 +714,8 @@ AC_OUTPUT | ||
20 | # | ||
21 | # Files copied for windows compilation. | ||
22 | # | ||
23 | -echo "configure: copying \"autoconfig.h\" to \"build/inc/autoconfig.h\"" | ||
24 | -cp autoconfig.h build/inc/autoconfig.h | ||
25 | -echo "configure: copying \"upnp/inc/upnpconfig.h\" to \"build/inc/upnpconfig.h\"" | ||
26 | -cp upnp/inc/upnpconfig.h build/inc/upnpconfig.h | ||
27 | +echo "configure: copying \"autoconfig.h\" to \"\$srcdir/build/inc/autoconfig.h\"" | ||
28 | +cp autoconfig.h $srcdir/build/inc/autoconfig.h | ||
29 | +echo "configure: copying \"upnp/inc/upnpconfig.h\" to \"\$srcdir/build/inc/upnpconfig.h\"" | ||
30 | +cp upnp/inc/upnpconfig.h $srcdir/build/inc/upnpconfig.h | ||
31 | |||
32 | diff --git a/ixml/Makefile.am b/ixml/Makefile.am | ||
33 | index 49da766..0e9ab2c 100644 | ||
34 | --- a/ixml/Makefile.am | ||
35 | +++ b/ixml/Makefile.am | ||
36 | @@ -7,7 +7,7 @@ | ||
37 | |||
38 | SUBDIRS = doc | ||
39 | |||
40 | -AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc | ||
41 | +AM_CPPFLAGS = -I$(top_srcdir)/upnp/inc -I$(srcdir)/inc -I$(srcdir)/src/inc | ||
42 | AM_CFLAGS = | ||
43 | |||
44 | LDADD = libixml.la | ||
45 | diff --git a/threadutil/Makefile.am b/threadutil/Makefile.am | ||
46 | index a4ed325..42d0726 100644 | ||
47 | --- a/threadutil/Makefile.am | ||
48 | +++ b/threadutil/Makefile.am | ||
49 | @@ -4,7 +4,7 @@ | ||
50 | # (C) Copyright 2005 Remi Turboult <r3mi@users.sourceforge.net> | ||
51 | # | ||
52 | |||
53 | -AM_CPPFLAGS = -I$(srcdir)/inc -I$(srcdir)/src/inc | ||
54 | +AM_CPPFLAGS = -I$(top_srcdir)/upnp/inc -I$(srcdir)/inc -I$(srcdir)/src/inc | ||
55 | |||
56 | if ENABLE_DEBUG | ||
57 | AM_CPPFLAGS += -DDEBUG -DSTATS | ||
58 | -- | ||
59 | 1.9.1 | ||
60 | |||
diff --git a/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.6.19.bb b/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.6.19.bb new file mode 100644 index 000000000..133a8ebd5 --- /dev/null +++ b/meta-multimedia/recipes-connectivity/libupnp/libupnp_1.6.19.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "Portable SDK for UPnP* Devices" | ||
2 | DESCRIPTION = "The Portable SDK for UPnP Devices is an SDK for development of \ | ||
3 | UPnP device and control point applications. It consists of the core UPnP \ | ||
4 | protocols along with a UPnP-specific eXtensible Markup Language (XML) parser \ | ||
5 | supporting the Document Object Model (DOM) Level 2 API and an optional, \ | ||
6 | integrated mini web server for serving UPnP related documents." | ||
7 | HOMEPAGE = "http://pupnp.sourceforge.net/" | ||
8 | LICENSE = "BSD" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b3190d5244e08e78e4c8ee78544f4863" | ||
10 | |||
11 | SRC_URI = "${SOURCEFORGE_MIRROR}/pupnp/${BP}.tar.bz2 \ | ||
12 | file://avoid-redefining-strnlen-and-strndup.patch \ | ||
13 | file://sepbuildfix.patch \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "ee16e5d33a3ea7506f38d71facc057dd" | ||
17 | SRC_URI[sha256sum] = "b3142b39601243b50532eec90f4a27dba85eb86f58d4b849ac94edeb29d9b22a" | ||
18 | |||
19 | inherit autotools | ||