summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-09 00:57:04 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:49:37 +0200
commit30de915efca9f55a65ee0b4e780332f5e28abadc (patch)
tree9b7669c0f78fefadbcb0137d31c419a23e3fa575 /meta-multimedia/recipes-connectivity
parent458950562ff93b60bd07df8cf14c535854bc67e4 (diff)
downloadmeta-openembedded-30de915efca9f55a65ee0b4e780332f5e28abadc.tar.gz
gupnp-dlna: Upgrade to 0.10.5
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/files/move_vapigen.patch102
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb (renamed from meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb)8
2 files changed, 107 insertions, 3 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/files/move_vapigen.patch b/meta-multimedia/recipes-connectivity/gupnp/files/move_vapigen.patch
new file mode 100644
index 000000000..9bfc31b8e
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/gupnp/files/move_vapigen.patch
@@ -0,0 +1,102 @@
1OE-Core's vala class known one type of vapigen.m4 and deletes it since its
2not cross compile friendly, but this is a different case here where its not
3same vapigen.m4 just name is same and it tends to inherit vala bbclass so
4save it
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7Index: gupnp-dlna-0.10.5/m4/vapigen-custom.m4
8===================================================================
9--- /dev/null
10+++ gupnp-dlna-0.10.5/m4/vapigen-custom.m4
11@@ -0,0 +1,43 @@
12+
13+dnl vala.m4
14+dnl
15+dnl Copyright 2010 Marc-Andre Lureau
16+dnl Copyright 2011 Rodney Dawes <dobey.pwns@gmail.com>
17+dnl
18+dnl This library is free software; you can redistribute it and/or
19+dnl modify it under the terms of the GNU Lesser General Public
20+dnl License as published by the Free Software Foundation; either
21+dnl version 2.1 of the License, or (at your option) any later version.
22+dnl
23+dnl This library is distributed in the hope that it will be useful,
24+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
25+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
26+dnl Lesser General Public License for more details.
27+dnl
28+dnl You should have received a copy of the GNU Lesser General Public
29+dnl License along with this library; if not, write to the Free Software
30+dnl Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
31+
32+dnl dropped everything but VALA_PROG_VAPIGEN - Jens Georg <mail@jensge.org>
33+
34+# Check whether the Vala API Generator exists in `PATH'. If it is found,
35+# the variable VAPIGEN is set. Optionally a minimum release number of the
36+# generator can be requested.
37+#
38+# VALA_PROG_VAPIGEN([MINIMUM-VERSION])
39+# ------------------------------------
40+AC_DEFUN([GUPNP_PROG_VAPIGEN],
41+[AC_PATH_PROG([VAPIGEN], [vapigen], [])
42+ AS_IF([test -z "$VAPIGEN"],
43+ [AC_MSG_WARN([No Vala API Generator found. You will not be able to generate .vapi files.])],
44+ [AS_IF([test -n "$1"],
45+ [AC_MSG_CHECKING([$VAPIGEN is at least version $1])
46+ am__vapigen_version=`$VAPIGEN --version | sed 's/Vala API Generator *//'`
47+ AS_VERSION_COMPARE([$1], ["$am__vapigen_version"],
48+ [AC_MSG_RESULT([yes])],
49+ [AC_MSG_RESULT([yes])],
50+ [AC_MSG_RESULT([no])
51+ AC_MSG_WARN([Vala API Generator $1 not found.])
52+ VAPIGEN=""
53+ ])])])
54+])
55Index: gupnp-dlna-0.10.5/m4/vapigen.m4
56===================================================================
57--- gupnp-dlna-0.10.5.orig/m4/vapigen.m4
58+++ /dev/null
59@@ -1,43 +0,0 @@
60-
61-dnl vala.m4
62-dnl
63-dnl Copyright 2010 Marc-Andre Lureau
64-dnl Copyright 2011 Rodney Dawes <dobey.pwns@gmail.com>
65-dnl
66-dnl This library is free software; you can redistribute it and/or
67-dnl modify it under the terms of the GNU Lesser General Public
68-dnl License as published by the Free Software Foundation; either
69-dnl version 2.1 of the License, or (at your option) any later version.
70-dnl
71-dnl This library is distributed in the hope that it will be useful,
72-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
73-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
74-dnl Lesser General Public License for more details.
75-dnl
76-dnl You should have received a copy of the GNU Lesser General Public
77-dnl License along with this library; if not, write to the Free Software
78-dnl Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
79-
80-dnl dropped everything but VALA_PROG_VAPIGEN - Jens Georg <mail@jensge.org>
81-
82-# Check whether the Vala API Generator exists in `PATH'. If it is found,
83-# the variable VAPIGEN is set. Optionally a minimum release number of the
84-# generator can be requested.
85-#
86-# VALA_PROG_VAPIGEN([MINIMUM-VERSION])
87-# ------------------------------------
88-AC_DEFUN([GUPNP_PROG_VAPIGEN],
89-[AC_PATH_PROG([VAPIGEN], [vapigen], [])
90- AS_IF([test -z "$VAPIGEN"],
91- [AC_MSG_WARN([No Vala API Generator found. You will not be able to generate .vapi files.])],
92- [AS_IF([test -n "$1"],
93- [AC_MSG_CHECKING([$VAPIGEN is at least version $1])
94- am__vapigen_version=`$VAPIGEN --version | sed 's/Vala API Generator *//'`
95- AS_VERSION_COMPARE([$1], ["$am__vapigen_version"],
96- [AC_MSG_RESULT([yes])],
97- [AC_MSG_RESULT([yes])],
98- [AC_MSG_RESULT([no])
99- AC_MSG_WARN([Vala API Generator $1 not found.])
100- VAPIGEN=""
101- ])])])
102-])
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb
index 053604e12..3cafd6976 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.9.4.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb
@@ -5,9 +5,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
5 5
6DEPENDS = "libxml2 glib-2.0" 6DEPENDS = "libxml2 glib-2.0"
7 7
8SRC_URI = "http://download.gnome.org/sources/${BPN}/0.9/${BPN}-${PV}.tar.xz" 8SRC_URI = "http://download.gnome.org/sources/${BPN}/0.10/${BPN}-${PV}.tar.xz \
9SRC_URI[md5sum] = "f93665e535a512e4d515a86311435cb6" 9 file://move_vapigen.patch \
10SRC_URI[sha256sum] = "69969713f36c0e815fbbbcfdfb3ad9bd447cfd10d0fd86227d82dfd8edb6c807" 10"
11SRC_URI[md5sum] = "2d0dc1e4189d0243ac3838ece1e8fea0"
12SRC_URI[sha256sum] = "123e368227c11d5c17fc1aa76cbdaffa345355eb51d172cd39fc74a5b468ff6a"
11 13
12inherit autotools pkgconfig gobject-introspection vala 14inherit autotools pkgconfig gobject-introspection vala
13 15