summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-27 22:12:23 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-15 10:15:26 +0100
commitd269686233ac1df4403a0789801f04d98c6a18c2 (patch)
treed6a4402c397c51b2da2771fbd8240101e36d3d1e /meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb
parent0ee8e184eef482763bbc4db0273a63c506ea2b2b (diff)
downloadmeta-openembedded-d269686233ac1df4403a0789801f04d98c6a18c2.tar.gz
rygel: Update to 0.28.2
Update to latest version. This mainly fixes file uploading, which did not work in previous version (see upstream commit "1d45866a3fd7ca47bdbea60156bd18b994710662" among others). sqlite3 is now required to build whole rygel, as some media-export plugin routines have been centralized ; libunistring also improves collation logic if present. Rygel will not keep running anymore when its "plugins" folder is absent or empty. Thus, to avoid disappointments, we now RRECOMMEND at least the media-export plugin. Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb')
-rw-r--r--meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb
new file mode 100644
index 000000000..663f55ebe
--- /dev/null
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.28.2.bb
@@ -0,0 +1,59 @@
1SUMMARY = "A UPnP AV media server and renderer"
2DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \
3allow you to easily share audio, video and pictures to other devices. \
4Additionally, media player software may use Rygel to become a MediaRenderer \
5that may be controlled remotely by a UPnP or DLNA Controller."
6HOMEPAGE = "http://live.gnome.org/Rygel"
7
8LICENSE = "LGPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://src/rygel/rygel-main.vala;endline=27;md5=99324118da4c012d25edae2f779ae9b3"
11
12DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base ossp-uuid libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3"
13RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
14RRECOMMENDS_${PN} = "rygel-plugin-media-export"
15
16GNOME_COMPRESS_TYPE = "xz"
17SRC_URI[archive.md5sum] = "9fbe4fb53b6cfa2f3f3723b7649a2215"
18SRC_URI[archive.sha256sum] = "9ea23df7186caac5f1aad3137edf6d507d339b9a469fc3133df4043fa66b61f5"
19
20inherit gnomebase vala
21
22EXTRA_OECONF = "--disable-introspection --disable-tracker-plugin --with-media-engine=gstreamer"
23
24PACKAGECONFIG ?= "external mpris mediathek ruih media-export gst-launch gtk+3"
25PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
26PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
27PACKAGECONFIG[mediathek] = "--enable-mediathek-plugin,--disable-mediathek-plugin"
28PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin"
29PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin"
30PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin"
31PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3"
32
33LIBV = "2.6"
34
35do_install_append() {
36 # Remove .la files for loadable modules
37 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
38 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
39}
40
41FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
42FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
43
44PACKAGES += "${PN}-meta"
45ALLOW_EMPTY_${PN}-meta = "1"
46
47PACKAGES_DYNAMIC = "${PN}-plugin-*"
48
49python populate_packages_prepend () {
50 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
51 postinst = d.getVar('plugin_postinst', True)
52 pkgs = []
53
54 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
55 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
56
57 metapkg = d.getVar('PN', True) + '-meta'
58 d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
59}