summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-11 14:51:13 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-15 08:20:06 -0700
commit85b0d91d397fd46922c9266db13e725f36968837 (patch)
tree69070c7e06c65ba034d81bc79daff89524e7eb8e /meta-initramfs
parentb19f8c7d6e98b911620ea6fdb606339f49aca18a (diff)
downloadmeta-openembedded-85b0d91d397fd46922c9266db13e725f36968837.tar.gz
kexecboot: Fix build with glibc 2.28+
Update to latest srcrev at the same time. Fix out of tree builds Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch27
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch30
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb10
3 files changed, 63 insertions, 4 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
new file mode 100644
index 000000000..0565133d9
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
@@ -0,0 +1,27 @@
1From d302547305727797e0172ba89e7519252c400021 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Aug 2018 14:37:22 -0700
4Subject: [PATCH 1/2] Add top_srcdir to compiler include paths
5
6Helps in compiling with out of tree build dir
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 src/Makefile.am | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/src/Makefile.am b/src/Makefile.am
14index d04a3a8..6449c5a 100644
15--- a/src/Makefile.am
16+++ b/src/Makefile.am
17@@ -1,5 +1,7 @@
18 bin_PROGRAMS=kexecboot
19
20+kexecboot_CFLAGS = -I$(top_srcdir)
21+
22 kexecboot_SOURCES = \
23 util.c \
24 cfgparser.c \
25--
262.18.0
27
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
new file mode 100644
index 000000000..f12ae99e7
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
@@ -0,0 +1,30 @@
1From c587012cbe448c9295f50497812ca3530cabbb51 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Aug 2018 14:39:01 -0700
4Subject: [PATCH 2/2] include sys/sysmacros.h
5
6glibc 2.28+ does not include this header implicitly via other system
7headers anymore
8
9src/devicescan.c:373: undefined reference to `makedev'
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/devicescan.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/src/devicescan.c b/src/devicescan.c
17index 4f2f497..0b2b253 100644
18--- a/src/devicescan.c
19+++ b/src/devicescan.c
20@@ -20,6 +20,7 @@
21 #include <stdlib.h>
22 #include <string.h>
23 #include <sys/types.h>
24+#include <sys/sysmacros.h>
25 #include <sys/stat.h>
26 #include <fcntl.h>
27 #include <unistd.h>
28--
292.18.0
30
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 9f5dad7c6..8799a3e4c 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -38,15 +38,17 @@ LICENSE = "GPLv2"
38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
39PV = "0.6+git${SRCPV}" 39PV = "0.6+git${SRCPV}"
40S = "${WORKDIR}/git" 40S = "${WORKDIR}/git"
41SRC_URI = "git://github.com/kexecboot/kexecboot.git" 41SRC_URI = "git://github.com/kexecboot/kexecboot.git \
42SRCREV = "4c4f127e79ac5b8d6b6e2fbb938ccbf12b04c531" 42 file://0001-Add-top_srcdir-to-compiler-include-paths.patch \
43 file://0002-include-sys-sysmacros.h.patch \
44 "
45SRCREV = "d5ffd81bf6a1a2087cdc6c606cae98099229131c"
43inherit autotools 46inherit autotools
44 47
45EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250" 48EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
46 49
47do_install () { 50do_install () {
48 install -d ${D}${bindir} 51 install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
49 install -m 0755 kexecboot ${D}${bindir}
50 install -d ${D}/proc 52 install -d ${D}/proc
51 install -d ${D}/mnt 53 install -d ${D}/mnt
52 install -d ${D}/dev 54 install -d ${D}/dev