summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2018-09-07 12:45:34 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-08 00:06:24 -0700
commit6bed5b3d74322075e4bbd7bc20fcf364d9287e7d (patch)
tree0687d69e47a69c04742f835c68dc8b6b5aecd974 /meta-initramfs
parentf96b327a467b285ceca73825215654e6874c885c (diff)
downloadmeta-openembedded-6bed5b3d74322075e4bbd7bc20fcf364d9287e7d.tar.gz
kexecboot: upgrade to rev. 4c01d6960aa6
Remove upstreamed patches, get new options for kexec. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch27
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch30
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb40
3 files changed, 2 insertions, 95 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
deleted file mode 100644
index 0565133d9..000000000
--- a/meta-initramfs/recipes-bsp/kexecboot/files/0001-Add-top_srcdir-to-compiler-include-paths.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From d302547305727797e0172ba89e7519252c400021 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Aug 2018 14:37:22 -0700
4Subject: [PATCH 1/2] Add top_srcdir to compiler include paths
5
6Helps in compiling with out of tree build dir
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 src/Makefile.am | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/src/Makefile.am b/src/Makefile.am
14index d04a3a8..6449c5a 100644
15--- a/src/Makefile.am
16+++ b/src/Makefile.am
17@@ -1,5 +1,7 @@
18 bin_PROGRAMS=kexecboot
19
20+kexecboot_CFLAGS = -I$(top_srcdir)
21+
22 kexecboot_SOURCES = \
23 util.c \
24 cfgparser.c \
25--
262.18.0
27
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
deleted file mode 100644
index f12ae99e7..000000000
--- a/meta-initramfs/recipes-bsp/kexecboot/files/0002-include-sys-sysmacros.h.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From c587012cbe448c9295f50497812ca3530cabbb51 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 11 Aug 2018 14:39:01 -0700
4Subject: [PATCH 2/2] include sys/sysmacros.h
5
6glibc 2.28+ does not include this header implicitly via other system
7headers anymore
8
9src/devicescan.c:373: undefined reference to `makedev'
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/devicescan.c | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/src/devicescan.c b/src/devicescan.c
17index 4f2f497..0b2b253 100644
18--- a/src/devicescan.c
19+++ b/src/devicescan.c
20@@ -20,6 +20,7 @@
21 #include <stdlib.h>
22 #include <string.h>
23 #include <sys/types.h>
24+#include <sys/sysmacros.h>
25 #include <sys/stat.h>
26 #include <fcntl.h>
27 #include <unistd.h>
28--
292.18.0
30
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 8799a3e4c..6d79e8f83 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -1,36 +1,3 @@
1###########################
2# Configure options:
3#
4# --enable-static-linking compile kexecboot as static executable [default=no]
5# --enable-fbui support framebuffer menu [default=yes]
6# --enable-fbui-width limit FB UI width to specified value [default=no]
7# --enable-fbui-height limit FB UI height to specified value [default=no]
8# --enable-textui support console text user interface [default=no]
9# --enable-cfgfiles support config files [default=yes]
10# --enable-icons support custom icons (depends on fbui) [default=yes]
11# --enable-zaurus compile Sharp Zaurus specific code [default=no]
12# --enable-zimage compile with zImage support [default=yes]
13# --enable-uimage compile with uImage support [default=no]
14# --enable-machine-kernel look for machine-specific zImage kernel [default=no]
15# --enable-devices-recreating
16# enable devices re-creating [default=yes]
17# --enable-debug enable debug output [default=no]
18# --enable-host-debug allow for non-destructive executing of kexecboot on
19# host system [default=no]
20# --enable-numkeys enable menu item selection by keys [0-9] [default=yes]
21# --enable-bg-buffer enable buffer for pre-drawed FB GUI background
22#
23# --enable-timeout allow to boot 1st kernel after timeout in seconds
24# [default=no]
25# --enable-delay specify delay before device scanning, allowing
26# initialization of old CF/SD cards [default=1]
27# --enable-bpp enable support of specified bpp modes
28# (all,32,24,18,16,4,2,1) [default=all]
29# --enable-evdev-rate change evdev (keyboard/mouse) repeat rate
30# in milliseconds e.g. "1000,250" [default=no]
31# --with-kexec-binary look for kexec binary at path
32# [default="/usr/sbin/kexec"]
33##########################
34SUMMARY = "kexecboot linux-as-bootloader" 1SUMMARY = "kexecboot linux-as-bootloader"
35DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec." 2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
36HOMEPAGE = "http://kexecboot.org" 3HOMEPAGE = "http://kexecboot.org"
@@ -38,11 +5,8 @@ LICENSE = "GPLv2"
38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
39PV = "0.6+git${SRCPV}" 6PV = "0.6+git${SRCPV}"
40S = "${WORKDIR}/git" 7S = "${WORKDIR}/git"
41SRC_URI = "git://github.com/kexecboot/kexecboot.git \ 8SRC_URI = "git://github.com/kexecboot/kexecboot.git"
42 file://0001-Add-top_srcdir-to-compiler-include-paths.patch \ 9SRCREV = "4c01d6960aa6a9d03675605062469ab777fa2b01"
43 file://0002-include-sys-sysmacros.h.patch \
44 "
45SRCREV = "d5ffd81bf6a1a2087cdc6c606cae98099229131c"
46inherit autotools 10inherit autotools
47 11
48EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250" 12EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"