summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-01-04 09:09:51 -0800
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:36:53 -0800
commit02e3e2a211d2d4baadecb366de4658db1fcd2cbc (patch)
treea87ef2e58cd1e4034bc89959240129bd60d7c227 /meta-initramfs
parentaf308c17f6f35e3f331e52ba5e23b1dba004473f (diff)
downloadmeta-openembedded-02e3e2a211d2d4baadecb366de4658db1fcd2cbc.tar.gz
kexec-tools-klibc: update to fix build issues after core changes.
Parsing recipes...ERROR: ParseError at ../meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb:2: Could not include required file recipes-kernel/kexec/kexec-tools.inc This was introduced by: http://cgit.openembedded.org/openembedded-core/commit/?id=491f6d523b72b91dc7b186a6f273756435804581 removed the kexec-tools.inc so place those changes into the recipe. Signed-off-by: Armin Kuster <akuster808@gmail.com> Tested-by: Jaewon Lee <jaewon.lee@xilinx.com> Acked-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb36
1 files changed, 32 insertions, 4 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
index 49c53a3ea..2e2703382 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
@@ -1,10 +1,16 @@
1# the binaries are statically linked against klibc 1# the binaries are statically linked against klibc
2require recipes-kernel/kexec/kexec-tools.inc
3SUMMARY = "Kexec tools, statically compiled against klibc" 2SUMMARY = "Kexec tools, statically compiled against klibc"
4SRC_URI[md5sum] = "92eff93b097475b7767f8c98df84408a" 3AUTHOR = "Eric Biederman"
5SRC_URI[sha256sum] = "09e180ff36dee087182cdc939ba6c6917b6adbb5fc12d589f31fd3659b6471f2" 4HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/kexec/"
5SECTION = "kernel/userland"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a \
8 file://kexec/kexec.c;beginline=1;endline=20;md5=af10f6ae4a8715965e648aa687ad3e09"
9DEPENDS = "zlib xz"
10
11PR = "r1"
6 12
7inherit klibc 13inherit klibc autotools
8 14
9FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:" 15FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
10 16
@@ -23,6 +29,9 @@ SRC_URI += " \
23 file://0001-Adjust-the-order-of-headers-to-fix-build-for-musl.patch \ 29 file://0001-Adjust-the-order-of-headers-to-fix-build-for-musl.patch \
24 " 30 "
25 31
32SRC_URI[md5sum] = "92eff93b097475b7767f8c98df84408a"
33SRC_URI[sha256sum] = "09e180ff36dee087182cdc939ba6c6917b6adbb5fc12d589f31fd3659b6471f2"
34
26SRC_URI_append_arm = " file://arm_crashdump.patch" 35SRC_URI_append_arm = " file://arm_crashdump.patch"
27SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch" 36SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch"
28SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch" 37SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
@@ -35,7 +44,26 @@ EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
35CFLAGS += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" 44CFLAGS += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32"
36CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" 45CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64"
37 46
47do_compile_prepend() {
48 # Remove the prepackaged config.h from the source tree as it overrides
49 # the same file generated by configure and placed in the build tree
50 rm -f ${S}/include/config.h
51
52 # Remove the '*.d' file to make sure the recompile is OK
53 for dep in `find ${B} -type f -name '*.d'`; do
54 dep_no_d="`echo $dep | sed 's#.d$##'`"
55 # Remove file.d when there is a file.o
56 if [ -f "$dep_no_d.o" ]; then
57 rm -f $dep
58 fi
59 done
60}
61
38PACKAGES =+ "kexec-klibc kdump-klibc" 62PACKAGES =+ "kexec-klibc kdump-klibc"
39 63
40FILES_kexec-klibc = "${sbindir}/kexec" 64FILES_kexec-klibc = "${sbindir}/kexec"
41FILES_kdump-klibc = "${sbindir}/kdump" 65FILES_kdump-klibc = "${sbindir}/kdump"
66
67INSANE_SKIP_${PN} = "arch"
68
69COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|powerpc.*|mips.*)-(linux|freebsd.*)'