summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2017-02-08 00:56:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:31 +0100
commit547c047e429408bbd8fa154038fd33a9abc099be (patch)
treef9abadc0537b071dd543a7d2e7b16477c633e6ef /meta-initramfs
parent8731b651cb8628ddbf9e938dfe76b83ec62ddf2e (diff)
downloadmeta-openembedded-547c047e429408bbd8fa154038fd33a9abc099be.tar.gz
initramfs-kexecboot-image: disable runtime dependency on run-postinsts
The runtime dependency chain leads to the install of unneeded files: /usr/sbin/run-postinsts /usr/sbin/update-rc.d This comes from the default value of ROOTFS_BOOTSTRAP_INSTALL='run-postinsts' To fix this, for this image we need an empty var. While there, do the same for KERNELDEPMODDEPEND as suggested in image.bbclass. Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
index 45ff50d6b..835b30754 100644
--- a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
@@ -3,10 +3,13 @@ DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5 5
6inherit image
7
6IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" 8IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
7 9
8# avoid circular dependencies 10# avoid circular dependencies
9EXTRA_IMAGEDEPENDS = "" 11EXTRA_IMAGEDEPENDS = ""
12KERNELDEPMODDEPEND = ""
10 13
11# We really need just kexecboot, kexec and ubiattach 14# We really need just kexecboot, kexec and ubiattach
12IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs" 15IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
@@ -18,7 +21,8 @@ IMAGE_LINGUAS = ""
18 21
19FEED_DEPLOYDIR_BASE_URI = "" 22FEED_DEPLOYDIR_BASE_URI = ""
20LDCONFIGDEPEND = "" 23LDCONFIGDEPEND = ""
21
22IMAGE_ROOTFS_EXTRA_SPACE = "0" 24IMAGE_ROOTFS_EXTRA_SPACE = "0"
23 25
24inherit image 26# disable runtime dependency on run-postinsts -> update-rc.d
27ROOTFS_BOOTSTRAP_INSTALL = ""
28