summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-11 08:16:14 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commit2b6cb6bd1f881405917a32363c94a6c5ad63a7aa (patch)
treeb642786411a606fcc9f3fa023127d779cdd8288e /meta-initramfs
parent2cd89a6618dd157a48ea2d3de3d6b4988f4c5ac8 (diff)
downloadmeta-openembedded-2b6cb6bd1f881405917a32363c94a6c5ad63a7aa.tar.gz
klibc: Fix linking by using bfd linker when default linker is gold
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit a52f2cb2e93ead8f747cecfa2df12a9a6e144499) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-always-use-bfd-linker.patch30
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc.inc1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-always-use-bfd-linker.patch b/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-always-use-bfd-linker.patch
new file mode 100644
index 000000000..41a6b9e13
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-always-use-bfd-linker.patch
@@ -0,0 +1,30 @@
1From 9ea19bd9636806a73bcf29cfcee40a268f91eb4c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 11 Jul 2017 08:09:52 -0700
4Subject: [PATCH] always use bfd linker
5
6its possible that distros choose to default to gold linker
7therefore explicitly asking for bfd linker would fix the
8linking issues on such distros
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/Makefile b/Makefile
16index dc10fc5d..40647be4 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -20,7 +20,7 @@ include $(srctree)/scripts/Kbuild.include
20 KLIBCROSS ?= $(CROSS_COMPILE)
21 export KLIBCROSS
22 export CC := $(KLIBCROSS)gcc
23-export LD := $(KLIBCROSS)ld
24+export LD := $(KLIBCROSS)ld.bfd
25 export AR := $(KLIBCROSS)ar
26 export RANLIB := $(KLIBCROSS)ranlib
27 export STRIP := $(KLIBCROSS)strip
28--
292.13.2
30
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc
index be59aa443..c4c3e00b8 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc.inc
+++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc
@@ -16,6 +16,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/libs/klibc/klibc.git \
16 file://0001-Define-in_-structs-for-non-glibc-system-libs.patch \ 16 file://0001-Define-in_-structs-for-non-glibc-system-libs.patch \
17 file://0001-include-linux-sysinfo.h-directly.patch \ 17 file://0001-include-linux-sysinfo.h-directly.patch \
18 file://0001-mkfifo-Implement-mkfifo.patch \ 18 file://0001-mkfifo-Implement-mkfifo.patch \
19 file://0001-always-use-bfd-linker.patch \
19" 20"
20 21
21ARMPATCHES ?= "" 22ARMPATCHES ?= ""