diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-09 07:25:37 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-10 08:48:30 -0700 |
commit | 8204ee52dea70f19e39f8f0affcb4e4edb203f8c (patch) | |
tree | e52f38d6596a24cce29011a91c201318efd16563 /meta-initramfs | |
parent | bc2b1482a0a79a6ff7a9211d9a06f3d637ab9e3d (diff) | |
download | meta-openembedded-8204ee52dea70f19e39f8f0affcb4e4edb203f8c.tar.gz |
klibc: Upgrade to 2.0.10
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
11 files changed, 9 insertions, 50 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/files/0001-Define-in_-structs-for-non-glibc-system-libs.patch b/meta-initramfs/recipes-devtools/klibc/files/0001-Define-in_-structs-for-non-glibc-system-libs.patch index e7a0cce83..29873cf7b 100644 --- a/meta-initramfs/recipes-devtools/klibc/files/0001-Define-in_-structs-for-non-glibc-system-libs.patch +++ b/meta-initramfs/recipes-devtools/klibc/files/0001-Define-in_-structs-for-non-glibc-system-libs.patch | |||
@@ -16,8 +16,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
16 | usr/include/netinet/in.h | 36 ++++++++++++++++++++++++++++++++++++ | 16 | usr/include/netinet/in.h | 36 ++++++++++++++++++++++++++++++++++++ |
17 | 2 files changed, 47 insertions(+) | 17 | 2 files changed, 47 insertions(+) |
18 | 18 | ||
19 | diff --git a/usr/include/net/if.h b/usr/include/net/if.h | ||
20 | index 116a176..6246b12 100644 | ||
21 | --- a/usr/include/net/if.h | 19 | --- a/usr/include/net/if.h |
22 | +++ b/usr/include/net/if.h | 20 | +++ b/usr/include/net/if.h |
23 | @@ -1,6 +1,17 @@ | 21 | @@ -1,6 +1,17 @@ |
@@ -38,8 +36,6 @@ index 116a176..6246b12 100644 | |||
38 | #include <sys/socket.h> | 36 | #include <sys/socket.h> |
39 | #include <sys/types.h> | 37 | #include <sys/types.h> |
40 | #include <linux/if.h> | 38 | #include <linux/if.h> |
41 | diff --git a/usr/include/netinet/in.h b/usr/include/netinet/in.h | ||
42 | index 2952bb2..0c95bc9 100644 | ||
43 | --- a/usr/include/netinet/in.h | 39 | --- a/usr/include/netinet/in.h |
44 | +++ b/usr/include/netinet/in.h | 40 | +++ b/usr/include/netinet/in.h |
45 | @@ -5,6 +5,42 @@ | 41 | @@ -5,6 +5,42 @@ |
@@ -82,6 +78,6 @@ index 2952bb2..0c95bc9 100644 | |||
82 | +#define __UAPI_DEF_IF_IFREQ 1 | 78 | +#define __UAPI_DEF_IF_IFREQ 1 |
83 | +#endif | 79 | +#endif |
84 | + | 80 | + |
81 | #include <sys/types.h> | ||
85 | #include <klibc/extern.h> | 82 | #include <klibc/extern.h> |
86 | #include <stdint.h> | 83 | #include <stdint.h> |
87 | #include <endian.h> /* Must be included *before* <linux/in.h> */ | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/files/0001-dash-Specify-format-string-in-fmtstr.patch b/meta-initramfs/recipes-devtools/klibc/files/0001-dash-Specify-format-string-in-fmtstr.patch deleted file mode 100644 index 46a23987f..000000000 --- a/meta-initramfs/recipes-devtools/klibc/files/0001-dash-Specify-format-string-in-fmtstr.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 8beffe501c1ac5b35d62004735c4157c74183901 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 9 Jul 2017 13:51:25 -0700 | ||
4 | Subject: [PATCH] dash: Specify format string in fmtstr() | ||
5 | |||
6 | Fixes build with hardening flags | ||
7 | |||
8 | usr/dash/jobs.c:429:3: error: format not a string literal and no format arguments [-Werror=format-security] | ||
9 | col = fmtstr(s, 32, strsignal(st)); | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | |||
13 | --- | ||
14 | usr/dash/jobs.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/usr/dash/jobs.c b/usr/dash/jobs.c | ||
18 | index 009bbfe..299bcac 100644 | ||
19 | --- a/usr/dash/jobs.c | ||
20 | +++ b/usr/dash/jobs.c | ||
21 | @@ -426,7 +426,7 @@ sprint_status(char *s, int status, int sigonly) | ||
22 | goto out; | ||
23 | #endif | ||
24 | } | ||
25 | - col = fmtstr(s, 32, strsignal(st)); | ||
26 | + col = fmtstr(s, 32, "%s", strsignal(st)); | ||
27 | #ifdef WCOREDUMP | ||
28 | if (WCOREDUMP(status)) { | ||
29 | col += fmtstr(s + col, 16, " (core dumped)"); | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/files/0001-include-linux-sysinfo.h-directly.patch b/meta-initramfs/recipes-devtools/klibc/files/0001-include-linux-sysinfo.h-directly.patch index 04c97fc5e..d58229681 100644 --- a/meta-initramfs/recipes-devtools/klibc/files/0001-include-linux-sysinfo.h-directly.patch +++ b/meta-initramfs/recipes-devtools/klibc/files/0001-include-linux-sysinfo.h-directly.patch | |||
@@ -15,14 +15,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
15 | usr/include/sys/sysinfo.h | 2 +- | 15 | usr/include/sys/sysinfo.h | 2 +- |
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | 16 | 1 file changed, 1 insertion(+), 1 deletion(-) |
17 | 17 | ||
18 | diff --git a/usr/include/sys/sysinfo.h b/usr/include/sys/sysinfo.h | ||
19 | index dba68dc..d145c0b 100644 | ||
20 | --- a/usr/include/sys/sysinfo.h | 18 | --- a/usr/include/sys/sysinfo.h |
21 | +++ b/usr/include/sys/sysinfo.h | 19 | +++ b/usr/include/sys/sysinfo.h |
22 | @@ -5,7 +5,7 @@ | 20 | @@ -6,7 +6,7 @@ |
23 | #ifndef _SYS_SYSINFO_H | ||
24 | #define _SYS_SYSINFO_H | 21 | #define _SYS_SYSINFO_H |
25 | 22 | ||
23 | #include <sys/types.h> | ||
26 | -#include <linux/kernel.h> | 24 | -#include <linux/kernel.h> |
27 | +#include <linux/sysinfo.h> | 25 | +#include <linux/sysinfo.h> |
28 | 26 | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/files/0001-workaround-for-overlapping-sections-in-binary.patch b/meta-initramfs/recipes-devtools/klibc/files/0001-workaround-for-overlapping-sections-in-binary.patch index 8ccfe447e..2f203ef0a 100644 --- a/meta-initramfs/recipes-devtools/klibc/files/0001-workaround-for-overlapping-sections-in-binary.patch +++ b/meta-initramfs/recipes-devtools/klibc/files/0001-workaround-for-overlapping-sections-in-binary.patch | |||
@@ -34,19 +34,14 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
34 | usr/klibc/syscalls/Kbuild | 2 +- | 34 | usr/klibc/syscalls/Kbuild | 2 +- |
35 | 1 file changed, 1 insertion(+), 1 deletion(-) | 35 | 1 file changed, 1 insertion(+), 1 deletion(-) |
36 | 36 | ||
37 | diff --git a/usr/klibc/syscalls/Kbuild b/usr/klibc/syscalls/Kbuild | ||
38 | index 2430b9b4..754d028e 100644 | ||
39 | --- a/usr/klibc/syscalls/Kbuild | 37 | --- a/usr/klibc/syscalls/Kbuild |
40 | +++ b/usr/klibc/syscalls/Kbuild | 38 | +++ b/usr/klibc/syscalls/Kbuild |
41 | @@ -71,7 +71,7 @@ $(obj)/typesize.c: $(srctree)/$(KLIBCSRC)/syscalls.pl $(obj)/SYSCALLS.i \ | 39 | @@ -71,7 +71,7 @@ $(obj)/typesize.c: $(srctree)/$(KLIBCSRC |
42 | 40 | ||
43 | # Convert typesize.o to typesize.bin | 41 | # Convert typesize.o to typesize.bin |
44 | quiet_cmd_mkbin = OBJCOPY $@ | 42 | quiet_cmd_mkbin = OBJCOPY $@ |
45 | - cmd_mkbin = $(KLIBCOBJCOPY) -O binary $< $@ | 43 | - cmd_mkbin = $(KLIBCOBJCOPY) -O binary --only-section .rodata $< $@ |
46 | + cmd_mkbin = $(KLIBCOBJCOPY) -O binary --remove-section .note.gnu.property $< $@ | 44 | + cmd_mkbin = $(KLIBCOBJCOPY) -O binary --remove-section .note.gnu.property $< $@ |
47 | 45 | ||
48 | $(obj)/typesize.bin: $(obj)/typesize.o FORCE | 46 | $(obj)/typesize.bin: $(obj)/typesize.o FORCE |
49 | $(call if_changed,mkbin) | 47 | $(call if_changed,mkbin) |
50 | -- | ||
51 | 2.30.0 | ||
52 | |||
diff --git a/meta-initramfs/recipes-devtools/klibc/files/armv4-fix-v4bx.patch b/meta-initramfs/recipes-devtools/klibc/files/armv4-fix-v4bx.patch index 4a334fa25..6c734dfd6 100644 --- a/meta-initramfs/recipes-devtools/klibc/files/armv4-fix-v4bx.patch +++ b/meta-initramfs/recipes-devtools/klibc/files/armv4-fix-v4bx.patch | |||
@@ -14,8 +14,8 @@ Signed-off-by: Andrea Adami <andrea.adami@gmail.com> | |||
14 | 14 | ||
15 | --- a/usr/klibc/arch/arm/MCONFIG | 15 | --- a/usr/klibc/arch/arm/MCONFIG |
16 | +++ b/usr/klibc/arch/arm/MCONFIG | 16 | +++ b/usr/klibc/arch/arm/MCONFIG |
17 | @@ -29,6 +29,7 @@ else | 17 | @@ -27,6 +27,7 @@ else |
18 | KLIBCSHAREDFLAGS = -Ttext-segment 0x01800000 | 18 | KLIBCSHAREDFLAGS = $(LD_IMAGE_BASE_OPT) 0x01800000 |
19 | ifeq ($(CONFIG_AEABI),y) | 19 | ifeq ($(CONFIG_AEABI),y) |
20 | KLIBCREQFLAGS += -mabi=aapcs-linux -mno-thumb-interwork | 20 | KLIBCREQFLAGS += -mabi=aapcs-linux -mno-thumb-interwork |
21 | +KLIBCLDFLAGS += $(FIX_ARMV4_EABI_BX) | 21 | +KLIBCLDFLAGS += $(FIX_ARMV4_EABI_BX) |
diff --git a/meta-initramfs/recipes-devtools/klibc/files/cross-clang.patch b/meta-initramfs/recipes-devtools/klibc/files/cross-clang.patch index 69799c5c7..41936c9fe 100644 --- a/meta-initramfs/recipes-devtools/klibc/files/cross-clang.patch +++ b/meta-initramfs/recipes-devtools/klibc/files/cross-clang.patch | |||
@@ -6,7 +6,7 @@ | |||
6 | -I$(KLIBCOBJ)/../include \ | 6 | -I$(KLIBCOBJ)/../include \ |
7 | - -I$(KLIBCINC) | 7 | - -I$(KLIBCINC) |
8 | -ifeq ($(cc-name),clang) | 8 | -ifeq ($(cc-name),clang) |
9 | -KLIBCCPPFLAGS += -I$(shell $(KLIBCCC) $(KLIBCCFLAGS) --print-file-name=include) | 9 | -KLIBCCPPFLAGS += -isystem $(shell $(KLIBCCC) $(KLIBCCFLAGS) --print-file-name=include) |
10 | -endif | 10 | -endif |
11 | + -I$(KLIBCINC) \ | 11 | + -I$(KLIBCINC) \ |
12 | + -I$(shell $(KLIBCCC) $(KLIBCCFLAGS) --print-file-name=include) | 12 | + -I$(shell $(KLIBCCC) $(KLIBCCFLAGS) --print-file-name=include) |
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.8.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.10.bb index 4011aa231..4011aa231 100644 --- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.8.bb +++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_2.0.10.bb | |||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_2.0.8.bb b/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_2.0.10.bb index 0de580781..0de580781 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_2.0.8.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_2.0.10.bb | |||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-utils_2.0.8.bb b/meta-initramfs/recipes-devtools/klibc/klibc-utils_2.0.10.bb index 2f26093cb..2f26093cb 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-utils_2.0.8.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc-utils_2.0.10.bb | |||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc index ceb4f5ad3..4c915af2f 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc.inc +++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc | |||
@@ -10,7 +10,6 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/libs/klibc/2.0/klibc-${PV}.tar.xz \ | |||
10 | ${ARMPATCHES} \ | 10 | ${ARMPATCHES} \ |
11 | file://klcc-consider-sysroot.patch \ | 11 | file://klcc-consider-sysroot.patch \ |
12 | file://klcc-cross-accept-clang-options.patch \ | 12 | file://klcc-cross-accept-clang-options.patch \ |
13 | file://0001-dash-Specify-format-string-in-fmtstr.patch \ | ||
14 | file://0001-Define-in_-structs-for-non-glibc-system-libs.patch \ | 13 | file://0001-Define-in_-structs-for-non-glibc-system-libs.patch \ |
15 | file://0001-include-linux-sysinfo.h-directly.patch \ | 14 | file://0001-include-linux-sysinfo.h-directly.patch \ |
16 | file://0001-mkfifo-Implement-mkfifo.patch \ | 15 | file://0001-mkfifo-Implement-mkfifo.patch \ |
@@ -28,7 +27,7 @@ ARMPATCHES ?= "" | |||
28 | ARMPATCHES:arm = " \ | 27 | ARMPATCHES:arm = " \ |
29 | file://armv4-fix-v4bx.patch \ | 28 | file://armv4-fix-v4bx.patch \ |
30 | " | 29 | " |
31 | SRC_URI[sha256sum] = "4e48f1398cfe3ce0b6df55ce6e70acf54fc8488e3aea3fb3610ee1622d9cb436" | 30 | SRC_URI[sha256sum] = "662753da8889e744dfc0db6eb4021c3377ee7ef8ed66d7d57765f8c9e25939cd" |
32 | 31 | ||
33 | S = "${WORKDIR}/klibc-${PV}" | 32 | S = "${WORKDIR}/klibc-${PV}" |
34 | 33 | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc_2.0.8.bb b/meta-initramfs/recipes-devtools/klibc/klibc_2.0.10.bb index 8dda9a8cd..8dda9a8cd 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc_2.0.8.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc_2.0.10.bb | |||