summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2015-09-24 00:29:28 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:27:52 +0200
commit2cbfbf994475a0b078f1ec5f4be2afed817f3a05 (patch)
treee2626db696a2ee13546f5d5c57b46d8155c561e2 /meta-initramfs
parent9ea39b81e2eaead10480383206f0e741df455843 (diff)
downloadmeta-openembedded-2cbfbf994475a0b078f1ec5f4be2afed817f3a05.tar.gz
kexecboot_0.6: fix build with gcc 5
Resolving the issue: rgb.h:55:1: warning: inline function 'rgba2comp' declared but never defined | rgba2comp(kx_rgba rgba, kx_ccomp *red, kx_ccomp *green, | ^ Fix C99 inline semantic as documented here: https://gcc.gnu.org/gcc-5/porting_to.html Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/files/0005-rgb.h-fix-build-with-gcc5.patch34
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb2
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0005-rgb.h-fix-build-with-gcc5.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0005-rgb.h-fix-build-with-gcc5.patch
new file mode 100644
index 000000000..e451435dc
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/files/0005-rgb.h-fix-build-with-gcc5.patch
@@ -0,0 +1,34 @@
1From b2c4fc69868a4831ec798ad98f5e7fce200cf0e3 Mon Sep 17 00:00:00 2001
2From: Andrea Adami <andrea.adami@gmail.com>
3Date: Thu, 24 Sep 2015 00:02:48 +0200
4Subject: [PATCH] rgb.h: fix build with gcc 5 (C99 inline semantic)
5
6Building with gcc 5.2 we trigger the following error:
7
8rgb.h:55:1: warning: inline function 'rgba2comp' declared but never defined
9| rgba2comp(kx_rgba rgba, kx_ccomp *red, kx_ccomp *green,
10| ^
11
12https://gcc.gnu.org/gcc-5/porting_to.html
13
14Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
15---
16 rgb.h | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/rgb.h b/rgb.h
20index 0ba987a..4f64622 100644
21--- a/rgb.h
22+++ b/rgb.h
23@@ -51,7 +51,7 @@ typedef struct {
24 } kx_named_color;
25
26 /* Convert RGBA uint32 to red/green/blue/alpha components */
27-inline void
28+extern inline void
29 rgba2comp(kx_rgba rgba, kx_ccomp *red, kx_ccomp *green,
30 kx_ccomp *blue, kx_ccomp *alpha);
31
32--
331.9.1
34
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
index 9061c272f..3397c2950 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
@@ -47,6 +47,8 @@ SRC_URI += "\
47 file://0002-kexecboot-fix-configure-warnings.patch \ 47 file://0002-kexecboot-fix-configure-warnings.patch \
48 file://0003-kexecboot-do-not-hardcode-MOUNTPOINT.patch \ 48 file://0003-kexecboot-do-not-hardcode-MOUNTPOINT.patch \
49 file://0004-kexecboot.c-workaround-for-absolute-kernel-and-initr.patch \ 49 file://0004-kexecboot.c-workaround-for-absolute-kernel-and-initr.patch \
50 \
51 file://0005-rgb.h-fix-build-with-gcc5.patch \
50 " 52 "
51 53
52inherit autotools 54inherit autotools