diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2012-02-21 00:21:56 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-22 09:40:26 +0100 |
commit | 31f161628e122207426bffbec40b4e5c14ee9c4d (patch) | |
tree | cb1c1c1f07a8cced8f0ba0682c8df8ff44468734 /meta-initramfs | |
parent | efeb92404138e72b67c5d3100211e3dbabb84c76 (diff) | |
download | meta-openembedded-31f161628e122207426bffbec40b4e5c14ee9c4d.tar.gz |
meta-initramfs: add kexecboot recipes from meta-handheld
* (purged from device specific settings)
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs')
4 files changed, 136 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb new file mode 100644 index 0000000000..84c1116e33 --- /dev/null +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "Configuration file for kexecboot" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" | ||
5 | |||
6 | PR = "r13" | ||
7 | |||
8 | INHIBIT_DEFAULT_DEPS = "1" | ||
9 | |||
10 | SRC_URI = "file://icon.xpm" | ||
11 | |||
12 | CMDLINE ?= "" | ||
13 | CMDLINE_DEBUG ?= "${@base_conditional('DISTRO_TYPE', 'release', 'quiet', 'debug',d)}" | ||
14 | |||
15 | # Note: for qvga the label is currently limited to about 24 chars | ||
16 | KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}" | ||
17 | |||
18 | do_configure_prepend () { | ||
19 | install -m 0644 ${WORKDIR}/icon.xpm ${S} | ||
20 | } | ||
21 | |||
22 | do_install_prepend () { | ||
23 | echo '# First kernel stanza. | ||
24 | # Specify full kernel path on target. | ||
25 | KERNEL=/boot/${KERNEL_IMAGETYPE} | ||
26 | |||
27 | # Show this label in kexecboot menu. | ||
28 | LABEL=${KEXECBOOT_LABEL} | ||
29 | # | ||
30 | # Append this tags to the kernel cmdline. | ||
31 | APPEND=${CMDLINE} ${CMDLINE_DEBUG} | ||
32 | # | ||
33 | # Specify optional initrd/initramfs. | ||
34 | # INITRD=/boot/initramfs.cpio.gz | ||
35 | # | ||
36 | # Specify full path for a custom icon for the menu-item. | ||
37 | # If not set, use device-icons as default (NAND, SD, CF, ...). | ||
38 | # ICON=/boot/icon.xpm | ||
39 | # | ||
40 | # Priority of item in kexecboot menu. | ||
41 | # Items with highest priority will be shown at top of menu. | ||
42 | # Default: 0 (lowest, ordered by device ordering) | ||
43 | # PRIORITY=10 | ||
44 | # | ||
45 | # | ||
46 | # Second kernel stanza. | ||
47 | # KERNEL=/boot/${KERNEL_IMAGETYPE}-test | ||
48 | # LABEL=${DISTRO}-${MACHINE}-test | ||
49 | # APPEND=${CMDLINE} | ||
50 | #' >> ${S}/boot.cfg | ||
51 | } | ||
52 | |||
53 | do_install () { | ||
54 | install -d ${D}/boot | ||
55 | install -m 0644 boot.cfg ${D}/boot/boot.cfg | ||
56 | install -m 0644 icon.xpm ${D}/boot/icon.xpm | ||
57 | } | ||
58 | |||
59 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
60 | |||
61 | FILES_${PN} += "/boot/*" | ||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb new file mode 100644 index 0000000000..0d6d00f6f1 --- /dev/null +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | RDEPENDS_${PN} = "kexec-klibc" | ||
2 | PV = "0.5.9" | ||
3 | PR = "r8+gitr${SRCREV}" | ||
4 | |||
5 | SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git " | ||
6 | SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7" | ||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | # the binary is statically linked against klibc | ||
10 | inherit klibc | ||
11 | |||
12 | require kexecboot.inc | ||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc new file mode 100644 index 0000000000..a205904e4f --- /dev/null +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc | |||
@@ -0,0 +1,54 @@ | |||
1 | ########################### | ||
2 | # Configure options: | ||
3 | # | ||
4 | # --enable-static-linking compile kexecboot as static executable [default=no] | ||
5 | # --enable-fbui support framebuffer menu [default=yes] | ||
6 | # --enable-fbui-width limit FB UI width to specified value [default=no] | ||
7 | # --enable-fbui-height limit FB UI height to specified value [default=no] | ||
8 | # --enable-textui support console text user interface [default=no] | ||
9 | # --enable-cfgfiles support config files [default=yes] | ||
10 | # --enable-icons support custom icons (depends on fbui) [default=yes] | ||
11 | # --enable-zaurus compile Sharp Zaurus specific code [default=no] | ||
12 | # --enable-zimage compile with zImage support [default=yes] | ||
13 | # --enable-uimage compile with uImage support [default=no] | ||
14 | # --enable-machine-kernel look for machine-specific zImage kernel [default=no] | ||
15 | # --enable-devices-recreating | ||
16 | # enable devices re-creating [default=yes] | ||
17 | # --enable-debug enable debug output [default=no] | ||
18 | # --enable-host-debug allow for non-destructive executing of kexecboot on | ||
19 | # host system [default=no] | ||
20 | # --enable-numkeys enable menu item selection by keys [0-9] [default=yes] | ||
21 | # --enable-bg-buffer enable buffer for pre-drawed FB GUI background | ||
22 | # | ||
23 | # --enable-timeout allow to boot 1st kernel after timeout in seconds | ||
24 | # [default=no] | ||
25 | # --enable-delay specify delay before device scanning, allowing | ||
26 | # initialization of old CF/SD cards [default=1] | ||
27 | # --enable-bpp enable support of specified bpp modes | ||
28 | # (all,32,24,18,16,4,2,1) [default=all] | ||
29 | # --enable-evdev-rate change evdev (keyboard/mouse) repeat rate | ||
30 | # in milliseconds e.g. "1000,250" [default=no] | ||
31 | # --with-kexec-binary look for kexec binary at path | ||
32 | # [default="/usr/sbin/kexec"] | ||
33 | ########################## | ||
34 | LICENSE = "GPLv2" | ||
35 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
36 | inherit autotools | ||
37 | |||
38 | EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250" | ||
39 | |||
40 | do_install () { | ||
41 | install -d ${D}${bindir} | ||
42 | install -m 0755 kexecboot ${D}${bindir}/ | ||
43 | install -d ${D}/proc | ||
44 | install -d ${D}/mnt | ||
45 | install -d ${D}/dev | ||
46 | } | ||
47 | |||
48 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
49 | |||
50 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev" | ||
51 | |||
52 | pkg_postinst_${PN} () { | ||
53 | ln -sf ${bindir}/kexecboot $D/init | ||
54 | } | ||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb new file mode 100644 index 0000000000..13414615b6 --- /dev/null +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | RDEPENDS_${PN} = "kexec" | ||
2 | PV = "0.5.9" | ||
3 | PR = "r8+gitr${SRCREV}" | ||
4 | |||
5 | SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git " | ||
6 | SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7" | ||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | require kexecboot.inc | ||