summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2012-05-13 23:01:00 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-14 16:02:01 +0200
commit2490c44e51fcd83ea9f5ebd0f195e58499c02224 (patch)
tree0312a287c1241c9d2ba533c833674a97b4d013a2 /meta-initramfs
parentfbfa12572611748c87c8d1f63aab5ae355b86571 (diff)
downloadmeta-openembedded-2490c44e51fcd83ea9f5ebd0f195e58499c02224.tar.gz
klibc_1.5.26: now build against linux-libc-headers
* add install-patch creating symlinks as done by debian * extra add the mtd headers * refresh patches (split out prefix.patch) * recipe is now not machine-specific anymore * bump INC_PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.26.bb2
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/klibc-linux-libc-dev.patch23
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/prefix.patch14
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/staging.patch23
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc.inc13
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc_1.5.26.bb16
6 files changed, 53 insertions, 38 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.26.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.26.bb
index ad7c07e8c..5a6739d4e 100644
--- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.26.bb
+++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.26.bb
@@ -14,7 +14,7 @@ FILESPATH =. "${FILE_DIRNAME}/klibc-${PV}:"
14# ${TARGET_PREFIX}klcc is just a 14# ${TARGET_PREFIX}klcc is just a
15# perl wrapper around gcc-cross 15# perl wrapper around gcc-cross
16# so give it the same arch and path 16# so give it the same arch and path
17PACKAGE_ARCH = "${TUNE_PKGARCH}" 17#PACKAGE_ARCH = "${TUNE_PKGARCH}"
18 18
19inherit cross 19inherit cross
20 20
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/klibc-linux-libc-dev.patch b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/klibc-linux-libc-dev.patch
new file mode 100644
index 000000000..3c55e1482
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/klibc-linux-libc-dev.patch
@@ -0,0 +1,23 @@
1commit 43adf69062254fb4f8d4d11fb5fe36a60ae25d5a
2Author: Ben Hutchings <ben@decadent.org.uk>
3Date: Sun Mar 14 18:41:56 2010 +0000
4
5 Taken from debian "Fix klibc Debian specific build trouble"
6
7Index: klibc-2.0~rc2/scripts/Kbuild.install
8===================================================================
9--- klibc-2.0~rc2.orig/scripts/Kbuild.install 2012-02-11 18:50:21.000000000 +0000
10+++ klibc-2.0~rc2/scripts/Kbuild.install 2012-02-11 19:04:52.000000000 +0000
11@@ -95,8 +95,11 @@
12 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
13 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)lib
14 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)bin
15- $(Q)$(MAKE) -C $(KLIBCKERNELSRC) ARCH=$(KLIBCARCH) INSTALL_HDR_PATH=$(INSTALLROOT)$(INSTALLDIR)/$(KCROSS) headers_install
16+ $(Q)for x in $(KLIBCKERNELSRC)/include/asm $(KLIBCKERNELSRC)/include/asm* $(KLIBCKERNELSRC)/include/linux $(KLIBCKERNELSRC)/include/mtd; do \
17+ ln -sf $${x} $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/ || exit; \
18+ done
19 $(Q)cp -rf usr/include/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/.
20+ $(Q)chmod -R a+rX $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
21 $(Q)$(install-data) $(srctree)/klcc/klcc.1 $(INSTALLROOT)$(mandir)/man1/$(KCROSS)klcc.1
22 $(Q)$(install-bin) $(objtree)/klcc/$(KCROSS)klcc $(INSTALLROOT)$(bindir)
23
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/prefix.patch b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/prefix.patch
new file mode 100644
index 000000000..6f5ff0d60
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/prefix.patch
@@ -0,0 +1,14 @@
1Index: klibc-1.5.24/Makefile
2===================================================================
3--- a/Makefile 2011-07-27 15:50:53.000000000 +0200
4+++ b/Makefile 2011-08-01 00:47:56.000000000 +0200
5@@ -39,7 +39,7 @@
6 export PERL := perl
7
8 # Location for installation
9-export prefix = /usr
10+export prefix = $(INST)
11 export bindir = $(prefix)/bin
12 export libdir = $(prefix)/lib
13 export mandir = $(prefix)/man
14
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/staging.patch b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/staging.patch
index cedd5e639..03955f25c 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/staging.patch
+++ b/meta-initramfs/recipes-devtools/klibc/klibc-1.5.26/staging.patch
@@ -6,25 +6,11 @@ Signed-off-by: Thomas Kunze <thommycheck@gmx.de>
6Minor edits following upstream changes 6Minor edits following upstream changes
7Signed-off-by: Andrea Adami <andrea.adami@gmail.com> 7Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
8 8
9Index: klibc-1.5.24/Makefile
10===================================================================
11--- a/Makefile 2011-07-27 15:50:53.000000000 +0200
12+++ b/Makefile 2011-08-01 00:47:56.000000000 +0200
13@@ -39,7 +39,7 @@
14 export PERL := perl
15
16 # Location for installation
17-export prefix = /usr
18+export prefix = $(INST)
19 export bindir = $(prefix)/bin
20 export libdir = $(prefix)/lib
21 export mandir = $(prefix)/man
22
23Index: klibc-1.5.24/scripts/Kbuild.install 9Index: klibc-1.5.24/scripts/Kbuild.install
24=================================================================== 10===================================================================
25--- a/scripts/Kbuild.install 2011-07-27 15:50:53.000000000 +0200 11--- a/scripts/Kbuild.install 2011-07-27 15:50:53.000000000 +0200
26+++ b/scripts/Kbuild.install 2011-08-01 00:03:03.000000000 +0200 12+++ b/scripts/Kbuild.install 2011-08-01 00:03:03.000000000 +0200
27@@ -88,16 +88,12 @@ 13@@ -88,13 +88,10 @@
28 header: 14 header:
29 $(Q)echo " INSTALL headers + man pages to $(INSTALLROOT)$(INSTALLDIR)" 15 $(Q)echo " INSTALL headers + man pages to $(INSTALLROOT)$(INSTALLDIR)"
30 $(Q)mkdir -p $(INSTALLROOT)$(bindir) 16 $(Q)mkdir -p $(INSTALLROOT)$(bindir)
@@ -35,8 +21,13 @@ Index: klibc-1.5.24/scripts/Kbuild.install
35 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include 21 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
36 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)lib 22 $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)lib
37- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)bin 23- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)bin
38 $(Q)$(MAKE) -C $(KLIBCKERNELSRC) ARCH=$(KLIBCARCH) INSTALL_HDR_PATH=$(INSTALLROOT)$(INSTALLDIR)/$(KCROSS) headers_install 24 $(Q)for x in $(KLIBCKERNELSRC)/include/asm $(KLIBCKERNELSRC)/include/asm* $(KLIBCKERNELSRC)/include/linux $(KLIBCKERNELSRC)/include/mtd; do \
25 ln -sf $${x} $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/ || exit; \
26 done
27@@ -103,7 +100,6 @@
28 done
39 $(Q)cp -rf usr/include/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/. 29 $(Q)cp -rf usr/include/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/.
30 $(Q)chmod -R a+rX $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
40- $(Q)$(install-data) $(srctree)/klcc/klcc.1 $(INSTALLROOT)$(mandir)/man1/$(KCROSS)klcc.1 31- $(Q)$(install-data) $(srctree)/klcc/klcc.1 $(INSTALLROOT)$(mandir)/man1/$(KCROSS)klcc.1
41 $(Q)$(install-bin) $(objtree)/klcc/$(KCROSS)klcc $(INSTALLROOT)$(bindir) 32 $(Q)$(install-bin) $(objtree)/klcc/$(KCROSS)klcc $(INSTALLROOT)$(bindir)
42 33
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc
index 195f089e4..f89af9de6 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc.inc
+++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc
@@ -1,4 +1,4 @@
1DEPENDS = "virtual/kernel perl-native" 1DEPENDS = "linux-libc-headers perl-native"
2SECTION = "libs" 2SECTION = "libs"
3DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \ 3DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \
4use with initramfs. It is deliberately written for small size, \ 4use with initramfs. It is deliberately written for small size, \
@@ -6,13 +6,11 @@ minimal entaglement, and portability, not speed."
6LICENSE = "BSD-3-Clause & GPL-2.0 & MIT & Zlib" 6LICENSE = "BSD-3-Clause & GPL-2.0 & MIT & Zlib"
7LIC_FILES_CHKSUM = "file://usr/klibc/LICENSE;md5=d75181f10e998c21eb147f6d2e43ce8b" 7LIC_FILES_CHKSUM = "file://usr/klibc/LICENSE;md5=d75181f10e998c21eb147f6d2e43ce8b"
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11# Prevents do_package failures with: 9# Prevents do_package failures with:
12# debugsources.list: No such file or directory: 10# debugsources.list: No such file or directory:
13INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 11INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
14 12
15INC_PR = "r0" 13INC_PR = "r1"
16 14
17KLIBC_ARCH = '${TARGET_ARCH}' 15KLIBC_ARCH = '${TARGET_ARCH}'
18KLIBC_ARCH_armeb = 'arm' 16KLIBC_ARCH_armeb = 'arm'
@@ -30,9 +28,11 @@ SRC_URI_append_linux-gnueabi = " file://klibc-config-eabi.patch"
30SRC_URI_append_linux-uclibceabi = " file://klibc-config-eabi.patch" 28SRC_URI_append_linux-uclibceabi = " file://klibc-config-eabi.patch"
31 29
32SRC_URI += "file://fstype-sane-vfat-and-jffs2-for-1.5.patch \ 30SRC_URI += "file://fstype-sane-vfat-and-jffs2-for-1.5.patch \
31 file://klibc-linux-libc-dev.patch \
33 file://modprobe.patch \ 32 file://modprobe.patch \
34 file://dash_readopt.patch \ 33 file://dash_readopt.patch \
35 file://wc.patch \ 34 file://wc.patch \
35 file://prefix.patch \
36 file://staging.patch \ 36 file://staging.patch \
37 file://kernel_3.2__aligned_u64.patch \ 37 file://kernel_3.2__aligned_u64.patch \
38 " 38 "
@@ -41,9 +41,10 @@ S = "${WORKDIR}/git"
41 41
42EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \ 42EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \
43 'CROSS_COMPILE=${TARGET_PREFIX}' \ 43 'CROSS_COMPILE=${TARGET_PREFIX}' \
44 'KLIBCKERNELSRC=${STAGING_KERNEL_DIR}' \ 44 'KLIBCKERNELSRC=${STAGING_DIR_TARGET}/${exec_prefix}' \
45 " 45 "
46 46
47do_configure () { 47do_configure () {
48 ln -sf ${STAGING_KERNEL_DIR} linux 48
49 ln -sf "${STAGING_DIR_TARGET}/${exec_prefix}" linux
49} 50}
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc_1.5.26.bb b/meta-initramfs/recipes-devtools/klibc/klibc_1.5.26.bb
index c583fdc4f..101ba555e 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc_1.5.26.bb
+++ b/meta-initramfs/recipes-devtools/klibc/klibc_1.5.26.bb
@@ -2,23 +2,9 @@ PR = "${INC_PR}.0"
2 2
3export INST = "${D}" 3export INST = "${D}"
4 4
5do_compile_prepend() {
6
7 # after kernel 3.1 the headers are moved in /generated
8 if [ ! -e ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/bitsperlong.h ]
9 then
10 ln -sf ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/generated/asm/bitsperlong.h ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/bitsperlong.h
11 ln -sf ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/generated/asm/errno.h ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/errno.h
12 ln -sf ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/generated/asm/ioctl.h ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/ioctl.h
13 ln -sf ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/generated/asm/poll.h ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/poll.h
14 ln -sf ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/generated/asm/resource.h ${STAGING_KERNEL_DIR}/arch/${TARGET_ARCH}/include/asm/resource.h
15 fi
16
17}
18
19do_install() { 5do_install() {
20 6
21 oe_runmake install 7 oe_runmake DESTDIR="${D}" install
22 8
23 # the crosscompiler is packaged by klcc-cross 9 # the crosscompiler is packaged by klcc-cross
24 # remove klcc 10 # remove klcc