summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-10-10 23:26:25 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-11 00:27:39 +0100
commite25a3b60e4a9d6c99c03417f28a8c8d5e9e07016 (patch)
tree38e4395a0892cc2154c0afbdaaa13c80b29e1a9f /meta-initramfs
parent0eaa9888882dcf393f7244578854baf8c2d8a4cf (diff)
downloadmeta-openembedded-e25a3b60e4a9d6c99c03417f28a8c8d5e9e07016.tar.gz
kexecboot_cfg: process with oe-stylize.py
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb19
1 files changed, 8 insertions, 11 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
index af3320f8a..ff91b201e 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
@@ -3,23 +3,13 @@ DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base" 3SECTION = "base"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r14" 6PR = "r14"
8 7
9INHIBIT_DEFAULT_DEPS = "1"
10
11SRC_URI = "file://icon.xpm" 8SRC_URI = "file://icon.xpm"
12 9
13CMDLINE ?= ""
14CMDLINE_DEBUG ?= "quiet"
15
16# Note: for qvga the label is currently limited to about 24 chars
17KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"
18
19do_configure_prepend () { 10do_configure_prepend () {
20 install -m 0644 ${WORKDIR}/icon.xpm ${S} 11 install -m 0644 ${WORKDIR}/icon.xpm ${S}
21} 12}
22
23do_install_prepend () { 13do_install_prepend () {
24echo '# /boot/boot.cfg - KEXECBOOT configuration file. 14echo '# /boot/boot.cfg - KEXECBOOT configuration file.
25# 15#
@@ -53,7 +43,6 @@ APPEND=${CMDLINE} ${CMDLINE_DEBUG}
53# APPEND=${CMDLINE} 43# APPEND=${CMDLINE}
54#' > ${S}/boot.cfg 44#' > ${S}/boot.cfg
55} 45}
56
57do_install () { 46do_install () {
58 install -d ${D}/boot 47 install -d ${D}/boot
59 install -m 0644 boot.cfg ${D}/boot/boot.cfg 48 install -m 0644 boot.cfg ${D}/boot/boot.cfg
@@ -63,3 +52,11 @@ do_install () {
63PACKAGE_ARCH = "${MACHINE_ARCH}" 52PACKAGE_ARCH = "${MACHINE_ARCH}"
64 53
65FILES_${PN} += "/boot/*" 54FILES_${PN} += "/boot/*"
55
56CMDLINE ?= ""
57CMDLINE_DEBUG ?= "quiet"
58
59INHIBIT_DEFAULT_DEPS = "1"
60
61# Note: for qvga the label is currently limited to about 24 chars
62KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"