diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-13 23:44:35 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-14 00:00:20 -0800 |
commit | c332ab143f64053187e75e001c8a005e142bfe9e (patch) | |
tree | 59e8df829cc5265e62895a37545b2eb5c5c8f8c9 /meta-initramfs/recipes-kernel | |
parent | ab5c58ffdc5910f49d6d015e2b504b36aff89b1f (diff) | |
download | meta-openembedded-c332ab143f64053187e75e001c8a005e142bfe9e.tar.gz |
kexec-tools-klibc: Use SITEINFO_BITS to construct includepath
This helps getting rid of per arch overrides
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-kernel')
-rw-r--r-- | meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb | 15 |
1 files changed, 3 insertions, 12 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb index c49b24f52..656162fb1 100644 --- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb +++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_git.bb | |||
@@ -10,7 +10,7 @@ PV = "2.0.18+git${SRCPV}" | |||
10 | 10 | ||
11 | DEPENDS = "zlib xz" | 11 | DEPENDS = "zlib xz" |
12 | 12 | ||
13 | inherit klibc autotools | 13 | inherit klibc autotools siteinfo |
14 | 14 | ||
15 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git" | 15 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git" |
16 | SRCREV = "5750980cdbbc33ef75bfba6660295b932376ce15" | 16 | SRCREV = "5750980cdbbc33ef75bfba6660295b932376ce15" |
@@ -66,17 +66,8 @@ EXTRA_OECONF += "--without-zlib --without-lzma --without-xen" | |||
66 | 66 | ||
67 | # fix purgatory/printf.c:2:10: fatal error: limits.h: No such file or directory | 67 | # fix purgatory/printf.c:2:10: fatal error: limits.h: No such file or directory |
68 | # fix include/limits.h:42:10: fatal error: bitsize/limits.h: No such file or directory | 68 | # fix include/limits.h:42:10: fatal error: bitsize/limits.h: No such file or directory |
69 | COMMON_CFLAGS += "-O2 -I${STAGING_DIR_HOST}${libdir}/klibc/include -I${S}/purgatory/include" | 69 | CFLAGS += "-O2 -I${STAGING_DIR_HOST}${libdir}/klibc/include -I${S}/purgatory/include \ |
70 | CFLAGS_x86_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" | 70 | -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits${SITEINFO_BITS}" |
71 | CFLAGS_x86-64_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" | ||
72 | CFLAGS_arm_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" | ||
73 | CFLAGS_aarch64_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" | ||
74 | CFLAGS_mips_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" | ||
75 | CFLAGS_mipsel_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" | ||
76 | CFLAGS_mips64_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" | ||
77 | CFLAGS_mips64el_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64" | ||
78 | CFLAGS_powerpc_append = " ${COMMON_CFLAGS} -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32" | ||
79 | |||
80 | 71 | ||
81 | do_compile_prepend() { | 72 | do_compile_prepend() { |
82 | # Remove the prepackaged config.h from the source tree as it overrides | 73 | # Remove the prepackaged config.h from the source tree as it overrides |