diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2018-08-21 17:02:37 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-21 10:36:04 -0700 |
commit | 4edac5919f4e4879313d391bffcac3562fbea39f (patch) | |
tree | 9c0894839797d2d13c11cf73d711208231f9b08e /meta-initramfs/recipes-kernel | |
parent | bdded3422e7d58298c3598df6422902db42a04e4 (diff) | |
download | meta-openembedded-4edac5919f4e4879313d391bffcac3562fbea39f.tar.gz |
kexec-tools-klibc: rework Makefile patch for purgatory
Replace previous hack, wrap linker LDFLAGS for compatibility with
klcc.
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-kernel')
-rw-r--r-- | meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch | 33 |
1 files changed, 14 insertions, 19 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch index 0ae2be77d..a459d45a2 100644 --- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch +++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch | |||
@@ -1,17 +1,16 @@ | |||
1 | From fa3844ce6ce95f2db142b6c77f077b3e704d4f6f Mon Sep 17 00:00:00 2001 | 1 | From 9b6866b106eb3ad11115bd591a23e65a68dd847d Mon Sep 17 00:00:00 2001 |
2 | From: Andrea Adami <andrea.adami@gmail.com> | 2 | From: Andrea Adami <andrea.adami@gmail.com> |
3 | Date: Tue, 17 Apr 2018 19:12:14 +0200 | 3 | Date: Tue, 21 Aug 2018 16:31:44 +0200 |
4 | Subject: [PATCH] purgatory Makefile: adapt to klcc | 4 | Subject: [PATCH 11/11] purgatory Makefile: adapt to klcc |
5 | 5 | ||
6 | Upstream-Status: Inappropriate [klibc specific] | 6 | Upstream-Status: Inappropriate [klibc specific] |
7 | Signed-off-by: Andrea Adami <andrea.adami@gmail.com> | 7 | Signed-off-by: Andrea Adami <andrea.adami@gmail.com> |
8 | |||
9 | --- | 8 | --- |
10 | purgatory/Makefile | 9 +++++---- | 9 | purgatory/Makefile | 6 +++--- |
11 | 1 file changed, 5 insertions(+), 4 deletions(-) | 10 | 1 file changed, 3 insertions(+), 3 deletions(-) |
12 | 11 | ||
13 | diff --git a/purgatory/Makefile b/purgatory/Makefile | 12 | diff --git a/purgatory/Makefile b/purgatory/Makefile |
14 | index 49ce80a..da36075 100644 | 13 | index 49ce80a..72eefaa 100644 |
15 | --- a/purgatory/Makefile | 14 | --- a/purgatory/Makefile |
16 | +++ b/purgatory/Makefile | 15 | +++ b/purgatory/Makefile |
17 | @@ -47,7 +47,7 @@ purgatory/sha256.o: $(srcdir)/util_lib/sha256.c | 16 | @@ -47,7 +47,7 @@ purgatory/sha256.o: $(srcdir)/util_lib/sha256.c |
@@ -23,21 +22,17 @@ index 49ce80a..da36075 100644 | |||
23 | -fno-zero-initialized-in-bss \ | 22 | -fno-zero-initialized-in-bss \ |
24 | -fno-PIC -fno-PIE -fno-stack-protector | 23 | -fno-PIC -fno-PIE -fno-stack-protector |
25 | 24 | ||
26 | @@ -59,13 +59,14 @@ $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \ | 25 | @@ -59,8 +59,8 @@ $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \ |
27 | -Iinclude \ | 26 | -Iinclude \ |
28 | -I$(shell $(CC) -print-file-name=include) | 27 | -I$(shell $(CC) -print-file-name=include) |
29 | $(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\ | 28 | $(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\ |
30 | - -Wl,--no-undefined -nostartfiles -nostdlib \ | 29 | - -Wl,--no-undefined -nostartfiles -nostdlib \ |
31 | + --no-undefined -nostartfiles -nostdlib \ | 30 | - -nodefaultlibs -e purgatory_start -r \ |
32 | -nodefaultlibs -e purgatory_start -r \ | 31 | + -Wl,--no-undefined -Wl,-nostartfiles -Wl,-nostdlib \ |
33 | - -Wl,-Map=$(PURGATORY_MAP) | 32 | + -Wl,-nodefaultlibs -Wl,--entry=purgatory_start -Wl,-r \ |
34 | + -Map=$(PURGATORY_MAP) | 33 | -Wl,-Map=$(PURGATORY_MAP) |
35 | 34 | ||
36 | $(PURGATORY): $(PURGATORY_OBJS) | 35 | $(PURGATORY): $(PURGATORY_OBJS) |
37 | $(MKDIR) -p $(@D) | 36 | -- |
38 | - $(CC) $(CFLAGS) $(LDFLAGS) -o $@.sym $^ | 37 | 2.7.4 |
39 | +# $(CC) $(CFLAGS) -o $@.sym $^ | 38 | |
40 | + $(LD) $(LDFLAGS) -o $@.sym $^ | ||
41 | # $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB) | ||
42 | $(STRIP) --strip-debug -o $@ $@.sym | ||
43 | |||