summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2013-05-13 01:22:23 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-05-13 09:50:24 +0100
commit97957e5cee9a797d3e05c1a8848338a033f40770 (patch)
tree59351568b51e711b80ca3fff348e61d9079eaf01 /meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
parent06318f320803814ac7f2827473a8e46a8eb0d8cb (diff)
downloadmeta-openembedded-97957e5cee9a797d3e05c1a8848338a033f40770.tar.gz
kexec-tools-klibc_2.0.2: refactor and extend patches for building
* some old patches apparently unneeded have been removed * patches are now better split * fix build for x86 and x86-64 * tested with qemuarm, qemuppc, qemumips, qemux86, qemux86-64 Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb28
1 files changed, 19 insertions, 9 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
index 90b876cdd..eedcaa557 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
@@ -7,20 +7,30 @@ inherit klibc
7 7
8FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:" 8FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
9 9
10SRC_URI += "file://elf.patch \ 10SRC_URI += " \
11 file://errno.patch \ 11 file://kexec-elf-rel.patch \
12 file://string.patch \ 12 file://kexec-syscall.patch \
13 file://syscall.patch \ 13 file://cflags_static.patch \
14 file://other.patch \ 14 file://ifdown_errno.patch \
15" 15 file://purgatory_flags.patch \
16 file://purgatory_string.patch \
17 file://sha256.patch \
18 file://sysconf_nrprocessors.patch \
19 "
20
21SRC_URI_append_arm = " file://arm_crashdump.patch"
22SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch"
23SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
24SRC_URI_append_x86-64 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
16 25
17S = "${WORKDIR}/kexec-tools-${PV}" 26S = "${WORKDIR}/kexec-tools-${PV}"
18 27
19EXTRA_OECONF += "--without-zlib" 28EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
20
21PACKAGES =+ "kexec-klibc kdump-klibc"
22 29
23CFLAGS += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits32" 30CFLAGS += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits32"
31CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${base_libdir}/klibc/include -I${STAGING_DIR_HOST}${base_libdir}/klibc/include/bits64"
32
33PACKAGES =+ "kexec-klibc kdump-klibc"
24 34
25FILES_kexec-klibc = "${sbindir}/kexec" 35FILES_kexec-klibc = "${sbindir}/kexec"
26FILES_kdump-klibc = "${sbindir}/kdump" 36FILES_kdump-klibc = "${sbindir}/kdump"