diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2012-05-29 22:12:07 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-05 10:46:54 +0200 |
commit | bb62247d601a2d853d81dc7403edfc5e3b0818c7 (patch) | |
tree | 0037cf27bb4cf2f300babd932cc251f2ee157efb /meta-initramfs/recipes-devtools | |
parent | 0dbd716b73aeac3f8b2d6b82583d8a6a4fd0b636 (diff) | |
download | meta-openembedded-bb62247d601a2d853d81dc7403edfc5e3b0818c7.tar.gz |
ubi-utils-klibc: more patch-cleanings
* remove unnecessary patches after klibc upgrades
* bump PR
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
4 files changed, 16 insertions, 79 deletions
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libiniparser.c.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libiniparser.c.patch index 8be8ac32a..45f2439c8 100644 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libiniparser.c.patch +++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libiniparser.c.patch | |||
@@ -1,13 +1,19 @@ | |||
1 | --- a/ubi-utils/libiniparser.c 2012-04-30 23:59:40.000000000 +0200 | 1 | --- a/ubi-utils/libiniparser.c 2012-05-29 23:46:08.000000000 +0200 |
2 | +++ b/ubi-utils/libiniparser.c 2012-04-30 23:55:15.000000000 +0200 | 2 | +++ b/ubi-utils/libiniparser.c 2012-05-29 23:45:01.000000000 +0200 |
3 | @@ -333,7 +333,9 @@ | 3 | @@ -327,6 +327,8 @@ |
4 | 4 | the notfound value is returned. | |
5 | str = iniparser_getstring(d, key, INI_INVALID_KEY); | 5 | */ |
6 | /*--------------------------------------------------------------------------*/ | ||
7 | +/* Floating-point is not supported in klibc */ | ||
8 | +/* | ||
9 | double iniparser_getdouble(dictionary * d, char * key, double notfound) | ||
10 | { | ||
11 | char * str ; | ||
12 | @@ -335,6 +337,7 @@ | ||
6 | if (str==INI_INVALID_KEY) return notfound ; | 13 | if (str==INI_INVALID_KEY) return notfound ; |
7 | - return atof(str); | 14 | return atof(str); |
8 | + double value; | ||
9 | + sscanf(str,"%lf",&value); | ||
10 | + return value; | ||
11 | } | 15 | } |
16 | +*/ | ||
12 | 17 | ||
13 | /*-------------------------------------------------------------------------*/ | 18 | /*-------------------------------------------------------------------------*/ |
19 | /** | ||
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libmtd.c.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libmtd.c.patch deleted file mode 100644 index f32fb70a1..000000000 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libmtd.c.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | --- a/lib/libmtd.c 2012-04-29 21:44:52.000000000 +0200 | ||
2 | +++ b/lib/libmtd.c 2012-04-29 21:43:04.000000000 +0200 | ||
3 | @@ -441,8 +441,8 @@ | ||
4 | return -1; | ||
5 | } | ||
6 | |||
7 | - major = major(st.st_rdev); | ||
8 | - minor = minor(st.st_rdev); | ||
9 | + major = __major(st.st_rdev); | ||
10 | + minor = __minor(st.st_rdev); | ||
11 | |||
12 | if (mtd_get_info((libmtd_t *)lib, &info)) | ||
13 | return -1; | ||
14 | @@ -1381,8 +1381,8 @@ | ||
15 | return -1; | ||
16 | } | ||
17 | |||
18 | - major = major(st.st_rdev); | ||
19 | - minor = minor(st.st_rdev); | ||
20 | + major = __major(st.st_rdev); | ||
21 | + minor = __minor(st.st_rdev); | ||
22 | |||
23 | if (mtd_get_info((libmtd_t *)lib, &info)) | ||
24 | return -1; | ||
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch index 8278a4fc7..db95904ea 100644 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch +++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch | |||
@@ -1,27 +1,5 @@ | |||
1 | --- a/ubi-utils/libubi.c 2012-05-01 01:57:51.000000000 +0200 | 1 | --- a/ubi-utils/libubi.c 2012-05-01 01:57:51.000000000 +0200 |
2 | +++ b/ubi-utils/libubi.c 2012-05-01 01:55:14.000000000 +0200 | 2 | +++ b/ubi-utils/libubi.c 2012-05-01 01:55:14.000000000 +0200 |
3 | @@ -382,8 +402,8 @@ | ||
4 | return errmsg("\"%s\" is not a character device", node); | ||
5 | } | ||
6 | |||
7 | - major = major(st.st_rdev); | ||
8 | - minor = minor(st.st_rdev); | ||
9 | + major = __major(st.st_rdev); | ||
10 | + minor = __minor(st.st_rdev); | ||
11 | |||
12 | if (minor == 0) { | ||
13 | errno = EINVAL; | ||
14 | @@ -448,8 +468,8 @@ | ||
15 | return errmsg("\"%s\" is not a character device", node); | ||
16 | } | ||
17 | |||
18 | - major = major(st.st_rdev); | ||
19 | - minor = minor(st.st_rdev); | ||
20 | + major = __major(st.st_rdev); | ||
21 | + minor = __minor(st.st_rdev); | ||
22 | |||
23 | if (minor != 0) { | ||
24 | errno = EINVAL; | ||
25 | @@ -686,7 +706,7 @@ | 3 | @@ -686,7 +706,7 @@ |
26 | * success and %-1 in case of failure. @r->ubi_num contains newly created UBI | 4 | * success and %-1 in case of failure. @r->ubi_num contains newly created UBI |
27 | * device number. | 5 | * device number. |
@@ -31,25 +9,3 @@ | |||
31 | { | 9 | { |
32 | int fd, ret; | 10 | int fd, ret; |
33 | 11 | ||
34 | @@ -757,8 +777,8 @@ | ||
35 | mtd_dev_node); | ||
36 | } | ||
37 | |||
38 | - major = major(sb.st_rdev); | ||
39 | - minor = minor(sb.st_rdev); | ||
40 | + major = __major(sb.st_rdev); | ||
41 | + minor = __minor(sb.st_rdev); | ||
42 | |||
43 | if (major != MTD_CHAR_MAJOR) { | ||
44 | errno = EINVAL; | ||
45 | @@ -866,8 +886,8 @@ | ||
46 | return -1; | ||
47 | } | ||
48 | |||
49 | - major = major(st.st_rdev); | ||
50 | - minor = minor(st.st_rdev); | ||
51 | + major = __major(st.st_rdev); | ||
52 | + minor = __minor(st.st_rdev); | ||
53 | |||
54 | if (ubi_get_info((libubi_t *)lib, &info)) | ||
55 | return -1; | ||
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb index f975952b2..ebdd3f6c8 100644 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb +++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb | |||
@@ -6,14 +6,13 @@ LICENSE = "GPLv2+" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
7 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" | 7 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" |
8 | 8 | ||
9 | PR = "r3" | 9 | PR = "r4" |
10 | 10 | ||
11 | inherit klibc | 11 | inherit klibc |
12 | 12 | ||
13 | SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=995cfe51b0a3cf32f381c140bf72b21bf91cef1b \ | 13 | SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=995cfe51b0a3cf32f381c140bf72b21bf91cef1b \ |
14 | file://Makefile.patch \ | 14 | file://Makefile.patch \ |
15 | file://common.mk.patch \ | 15 | file://common.mk.patch \ |
16 | file://libmtd.c.patch \ | ||
17 | file://libubi.c.patch \ | 16 | file://libubi.c.patch \ |
18 | file://libiniparser.c.patch \ | 17 | file://libiniparser.c.patch \ |
19 | file://ubiformat.c.patch \ | 18 | file://ubiformat.c.patch \ |