diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2012-02-29 01:25:24 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-02-29 09:36:27 +0100 |
commit | 4c9740b5a893255326efa62fb8dd60153f88da2d (patch) | |
tree | d8a064af757c850b05ab20effc6fdfce2564fe92 /meta-initramfs/recipes-devtools | |
parent | 08bf37116bd13d9edc1ddd185ff9d6c230eb17a2 (diff) | |
download | meta-openembedded-4c9740b5a893255326efa62fb8dd60153f88da2d.tar.gz |
klibc_1.5.25: Fetcher and QA fixes
* fix unfetchable SRC_URI and use git fetcher instead
* and remove checksums file
* adapt ${S}
* fix QA about non -staticdev package contains static .a library
* fix QA about /bin installed but not shipped
* fix license and relative QA
* bump INC_PR
* patchset untouched awaiting klibc_2.0, expected in March 2012
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
6 files changed, 9 insertions, 17 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb index 922c8d84f..ad7c07e8c 100644 --- a/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb +++ b/meta-initramfs/recipes-devtools/klibc/klcc-cross_1.5.25.bb | |||
@@ -1,7 +1,6 @@ | |||
1 | PR = "${INC_PR}.0" | 1 | PR = "${INC_PR}.0" |
2 | 2 | ||
3 | require klibc.inc | 3 | require klibc.inc |
4 | require klibc-checksums_${PV}.inc | ||
5 | 4 | ||
6 | export KLCC_INST = "${STAGING_DIR_TARGET}/lib/klibc" | 5 | export KLCC_INST = "${STAGING_DIR_TARGET}/lib/klibc" |
7 | 6 | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-checksums_1.5.25.inc b/meta-initramfs/recipes-devtools/klibc/klibc-checksums_1.5.25.inc deleted file mode 100644 index ebba6587c..000000000 --- a/meta-initramfs/recipes-devtools/klibc/klibc-checksums_1.5.25.inc +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | SRC_URI[md5sum] = "5bc4dcd63e9142b934787729133c2766" | ||
2 | SRC_URI[sha256sum] = "0b910ec0b2a97d4c775ed06e44ad7bca7be150efdf2a77a19253a573e16367d3" | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_1.5.25.bb b/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_1.5.25.bb index c9749f0d7..484134e44 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_1.5.25.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc-static-utils_1.5.25.bb | |||
@@ -14,4 +14,3 @@ FILES_${PN} = "" | |||
14 | 14 | ||
15 | require klibc-utils.inc | 15 | require klibc-utils.inc |
16 | require klibc.inc | 16 | require klibc.inc |
17 | require klibc-checksums_${PV}.inc | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-utils_1.5.25.bb b/meta-initramfs/recipes-devtools/klibc/klibc-utils_1.5.25.bb index b26dda400..37cab84c5 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc-utils_1.5.25.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc-utils_1.5.25.bb | |||
@@ -14,4 +14,3 @@ FILES_${PN} = "" | |||
14 | 14 | ||
15 | require klibc-utils.inc | 15 | require klibc-utils.inc |
16 | require klibc.inc | 16 | require klibc.inc |
17 | require klibc-checksums_${PV}.inc | ||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc index 1b1f7c626..bd365daf7 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc.inc +++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc | |||
@@ -3,7 +3,7 @@ SECTION = "libs" | |||
3 | DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \ | 3 | DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \ |
4 | use with initramfs. It is deliberately written for small size, \ | 4 | use with initramfs. It is deliberately written for small size, \ |
5 | minimal entaglement, and portability, not speed." | 5 | minimal entaglement, and portability, not speed." |
6 | LICENSE = "BSD-ADV" | 6 | LICENSE = "BSD-3-Clause & GPL-2.0 & Zlib" |
7 | LIC_FILES_CHKSUM = "file://usr/klibc/LICENSE;md5=d75181f10e998c21eb147f6d2e43ce8b" | 7 | LIC_FILES_CHKSUM = "file://usr/klibc/LICENSE;md5=d75181f10e998c21eb147f6d2e43ce8b" |
8 | 8 | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 9 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
@@ -12,7 +12,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
12 | # debugsources.list: No such file or directory: | 12 | # debugsources.list: No such file or directory: |
13 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 13 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
14 | 14 | ||
15 | INC_PR = "r0" | 15 | INC_PR = "r1" |
16 | 16 | ||
17 | KLIBC_ARCH = '${TARGET_ARCH}' | 17 | KLIBC_ARCH = '${TARGET_ARCH}' |
18 | KLIBC_ARCH_armeb = 'arm' | 18 | KLIBC_ARCH_armeb = 'arm' |
@@ -23,8 +23,8 @@ KLIBC_ARCH_i586 = 'i386' | |||
23 | KLIBC_ARCH_i686 = 'i386' | 23 | KLIBC_ARCH_i686 = 'i386' |
24 | KLIBC_ARCH_pentium = 'i386' | 24 | KLIBC_ARCH_pentium = 'i386' |
25 | 25 | ||
26 | KLIBC_FETCHDIR = "1.5" | 26 | SRCREV = "ff0a614bd724f6c4c6a5014a9955dc1bc028f336" |
27 | SRC_URI = "${KERNELORG_MIRROR}/linux/libs/klibc/${KLIBC_FETCHDIR}/klibc-${PV}.tar.bz2" | 27 | SRC_URI = "git://git.kernel.org/pub/scm/libs/klibc/klibc.git;protocol=git" |
28 | 28 | ||
29 | SRC_URI_append_linux-gnueabi = " file://klibc-config-eabi.patch" | 29 | SRC_URI_append_linux-gnueabi = " file://klibc-config-eabi.patch" |
30 | SRC_URI_append_linux-uclibceabi = " file://klibc-config-eabi.patch" | 30 | SRC_URI_append_linux-uclibceabi = " file://klibc-config-eabi.patch" |
@@ -36,7 +36,7 @@ SRC_URI += "file://fstype-sane-vfat-and-jffs2-for-1.5.patch \ | |||
36 | file://staging.patch \ | 36 | file://staging.patch \ |
37 | " | 37 | " |
38 | 38 | ||
39 | S = "${WORKDIR}/klibc-${PV}" | 39 | S = "${WORKDIR}/git" |
40 | 40 | ||
41 | EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \ | 41 | EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \ |
42 | 'CROSS_COMPILE=${TARGET_PREFIX}' \ | 42 | 'CROSS_COMPILE=${TARGET_PREFIX}' \ |
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc_1.5.25.bb b/meta-initramfs/recipes-devtools/klibc/klibc_1.5.25.bb index a313bfd77..8a5062841 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc_1.5.25.bb +++ b/meta-initramfs/recipes-devtools/klibc/klibc_1.5.25.bb | |||
@@ -8,8 +8,9 @@ do_install() { | |||
8 | 8 | ||
9 | # the crosscompiler is packaged by klcc-cross | 9 | # the crosscompiler is packaged by klcc-cross |
10 | # remove klcc | 10 | # remove klcc |
11 | # remove also from FILES_libklibc-dev | ||
12 | rm ${D}${base_bindir}/klcc | 11 | rm ${D}${base_bindir}/klcc |
12 | # remove now empty dir | ||
13 | rmdir ${D}${base_bindir} | ||
13 | 14 | ||
14 | # remove Linux headers .install and ..install.cmd files | 15 | # remove Linux headers .install and ..install.cmd files |
15 | find ${D}${base_libdir}/klibc/include -name '.install' -delete | 16 | find ${D}${base_libdir}/klibc/include -name '.install' -delete |
@@ -21,15 +22,11 @@ do_install() { | |||
21 | 22 | ||
22 | } | 23 | } |
23 | 24 | ||
24 | PACKAGES = "libklibc libklibc-dev" | 25 | PACKAGES = "libklibc libklibc-staticdev libklibc-dev" |
25 | FILES_libklibc = "${base_libdir}/klibc-*.so" | 26 | FILES_libklibc = "${base_libdir}/klibc-*.so" |
27 | FILES_libklibc-staticdev = "${base_libdir}/klibc/lib/libc.a" | ||
26 | FILES_libklibc-dev = "${base_libdir}/klibc.so \ | 28 | FILES_libklibc-dev = "${base_libdir}/klibc.so \ |
27 | ${base_libdir}/klibc/lib/* \ | 29 | ${base_libdir}/klibc/lib/* \ |
28 | ${base_libdir}/klibc/include/* \ | 30 | ${base_libdir}/klibc/include/* \ |
29 | " | 31 | " |
30 | # see above | ||
31 | # do not package it in -dev | ||
32 | # ${base_bindir}/klcc \ | ||
33 | |||
34 | require klibc.inc | 32 | require klibc.inc |
35 | require klibc-checksums_${PV}.inc | ||