diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2012-06-27 22:49:21 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-07-11 15:04:04 +0200 |
commit | 2f9d8fef13e592d232a9bec3c1eb7c59fe048878 (patch) | |
tree | a0c4034def41e4f85f55394448f6786534f9d411 /meta-initramfs/recipes-devtools/mtd | |
parent | 9af2bd13c63655744785950a411a40f2848a9f3f (diff) | |
download | meta-openembedded-2f9d8fef13e592d232a9bec3c1eb7c59fe048878.tar.gz |
ubi-utils-klibc: update to patched v. 1.5.0
* Fix build failing because of UBI_IOCSETPROP -> UBI_IOCSETVOLPROP renaming.
* This patch follows the one in oe-core for mtd-utils_1.5.0
* which was staging an older version of the ubi-user.h header.
* We need to match the renaming done in kernel 3.0
* http://lists.infradead.org/pipermail/linux-mtd/2011-March/
* 034419.html
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs/recipes-devtools/mtd')
-rw-r--r-- | meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch | 17 | ||||
-rw-r--r-- | meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.5.0.bb (renamed from meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb) | 6 |
2 files changed, 20 insertions, 3 deletions
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch index db95904ea..b52e20789 100644 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch +++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/libubi.c.patch | |||
@@ -9,3 +9,20 @@ | |||
9 | { | 9 | { |
10 | int fd, ret; | 10 | int fd, ret; |
11 | 11 | ||
12 | @@ -1346,13 +1346,13 @@ | ||
13 | |||
14 | int ubi_set_property(int fd, uint8_t property, uint64_t value) | ||
15 | { | ||
16 | - struct ubi_set_prop_req r; | ||
17 | + struct ubi_set_vol_prop_req r; | ||
18 | |||
19 | - memset(&r, 0, sizeof(struct ubi_set_prop_req)); | ||
20 | + memset(&r, 0, sizeof(struct ubi_set_vol_prop_req)); | ||
21 | r.property = property; | ||
22 | r.value = value; | ||
23 | |||
24 | - return ioctl(fd, UBI_IOCSETPROP, &r); | ||
25 | + return ioctl(fd, UBI_IOCSETVOLPROP, &r); | ||
26 | } | ||
27 | |||
28 | int ubi_leb_unmap(int fd, int lnum) | ||
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.5.0.bb index ebdd3f6c8..5cdd984b2 100644 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.4.9.bb +++ b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc_1.5.0.bb | |||
@@ -6,11 +6,11 @@ LICENSE = "GPLv2+" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
7 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" | 7 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" |
8 | 8 | ||
9 | PR = "r4" | 9 | PR = "r0" |
10 | 10 | ||
11 | inherit klibc | 11 | inherit klibc |
12 | 12 | ||
13 | SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=995cfe51b0a3cf32f381c140bf72b21bf91cef1b \ | 13 | SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=ca39eb1d98e736109c64ff9c1aa2a6ecca222d8f \ |
14 | file://Makefile.patch \ | 14 | file://Makefile.patch \ |
15 | file://common.mk.patch \ | 15 | file://common.mk.patch \ |
16 | file://libubi.c.patch \ | 16 | file://libubi.c.patch \ |
@@ -20,7 +20,7 @@ SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=995cfe51b0a3cf | |||
20 | 20 | ||
21 | S = "${WORKDIR}/git/" | 21 | S = "${WORKDIR}/git/" |
22 | 22 | ||
23 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}include -I${S}ubi-utils/include -DWITHOUT_XATTR' 'BUILDDIR=${S}'" | 23 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}include -DWITHOUT_XATTR' 'BUILDDIR=${S}'" |
24 | 24 | ||
25 | do_install () { | 25 | do_install () { |
26 | 26 | ||