diff options
author | Dan McGregor <dan.mcgregor@usask.ca> | 2015-02-06 09:02:35 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-02-12 19:35:40 +0100 |
commit | 57632c54d82d9f6826629e931b8a50bf5a5bf5e4 (patch) | |
tree | 0c01b893b159ea19c2044f5ce3ecefb706f4123b /meta-initramfs/recipes-devtools/dracut | |
parent | 9bb362cb3fdf3c28c6bb1f510fd303b5297c218f (diff) | |
download | meta-openembedded-57632c54d82d9f6826629e931b8a50bf5a5bf5e4.tar.gz |
dracut: recipe cleanup
Split out bash-completion data
Update RDEPENDS: getopt is util-linux-getopt now
Use distro_features_check to require systemd
Recommend busybox
Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools/dracut')
-rw-r--r-- | meta-initramfs/recipes-devtools/dracut/dracut_git.bb | 25 |
1 files changed, 19 insertions, 6 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb index ea55a4dfb..77c137c46 100644 --- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb +++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb | |||
@@ -13,8 +13,10 @@ SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git" | |||
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | do_configure() { | 16 | inherit distro_features_check |
17 | ./configure --prefix=${prefix} \ | 17 | REQUIRED_DISTRO_FEATURES = "systemd" |
18 | |||
19 | EXTRA_OECONF = "--prefix=${prefix} \ | ||
18 | --libdir=${libdir} \ | 20 | --libdir=${libdir} \ |
19 | --datadir=${datadir} \ | 21 | --datadir=${datadir} \ |
20 | --sysconfdir=${sysconfdir} \ | 22 | --sysconfdir=${sysconfdir} \ |
@@ -23,20 +25,31 @@ do_configure() { | |||
23 | --bindir=${bindir} \ | 25 | --bindir=${bindir} \ |
24 | --includedir=${includedir} \ | 26 | --includedir=${includedir} \ |
25 | --localstatedir=${localstatedir} \ | 27 | --localstatedir=${localstatedir} \ |
28 | --systemdsystemunitdir=${systemd_unitdir}/system" | ||
29 | |||
30 | do_configure() { | ||
31 | ./configure ${EXTRA_OECONF} | ||
26 | } | 32 | } |
27 | 33 | ||
28 | do_install() { | 34 | do_install() { |
29 | oe_runmake install DESTDIR=${D} | 35 | oe_runmake install DESTDIR=${D} |
30 | } | 36 | } |
31 | 37 | ||
32 | FILES_${PN} += "${datadir}/bash-completion \ | 38 | PACKAGES =+ "${PN}-bash-completion" |
33 | ${libdir}/kernel \ | 39 | |
40 | FILES_${PN}-bash-completion = "${datadir}/bash-completion" | ||
41 | |||
42 | FILES_${PN} += " ${libdir}/kernel \ | ||
43 | ${systemd_unitdir} \ | ||
34 | " | 44 | " |
45 | CONFFILES_${PN} += "${sysconfdir}/dracut.conf" | ||
46 | |||
47 | RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid util-linux-getopt bash ldd" | ||
48 | RDEPENDS_${PN}-bash-completion = "bash-completion" | ||
35 | 49 | ||
36 | # 'getopt' is in the util-linux main package | ||
37 | RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid util-linux bash ldd" | ||
38 | # This could be optimized a bit, but let's avoid non-booting systems :) | 50 | # This could be optimized a bit, but let's avoid non-booting systems :) |
39 | RRECOMMENDS_${PN} = " \ | 51 | RRECOMMENDS_${PN} = " \ |
40 | kernel-modules \ | 52 | kernel-modules \ |
53 | busybox \ | ||
41 | coreutils \ | 54 | coreutils \ |
42 | " | 55 | " |