diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-02-06 11:08:59 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-06 11:16:23 -0800 |
commit | a55c0bb9ef27fc7d1d3f9ae2b0d55aa3e711e52b (patch) | |
tree | 38b6359b54ee97824d42ee5d0fd50e92599e94e4 /meta-initramfs/recipes-bsp | |
parent | b178b1a11d905734ba3ed82b075ffdb3fe563c02 (diff) | |
download | meta-openembedded-a55c0bb9ef27fc7d1d3f9ae2b0d55aa3e711e52b.tar.gz |
kexecboot: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/files/0001-make-Add-compiler-includes-in-cflags.patch | 31 | ||||
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | 6 |
2 files changed, 35 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/files/0001-make-Add-compiler-includes-in-cflags.patch b/meta-initramfs/recipes-bsp/kexecboot/files/0001-make-Add-compiler-includes-in-cflags.patch new file mode 100644 index 000000000..931d0fa58 --- /dev/null +++ b/meta-initramfs/recipes-bsp/kexecboot/files/0001-make-Add-compiler-includes-in-cflags.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 528a64d17488295299dad9fbfe3d7140bc1cfdfa Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 6 Feb 2021 11:06:48 -0800 | ||
4 | Subject: [PATCH] make: Add compiler includes in cflags | ||
5 | |||
6 | Fixes | ||
7 | | In file included from /mnt/b/yoe/master/build/tmp/work/raspberrypi4_64-yoe-linux/kexecboot-klibc/0.6+gitAUTOINC+5a5e04be20-r0/recipe-sysroot/usr/lib/klibc/include/stdio.h:11: | ||
8 | | /mnt/b/yoe/master/build/tmp/work/raspberrypi4_64-yoe-linux/kexecboot-klibc/0.6+gitAUTOINC+5a5e04be20-r0/recipe-sysroot/usr/lib/klibc/include/stdarg.h:9:15: fatal error: 'stdarg.h' file not found | ||
9 | | #include_next <stdarg.h> | ||
10 | | ^~~~~~~~~~ | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/Makefile.am | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
18 | index c75df23..d2adf38 100644 | ||
19 | --- a/src/Makefile.am | ||
20 | +++ b/src/Makefile.am | ||
21 | @@ -1,6 +1,6 @@ | ||
22 | bin_PROGRAMS=kexecboot | ||
23 | |||
24 | -kexecboot_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS) | ||
25 | +kexecboot_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS) -I$(shell $(CC) -print-file-name=include) | ||
26 | |||
27 | kexecboot_SOURCES = \ | ||
28 | util.c \ | ||
29 | -- | ||
30 | 2.30.0 | ||
31 | |||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb index 2f46fa952..ad9ccd02c 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | |||
@@ -6,8 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | |||
6 | PV = "0.6+git${SRCPV}" | 6 | PV = "0.6+git${SRCPV}" |
7 | S = "${WORKDIR}/git" | 7 | S = "${WORKDIR}/git" |
8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" | 8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" |
9 | SRC_URI_append_libc-klibc = " file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch " | 9 | SRC_URI_append_libc-klibc = "\ |
10 | 10 | file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \ | |
11 | file://0001-make-Add-compiler-includes-in-cflags.patch \ | ||
12 | " | ||
11 | SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6" | 13 | SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6" |
12 | inherit autotools | 14 | inherit autotools |
13 | 15 | ||