diff options
author | Joshua Lock <joshua.g.lock@intel.com> | 2016-11-25 15:28:52 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-02 09:16:17 +0100 |
commit | efd3696e70a6603f1a45faa4a172433514f0a487 (patch) | |
tree | b72751ba93b050391db05a8e1be7506836b6d515 /meta-initramfs/recipes-bsp | |
parent | 761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff) | |
download | meta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz |
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True
option from getVar() calls with a regex search and replace.
Search made with the following regex: getVar ?\(( ?[^,()]*), True\)
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r-- | meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb | 2 | ||||
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb index da3023fe1..b7a8a9356 100644 --- a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb +++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb | |||
@@ -7,7 +7,7 @@ SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)" | |||
7 | IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc" | 7 | IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc" |
8 | 8 | ||
9 | python () { | 9 | python () { |
10 | if d.getVar('TARGET_ARCH', True) == "nios2": | 10 | if d.getVar('TARGET_ARCH') == "nios2": |
11 | raise bb.parse.SkipPackage("'nios2' not supported arch") | 11 | raise bb.parse.SkipPackage("'nios2' not supported arch") |
12 | } | 12 | } |
13 | 13 | ||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb index 69f38721b..085955c13 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb | |||
@@ -57,4 +57,4 @@ CMDLINE_DEBUG ?= "quiet" | |||
57 | INHIBIT_DEFAULT_DEPS = "1" | 57 | INHIBIT_DEFAULT_DEPS = "1" |
58 | 58 | ||
59 | # Note: for qvga the label is currently limited to about 24 chars | 59 | # Note: for qvga the label is currently limited to about 24 chars |
60 | KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}" | 60 | KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO') or d.getVar('DISTRO_VERSION')}-${MACHINE}" |