diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-07-29 17:04:53 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-03 10:21:25 -0700 |
commit | c61dc077bbd81260e4f167fa2251643ba0ba6974 (patch) | |
tree | 66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-initramfs/recipes-bsp | |
parent | c5f7cfb8db54cfa4257797db5bd87828dea43296 (diff) | |
download | meta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz |
Convert to new override syntax
This is the result of automated script (0.9.1) conversion:
oe-core/scripts/contrib/convert-overrides.py .
converting the metadata to use ":" as the override character instead of "_".
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb | 4 | ||||
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | 6 |
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb index f90e2344b..2dce19c6b 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.2.bb | |||
@@ -8,7 +8,7 @@ SRC_URI = "file://icon.xpm" | |||
8 | 8 | ||
9 | S = "${WORKDIR}" | 9 | S = "${WORKDIR}" |
10 | 10 | ||
11 | do_install_prepend () { | 11 | do_install:prepend () { |
12 | echo '# /boot/boot.cfg - KEXECBOOT configuration file. | 12 | echo '# /boot/boot.cfg - KEXECBOOT configuration file. |
13 | # | 13 | # |
14 | # First kernel stanza. | 14 | # First kernel stanza. |
@@ -55,7 +55,7 @@ do_install () { | |||
55 | 55 | ||
56 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 56 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
57 | 57 | ||
58 | FILES_${PN} += "/boot/*" | 58 | FILES:${PN} += "/boot/*" |
59 | 59 | ||
60 | CMDLINE ?= "" | 60 | CMDLINE ?= "" |
61 | CMDLINE_DEBUG ?= "quiet" | 61 | CMDLINE_DEBUG ?= "quiet" |
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb index ad9ccd02c..0f77f65df 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | |||
6 | PV = "0.6+git${SRCPV}" | 6 | PV = "0.6+git${SRCPV}" |
7 | S = "${WORKDIR}/git" | 7 | S = "${WORKDIR}/git" |
8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" | 8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" |
9 | SRC_URI_append_libc-klibc = "\ | 9 | SRC_URI:append_libc-klibc = "\ |
10 | file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \ | 10 | file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \ |
11 | file://0001-make-Add-compiler-includes-in-cflags.patch \ | 11 | file://0001-make-Add-compiler-includes-in-cflags.patch \ |
12 | " | 12 | " |
@@ -27,9 +27,9 @@ do_install () { | |||
27 | 27 | ||
28 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 28 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
29 | 29 | ||
30 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" | 30 | FILES:${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" |
31 | 31 | ||
32 | pkg_postinst_${PN} () { | 32 | pkg_postinst:${PN} () { |
33 | ln -sf ${bindir}/kexecboot $D/init | 33 | ln -sf ${bindir}/kexecboot $D/init |
34 | } | 34 | } |
35 | 35 | ||