diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2013-10-10 23:26:24 +0200 |
---|---|---|
committer | Paul Eggleton <paul.eggleton@linux.intel.com> | 2013-10-11 00:27:39 +0100 |
commit | 0eaa9888882dcf393f7244578854baf8c2d8a4cf (patch) | |
tree | 796053013aa093a7862d4a51405f711c71a5db6c /meta-initramfs/recipes-bsp | |
parent | d79d4b340358168d7ca4b8f2837c9d09c44bd1fe (diff) | |
download | meta-openembedded-0eaa9888882dcf393f7244578854baf8c2d8a4cf.tar.gz |
kexecboot.inc: merge back in the main recipe
and process with oe-stylize.py
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc | 58 | ||||
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | 62 |
2 files changed, 60 insertions, 60 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc deleted file mode 100644 index 065e3c1a5..000000000 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | ########################### | ||
2 | # Configure options: | ||
3 | # | ||
4 | # --enable-static-linking compile kexecboot as static executable [default=no] | ||
5 | # --enable-fbui support framebuffer menu [default=yes] | ||
6 | # --enable-fbui-width limit FB UI width to specified value [default=no] | ||
7 | # --enable-fbui-height limit FB UI height to specified value [default=no] | ||
8 | # --enable-textui support console text user interface [default=no] | ||
9 | # --enable-cfgfiles support config files [default=yes] | ||
10 | # --enable-icons support custom icons (depends on fbui) [default=yes] | ||
11 | # --enable-zaurus compile Sharp Zaurus specific code [default=no] | ||
12 | # --enable-zimage compile with zImage support [default=yes] | ||
13 | # --enable-uimage compile with uImage support [default=no] | ||
14 | # --enable-machine-kernel look for machine-specific zImage kernel [default=no] | ||
15 | # --enable-devices-recreating | ||
16 | # enable devices re-creating [default=yes] | ||
17 | # --enable-debug enable debug output [default=no] | ||
18 | # --enable-host-debug allow for non-destructive executing of kexecboot on | ||
19 | # host system [default=no] | ||
20 | # --enable-numkeys enable menu item selection by keys [0-9] [default=yes] | ||
21 | # --enable-bg-buffer enable buffer for pre-drawed FB GUI background | ||
22 | # | ||
23 | # --enable-timeout allow to boot 1st kernel after timeout in seconds | ||
24 | # [default=no] | ||
25 | # --enable-delay specify delay before device scanning, allowing | ||
26 | # initialization of old CF/SD cards [default=1] | ||
27 | # --enable-bpp enable support of specified bpp modes | ||
28 | # (all,32,24,18,16,4,2,1) [default=all] | ||
29 | # --enable-evdev-rate change evdev (keyboard/mouse) repeat rate | ||
30 | # in milliseconds e.g. "1000,250" [default=no] | ||
31 | # --with-kexec-binary look for kexec binary at path | ||
32 | # [default="/usr/sbin/kexec"] | ||
33 | ########################## | ||
34 | SUMMARY = "kexecboot linux-as-bootloader" | ||
35 | DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec." | ||
36 | HOMEPAGE = "http://kexecboot.org" | ||
37 | LICENSE = "GPLv2" | ||
38 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
39 | inherit autotools | ||
40 | |||
41 | EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250" | ||
42 | |||
43 | do_install () { | ||
44 | install -d ${D}${bindir} | ||
45 | install -m 0755 kexecboot ${D}${bindir}/ | ||
46 | install -d ${D}/proc | ||
47 | install -d ${D}/mnt | ||
48 | install -d ${D}/dev | ||
49 | install -d ${D}/sys | ||
50 | } | ||
51 | |||
52 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
53 | |||
54 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" | ||
55 | |||
56 | pkg_postinst_${PN} () { | ||
57 | ln -sf ${bindir}/kexecboot $D/init | ||
58 | } | ||
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb index b52012e96..7347ea598 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb | |||
@@ -1,9 +1,67 @@ | |||
1 | ########################### | ||
2 | # Configure options: | ||
3 | # | ||
4 | # --enable-static-linking compile kexecboot as static executable [default=no] | ||
5 | # --enable-fbui support framebuffer menu [default=yes] | ||
6 | # --enable-fbui-width limit FB UI width to specified value [default=no] | ||
7 | # --enable-fbui-height limit FB UI height to specified value [default=no] | ||
8 | # --enable-textui support console text user interface [default=no] | ||
9 | # --enable-cfgfiles support config files [default=yes] | ||
10 | # --enable-icons support custom icons (depends on fbui) [default=yes] | ||
11 | # --enable-zaurus compile Sharp Zaurus specific code [default=no] | ||
12 | # --enable-zimage compile with zImage support [default=yes] | ||
13 | # --enable-uimage compile with uImage support [default=no] | ||
14 | # --enable-machine-kernel look for machine-specific zImage kernel [default=no] | ||
15 | # --enable-devices-recreating | ||
16 | # enable devices re-creating [default=yes] | ||
17 | # --enable-debug enable debug output [default=no] | ||
18 | # --enable-host-debug allow for non-destructive executing of kexecboot on | ||
19 | # host system [default=no] | ||
20 | # --enable-numkeys enable menu item selection by keys [0-9] [default=yes] | ||
21 | # --enable-bg-buffer enable buffer for pre-drawed FB GUI background | ||
22 | # | ||
23 | # --enable-timeout allow to boot 1st kernel after timeout in seconds | ||
24 | # [default=no] | ||
25 | # --enable-delay specify delay before device scanning, allowing | ||
26 | # initialization of old CF/SD cards [default=1] | ||
27 | # --enable-bpp enable support of specified bpp modes | ||
28 | # (all,32,24,18,16,4,2,1) [default=all] | ||
29 | # --enable-evdev-rate change evdev (keyboard/mouse) repeat rate | ||
30 | # in milliseconds e.g. "1000,250" [default=no] | ||
31 | # --with-kexec-binary look for kexec binary at path | ||
32 | # [default="/usr/sbin/kexec"] | ||
33 | ########################## | ||
34 | SUMMARY = "kexecboot linux-as-bootloader" | ||
35 | DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec." | ||
36 | HOMEPAGE = "http://kexecboot.org" | ||
37 | LICENSE = "GPLv2" | ||
38 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
39 | SRCREV = "0bcc14671aa2d84ec20f260582aca36bb901ccf1" | ||
1 | PV = "0.5.9.1" | 40 | PV = "0.5.9.1" |
2 | 41 | ||
3 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" | 42 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" |
4 | SRCREV = "0bcc14671aa2d84ec20f260582aca36bb901ccf1" | 43 | |
5 | S = "${WORKDIR}/git" | 44 | S = "${WORKDIR}/git" |
6 | 45 | ||
7 | require kexecboot.inc | 46 | inherit autotools |
47 | |||
48 | EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250" | ||
49 | |||
50 | do_install () { | ||
51 | install -d ${D}${bindir} | ||
52 | install -m 0755 kexecboot ${D}${bindir}/ | ||
53 | install -d ${D}/proc | ||
54 | install -d ${D}/mnt | ||
55 | install -d ${D}/dev | ||
56 | install -d ${D}/sys | ||
57 | } | ||
58 | |||
59 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
60 | |||
61 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" | ||
62 | |||
63 | pkg_postinst_${PN} () { | ||
64 | ln -sf ${bindir}/kexecboot $D/init | ||
65 | } | ||
8 | 66 | ||
9 | BBCLASSEXTEND = "klibc" | 67 | BBCLASSEXTEND = "klibc" |