summaryrefslogtreecommitdiffstats
path: root/meta-gpe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-23 15:12:29 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-23 15:14:35 +0200
commitc62295ec6adc3da3283890071d452fd5abc1a08f (patch)
tree28e6b3adcaab665aae2714570e8676bf293fca3a /meta-gpe
parentc6b34871dc0fdd3c1e6a24f2a635505deaa28b20 (diff)
downloadmeta-openembedded-c62295ec6adc3da3283890071d452fd5abc1a08f.tar.gz
gpe-scap: import from OE rev aae5b51e4a8dd57b28a6f91e6c14a5311aadbdae
Add patch to fix -as-needed linker problems Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gpe')
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch28
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb22
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
new file mode 100644
index 000000000..c976ff470
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
@@ -0,0 +1,28 @@
1From c551dece6768f67b74b508e9c0133320205ef2df Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 23 May 2011 15:03:29 +0200
4Subject: [PATCH] Fix the ordering of LDADD options to fix a compilation failure.
5
6"invalid DSO for symbol `XUngrabServer' definition "
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 src/Makefile.am | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/src/Makefile.am b/src/Makefile.am
14index 2fddc98..45bd850 100644
15--- a/src/Makefile.am
16+++ b/src/Makefile.am
17@@ -6,7 +6,7 @@ INCLUDES = -DPKGDATADIR=\"$(pkgdatadir)\" \
18 $(GLADE_CFLAGS) \
19 -D_GNU_SOURCE
20
21-LIBS = $(GTK_LIBS) $(GLADE_LIBS) $(XSHAPE_LIBS)
22+LIBS = -lX11 $(XSHAPE_LIBS) $(GLADE_LIBS) $(GTK_LIBS)
23
24 bin_PROGRAMS = gpe-scap
25 gpe_scap_SOURCES = scr-i18n.h \
26--
271.6.6.1
28
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
new file mode 100644
index 000000000..cc889c77c
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A GPE application that allows you to take screenshots."
2SECTION = "gpe"
3PRIORITY = "optional"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
7
8DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup"
9
10PR = "r2"
11
12SRC_URI[md5sum] = "eaf545561b0ad981c9d01833f30fcf95"
13SRC_URI[sha256sum] = "762778421fae7c62d5ec6a9d27986166c0dbbe2ff51fc10bb9b8baff5c367534"
14
15GPE_TARBALL_SUFFIX = "bz2"
16
17inherit gpe autotools
18
19SRC_URI += "file://0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch"
20
21RREPLACES_${PN} = "gpe-screenshot"
22