summaryrefslogtreecommitdiffstats
path: root/meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch')
-rw-r--r--meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch b/meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch
new file mode 100644
index 000000000..f6e12023b
--- /dev/null
+++ b/meta-gpe/recipes-support/fbreader/files/0001-Fix-installation-of-the-icons-when-RESOLUTION-is-set.patch
@@ -0,0 +1,40 @@
1From da4170b61bb41eff0af170d1d77bfd90f9ebe5dd Mon Sep 17 00:00:00 2001
2From: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
3Date: Fri, 20 Jan 2012 11:34:42 +0100
4Subject: [PATCH] Fix installation of the icons when RESOLUTION is set
5
6When resolution is set, the following code(in fbreader/Makefile) is executed:
7 VARIANT = $(TARGET_ARCH)
8 ifneq "$(RESOLUTION)" ""
9 VARIANT = $(TARGET_ARCH)_$(RESOLUTION)
10 endif
11
12This fix is based on a patch from the openembedded project,
13 which can be found here:
14 http://cgit.openembedded.org/openembedded/tree/recipes/fbreader/fbreader-0.12.1/Makefile.patch
15
16Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
17---
18 Submitted trough github to git://github.com/geometer/FBReader.git as a pull request
19
20 fbreader/Makefile | 4 ++--
21 1 files changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/fbreader/Makefile b/fbreader/Makefile
24index bfa9242..03e6cc3 100644
25--- a/fbreader/Makefile
26+++ b/fbreader/Makefile
27@@ -60,8 +60,8 @@ do_install:
28 @install -d $(FBSHAREDIR)/resources
29 @install -m 0644 $(wildcard data/resources/*.xml) $(FBSHAREDIR)/resources
30 @install -d $(DESTDIR)$(APPIMAGEDIR_REAL)
31- @install -m 0644 $(wildcard data/icons/toolbar/$(VARIANT)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
32- @install -m 0644 $(wildcard data/icons/filetree/$(VARIANT)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
33+ @install -m 0644 $(wildcard data/icons/toolbar/$(TARGET_ARCH)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
34+ @install -m 0644 $(wildcard data/icons/filetree/$(TARGET_ARCH)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
35 @install -m 0644 $(wildcard data/icons/booktree/new/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
36 @make -C $(TARGET_ARCH) RESOLUTION=$(RESOLUTION) install
37
38--
391.7.4.1
40