summaryrefslogtreecommitdiffstats
path: root/meta-gpe/recipes-graphics
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-gpe/recipes-graphics
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-gpe/recipes-graphics')
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch28
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap/use.libsoup-2.4.patch42
-rw-r--r--meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb23
-rw-r--r--meta-gpe/recipes-graphics/libgpewidget/libgpewidget/glib-2.32.patch11
-rw-r--r--meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch11
-rw-r--r--meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb23
-rw-r--r--meta-gpe/recipes-graphics/minilite/minilite/makefile-fix.patch11
-rw-r--r--meta-gpe/recipes-graphics/minilite/minilite_0.50.bb16
8 files changed, 165 insertions, 0 deletions
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
new file mode 100644
index 000000000..c976ff470
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch
@@ -0,0 +1,28 @@
1From c551dece6768f67b74b508e9c0133320205ef2df Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 23 May 2011 15:03:29 +0200
4Subject: [PATCH] Fix the ordering of LDADD options to fix a compilation failure.
5
6"invalid DSO for symbol `XUngrabServer' definition "
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 src/Makefile.am | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/src/Makefile.am b/src/Makefile.am
14index 2fddc98..45bd850 100644
15--- a/src/Makefile.am
16+++ b/src/Makefile.am
17@@ -6,7 +6,7 @@ INCLUDES = -DPKGDATADIR=\"$(pkgdatadir)\" \
18 $(GLADE_CFLAGS) \
19 -D_GNU_SOURCE
20
21-LIBS = $(GTK_LIBS) $(GLADE_LIBS) $(XSHAPE_LIBS)
22+LIBS = -lX11 $(XSHAPE_LIBS) $(GLADE_LIBS) $(GTK_LIBS)
23
24 bin_PROGRAMS = gpe-scap
25 gpe_scap_SOURCES = scr-i18n.h \
26--
271.6.6.1
28
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/use.libsoup-2.4.patch b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/use.libsoup-2.4.patch
new file mode 100644
index 000000000..3cfe5d724
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap/use.libsoup-2.4.patch
@@ -0,0 +1,42 @@
1diff -uNr gpe-scap-1.4.orig/configure.ac gpe-scap-1.4/configure.ac
2--- gpe-scap-1.4.orig/configure.ac 2009-03-05 18:53:53.000000000 +0100
3+++ gpe-scap-1.4/configure.ac 2012-05-06 10:18:29.348308322 +0200
4@@ -24,7 +24,7 @@
5 AC_SUBST(LDFLAGS)
6
7 dnl libraries
8-GTK_MODULES="gtk+-2.0 >= 2.6.0 gthread-2.0 libsoup-2.2"
9+GTK_MODULES="gtk+-2.0 >= 2.6.0 gthread-2.0 libsoup-2.4"
10 PKG_CHECK_MODULES(GTK, $GTK_MODULES)
11 AC_SUBST(GTK_CFLAGS)
12 AC_SUBST(GTK_LIBS)
13diff -uNr gpe-scap-1.4.orig/src/scr-shot-common.c gpe-scap-1.4/src/scr-shot-common.c
14--- gpe-scap-1.4.orig/src/scr-shot-common.c 2009-03-05 12:13:20.000000000 +0100
15+++ gpe-scap-1.4/src/scr-shot-common.c 2012-05-06 10:30:52.299371576 +0200
16@@ -182,12 +182,12 @@
17 /* create session and message */
18 session = soup_session_sync_new ();
19 message = soup_message_new ("POST", url);
20- soup_message_add_header (message->request_headers, "User-Agent", "gpe-scap/" VERSION);
21- soup_message_add_header (message->request_headers, "Accept",
22+ soup_message_headers_append (message->request_headers, "User-Agent", "gpe-scap/" VERSION);
23+ soup_message_headers_append (message->request_headers, "Accept",
24 "text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5");
25-/* soup_message_add_header (message->request_headers, "Accept-Charset", "Accept-Charset=ISO-8859-1,utf-8;q=0.7,*;q=0.7");
26- soup_message_add_header (message->request_headers, "Keep-Alive", "100");
27- soup_message_add_header (message->request_headers, "Connection", "keep-alive");
28+/* soup_message_headers_append (message->request_headers, "Accept-Charset", "Accept-Charset=ISO-8859-1,utf-8;q=0.7,*;q=0.7");
29+ soup_message_headers_append (message->request_headers, "Keep-Alive", "100");
30+ soup_message_headers_append (message->request_headers, "Connection", "keep-alive");
31 soup_message_wire add_header (message->request_headers, "Accept-Encoding", "gzip,deflate");
32 */
33 /* build message body */
34@@ -207,7 +207,7 @@
35 memcpy (body + strlen (cmd) + len, tail, strlen (tail));
36
37 soup_message_set_request (message, "multipart/form-data; boundary="SEP,
38- SOUP_BUFFER_SYSTEM_OWNED, body, content_len);
39+ SOUP_MEMORY_TAKE, body, content_len);
40
41 soup_session_send_message (session, message);
42
diff --git a/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
new file mode 100644
index 000000000..3f1e27e87
--- /dev/null
+++ b/meta-gpe/recipes-graphics/gpe-scap/gpe-scap_1.4.bb
@@ -0,0 +1,23 @@
1SUMMARY = "A GPE application that allows you to take screenshots"
2SECTION = "gpe"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "glib-2.0 gtk+ libgpewidget libglade libsoup-2.4"
8
9PR = "r3"
10
11SRC_URI[md5sum] = "eaf545561b0ad981c9d01833f30fcf95"
12SRC_URI[sha256sum] = "762778421fae7c62d5ec6a9d27986166c0dbbe2ff51fc10bb9b8baff5c367534"
13
14GPE_TARBALL_SUFFIX = "bz2"
15
16inherit gpe autotools pkgconfig
17
18SRC_URI += "file://0001-Fix-the-ordering-of-LDADD-options-to-fix-a-compilati.patch \
19 file://use.libsoup-2.4.patch \
20"
21
22RREPLACES_${PN} = "gpe-screenshot"
23
diff --git a/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/glib-2.32.patch b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/glib-2.32.patch
new file mode 100644
index 000000000..f590caa46
--- /dev/null
+++ b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/glib-2.32.patch
@@ -0,0 +1,11 @@
1diff -uNr libgpewidget-0.117.orig/gpehelp.c libgpewidget-0.117/gpehelp.c
2--- libgpewidget-0.117.orig/gpehelp.c 2006-10-12 12:20:33.000000000 +0200
3+++ libgpewidget-0.117/gpehelp.c 2012-04-30 07:45:57.813293792 +0200
4@@ -33,7 +33,6 @@
5 #include <gdk-pixbuf/gdk-pixbuf.h>
6 #include <gdk/gdk.h>
7 #include <glib.h>
8-#include <glib/gkeyfile.h>
9
10
11 /* helper function definitions*/
diff --git a/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch
new file mode 100644
index 000000000..317e01a9b
--- /dev/null
+++ b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch
@@ -0,0 +1,11 @@
1--- configure.ac.orig 2006-02-04 17:37:55.000000000 +0100
2+++ configure.ac 2006-02-06 00:56:28.000000000 +0100
3@@ -36,7 +36,7 @@
4 ENABLE_CAIRO=$enableval
5 ],
6 [
7- PKG_CHECK_EXISTS(cairo, [ENABLE_CAIRO=yes], [ENABLE_CAIRO=no])
8+ PKG_CHECK_MODULES(cairo, [ENABLE_CAIRO=yes], [ENABLE_CAIRO=no])
9 ])
10
11 ENABLE_HILDON=false
diff --git a/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb
new file mode 100644
index 000000000..df774eed0
--- /dev/null
+++ b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "libgpewidget contains a collection of widgets and other common code shared by many GPE applications."
2SECTION = "gpe/libs"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499"
6
7DEPENDS = "gtk+ cairo libxinerama libxcomposite libxrender"
8PR = "r5"
9
10inherit gpe pkgconfig autotools gtk-doc
11
12SRC_URI += "file://pkgconfig.patch;striplevel=0 \
13 file://glib-2.32.patch \
14"
15SRC_URI[md5sum] = "b85a839264a35d0faf9a1a38c486e189"
16SRC_URI[sha256sum] = "f96d30c09b0395ea4e146730fd52d9ea303b619bb139051d9f12d3f868a9e18c"
17
18GPE_TARBALL_SUFFIX = "bz2"
19
20EXTRA_OECONF = "--enable-cairo"
21LDFLAGS += " -L${STAGING_LIBDIR}"
22
23PACKAGES =+ "${PN}-bin"
diff --git a/meta-gpe/recipes-graphics/minilite/minilite/makefile-fix.patch b/meta-gpe/recipes-graphics/minilite/minilite/makefile-fix.patch
new file mode 100644
index 000000000..1be6ceaa8
--- /dev/null
+++ b/meta-gpe/recipes-graphics/minilite/minilite/makefile-fix.patch
@@ -0,0 +1,11 @@
1--- /tmp/Makefile.old 2006-01-16 22:51:34.000000000 +0100
2+++ minilite-050/Makefile 2009-05-01 16:36:32.000000000 +0200
3@@ -45,7 +45,7 @@
4
5 install-program: all
6 mkdir -p $(DESTDIR)$(PREFIX)/bin
7- $(INSTALL) -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
8+ $(INSTALL) $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
9 mkdir -p $(DESTDIR)$(PREFIX)/share/applications
10 $(INSTALL) -m 644 $(PACKAGE).desktop $(DESTDIR)$(PREFIX)/share/applications/$(PACKAGE).desktop
11 mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps/
diff --git a/meta-gpe/recipes-graphics/minilite/minilite_0.50.bb b/meta-gpe/recipes-graphics/minilite/minilite_0.50.bb
new file mode 100644
index 000000000..90960a2b0
--- /dev/null
+++ b/meta-gpe/recipes-graphics/minilite/minilite_0.50.bb
@@ -0,0 +1,16 @@
1SUMMARY = "GPE Screen light control dockapp"
2SECTION = "gpe"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://minilite.c;beginline=8;endline=11;md5=fe9332aaecbce9f74ce2bfeb91680ed1"
6
7DEPENDS = "libgpewidget"
8
9inherit gpe
10
11SRC_URI = "${GPE_MIRROR}/${BP}.tar.gz \
12 file://makefile-fix.patch"
13SRC_URI[md5sum] = "d81cecf269ad7bab0da960e6e7228332"
14SRC_URI[sha256sum] = "2b299425203246090a4949e034f1d0efb3ff99cd1591d0e16c57370a530b361e"
15
16export CVSBUILD="no"