summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorPiotr Tworek <tworaz@tworaz.net>2019-08-22 19:17:07 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-24 05:20:42 -0700
commit5458f8264a6cd88ab24ca5ecb7477b3b9ab74802 (patch)
tree3dd46e0e3bd15f4f18159d42a74d46ef7aa3e0be /meta-gnome
parentda61ce2396b7987e3dc6b9450292a14c750d0c71 (diff)
downloadmeta-openembedded-5458f8264a6cd88ab24ca5ecb7477b3b9ab74802.tar.gz
evolution-data-server: Update to version 3.32.4
* 0004-Use-recommended-way-to-handle-the-icu-namespace.patch patch is already included in this release. Drop it. * To make this update possible we need to work around cmake inability to compile code for the host machine while cross compiling. To work around this necessary tools are manually compiled in the do_compile_prepend step. Custom patch is then used to modify project cmake files to invoke provided host tools instead of those produced during cross build. Signed-off-by: Piotr Tworek <tworaz@tworaz.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch20
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch10
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch10
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch50
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch46
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb)20
6 files changed, 86 insertions, 70 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
index a821a14ab..cc9dca4ea 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
@@ -1,7 +1,7 @@
1From 131b88a81aba3d72d566bc8a9d968941a98e0007 Mon Sep 17 00:00:00 2001 1From e32075119803f9fffbba01a31083e416cb213011 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> 2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Tue, 19 Dec 2017 16:37:20 +0100 3Date: Tue, 19 Dec 2017 16:37:20 +0100
4Subject: [PATCH] CMakeLists.txt: Remove TRY_RUN for iconv 4Subject: [PATCH 1/7] CMakeLists.txt: Remove TRY_RUN for iconv
5MIME-Version: 1.0 5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8 6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit 7Content-Transfer-Encoding: 8bit
@@ -13,18 +13,20 @@ Upstream-Status: Inappropriate [OE specific]
13 13
14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> 14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15--- 15---
16 CMakeLists.txt | 5 ----- 16 CMakeLists.txt | 6 ------
17 1 file changed, 5 deletions(-) 17 1 file changed, 6 deletions(-)
18 18
19diff --git a/CMakeLists.txt b/CMakeLists.txt 19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index 8d07772..a2396f2 100644 20index f9d72db..ed99904 100644
21--- a/CMakeLists.txt 21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt 22+++ b/CMakeLists.txt
23@@ -521,13 +521,8 @@ if(NOT HAVE_ICONV) 23@@ -526,15 +526,9 @@ endif(NOT HAVE_ICONV)
24 endif(NOT HAVE_ICONV)
25 24
26 set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS}) 25 set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS})
27-CHECK_C_SOURCE_RUNS("#include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv) 26 file(TO_NATIVE_PATH "${CMAKE_BINARY_DIR}/" _binary_dir_with_separator)
27-CHECK_C_SOURCE_RUNS("#define ICONV_DETECT_BUILD_DIR \"${_binary_dir_with_separator}\"
28- #include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv)
29 unset(_binary_dir_with_separator)
28 unset(CMAKE_REQUIRED_LIBRARIES) 30 unset(CMAKE_REQUIRED_LIBRARIES)
29 31
30-if(NOT _correct_iconv) 32-if(NOT _correct_iconv)
@@ -35,5 +37,5 @@ index 8d07772..a2396f2 100644
35 # Backtraces for debugging 37 # Backtraces for debugging
36 # ****************************** 38 # ******************************
37-- 39--
382.14.3 402.21.0
39 41
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
index c8dc7e12c..23c3a96d4 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
@@ -1,7 +1,7 @@
1From 210b204d9edd71202454ff04013cc52b23c598e4 Mon Sep 17 00:00:00 2001 1From 20bd8946a5c73290d961df151e82033171639c0d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> 2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Tue, 19 Dec 2017 16:55:13 +0100 3Date: Tue, 19 Dec 2017 16:55:13 +0100
4Subject: [PATCH] CMakeLists.txt: remove CHECK_C_SOURCE_RUNS check 4Subject: [PATCH 2/7] CMakeLists.txt: remove CHECK_C_SOURCE_RUNS check
5MIME-Version: 1.0 5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8 6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit 7Content-Transfer-Encoding: 8bit
@@ -15,10 +15,10 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15 1 file changed, 23 deletions(-) 15 1 file changed, 23 deletions(-)
16 16
17diff --git a/CMakeLists.txt b/CMakeLists.txt 17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index a2396f2..f3b271b 100644 18index ed99904..9a2e99f 100644
19--- a/CMakeLists.txt 19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt 20+++ b/CMakeLists.txt
21@@ -573,29 +573,6 @@ CHECK_C_SOURCE_COMPILES("#include <langinfo.h> 21@@ -579,29 +579,6 @@ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
22 CHECK_C_SOURCE_COMPILES("#include <langinfo.h> 22 CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
23 int main(void) { char *detail = nl_langinfo (_NL_ADDRESS_COUNTRY_AB2); return 0; }" HAVE__NL_ADDRESS_COUNTRY_AB2) 23 int main(void) { char *detail = nl_langinfo (_NL_ADDRESS_COUNTRY_AB2); return 0; }" HAVE__NL_ADDRESS_COUNTRY_AB2)
24 24
@@ -49,5 +49,5 @@ index a2396f2..f3b271b 100644
49 # system mail stuff 49 # system mail stuff
50 # ****************************** 50 # ******************************
51-- 51--
522.14.3 522.21.0
53 53
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
index 3cdfa8b6f..c9e6f96f5 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
@@ -1,14 +1,14 @@
1From 4df8bd8ae4258289663b27af1207027c7ee06340 Mon Sep 17 00:00:00 2001 1From d616eddf3a214a49900344f4455155879d3b82db Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com> 2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 4 Aug 2013 09:13:25 +0200 3Date: Sun, 4 Aug 2013 09:13:25 +0200
4Subject: [PATCH 1/5] contact: Replace the Novell sample contact with something 4Subject: [PATCH 3/7] contact: Replace the Novell sample contact with something
5 more appropriate 5 more appropriate
6 6
7Upstream-Status: Inappropriate [configuration] 7Upstream-Status: Inappropriate [configuration]
8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> 8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
9--- 9---
10 src/addressbook/libedata-book/ximian-vcard.h | 179 ++++++++++++++++++------------- 10 src/addressbook/libedata-book/ximian-vcard.h | 179 +++++++++++--------
11 2 files changed, 103 insertions(+), 77 deletions(-) 11 1 file changed, 102 insertions(+), 77 deletions(-)
12 12
13diff --git a/src/addressbook/libedata-book/ximian-vcard.h b/src/addressbook/libedata-book/ximian-vcard.h 13diff --git a/src/addressbook/libedata-book/ximian-vcard.h b/src/addressbook/libedata-book/ximian-vcard.h
14index 782d37b..5b0b250 100644 14index 782d37b..5b0b250 100644
@@ -198,5 +198,5 @@ index 782d37b..5b0b250 100644
198+" gQIUKE+H+C/wMGX8Ias1s6CQAAAABJRU5ErkJggg==\n" \ 198+" gQIUKE+H+C/wMGX8Ias1s6CQAAAABJRU5ErkJggg==\n" \
199 "END:VCARD" 199 "END:VCARD"
200-- 200--
2011.8.3.2 2012.21.0
202 202
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch
new file mode 100644
index 000000000..67023df2c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch
@@ -0,0 +1,50 @@
1From 30bd4ae3badb152c9f81c6d34014c586fa0cc825 Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Mon, 12 Aug 2019 14:13:52 +0200
4Subject: [PATCH 4/7] Add native suffix to exacutables produced and run during
5 build process.
6
7CMake can't build tools for the host system when cross compiling. As
8result eds currently fails to build in OE due to some programs being
9cross compiled for the target and run on the host. To work around this
10limitation modify existing targets using build time generated binaries
11to invoke binaries suffixed with -native. We can inject such binaries
12into expected locations prior to invoking ninja in do_compile.
13
14Upstream-Status: Inappropriate [OE specific]
15
16Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
17---
18 src/addressbook/libebook-contacts/CMakeLists.txt | 2 +-
19 src/camel/CMakeLists.txt | 2 +-
20 2 files changed, 2 insertions(+), 2 deletions(-)
21
22diff --git a/src/addressbook/libebook-contacts/CMakeLists.txt b/src/addressbook/libebook-contacts/CMakeLists.txt
23index e9e3259..2ae72a8 100644
24--- a/src/addressbook/libebook-contacts/CMakeLists.txt
25+++ b/src/addressbook/libebook-contacts/CMakeLists.txt
26@@ -25,7 +25,7 @@ target_link_libraries(gen-western-table
27
28 add_custom_command(
29 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
30- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gen-western-table "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
31+ COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gen-western-table-native "${CMAKE_CURRENT_SOURCE_DIR}/e-name-western-tables.h.in" >${CMAKE_CURRENT_BINARY_DIR}/e-name-western-tables.h
32 DEPENDS gen-western-table e-name-western-tables.h.in
33 )
34
35diff --git a/src/camel/CMakeLists.txt b/src/camel/CMakeLists.txt
36index be626a8..9226b2b 100644
37--- a/src/camel/CMakeLists.txt
38+++ b/src/camel/CMakeLists.txt
39@@ -10,7 +10,7 @@ target_include_directories(camel-gen-tables PUBLIC
40
41 add_custom_command(
42 OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
43- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/camel-gen-tables >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
44+ COMMAND ${CMAKE_CURRENT_BINARY_DIR}/camel-gen-tables-native >${CMAKE_CURRENT_BINARY_DIR}/camel-mime-tables.c
45 DEPENDS camel-gen-tables
46 )
47
48--
492.21.0
50
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch
deleted file mode 100644
index d3b0ac673..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-Use-recommended-way-to-handle-the-icu-namespace.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 698a0e104dcbe4b630df848fd4af7c59f76cdc37 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 5 May 2018 17:46:52 -0700
4Subject: [PATCH] Use recommended way to handle the icu namespace
5
6Fixes build with icu >= 61
7
8Upstream-Status: Pending
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 src/libedataserver/e-alphabet-index-private.cpp | 2 ++
13 src/libedataserver/e-transliterator-private.cpp | 2 ++
14 2 files changed, 4 insertions(+)
15
16diff --git a/src/libedataserver/e-alphabet-index-private.cpp b/src/libedataserver/e-alphabet-index-private.cpp
17index d3e44f4..ddffd99 100644
18--- a/src/libedataserver/e-alphabet-index-private.cpp
19+++ b/src/libedataserver/e-alphabet-index-private.cpp
20@@ -33,9 +33,11 @@
21
22 /* ICU headers */
23 #include <unicode/alphaindex.h>
24+#include <unicode/ustring.h>
25
26 using icu::AlphabeticIndex;
27 using icu::Locale;
28+using U_ICU_NAMESPACE::UnicodeString;
29
30 struct _EAlphabetIndex {
31 AlphabeticIndex *priv;
32diff --git a/src/libedataserver/e-transliterator-private.cpp b/src/libedataserver/e-transliterator-private.cpp
33index bb15593..573446f 100644
34--- a/src/libedataserver/e-transliterator-private.cpp
35+++ b/src/libedataserver/e-transliterator-private.cpp
36@@ -33,8 +33,10 @@
37
38 /* ICU headers */
39 #include <unicode/translit.h>
40+#include <unicode/ustring.h>
41
42 using icu::Transliterator;
43+using U_ICU_NAMESPACE::UnicodeString;
44
45 struct _ETransliterator {
46 Transliterator *priv;
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
index 1949fc7fd..ddb62597f 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.6.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
9 file://src/calendar/libecal/e-cal.h;endline=24;md5=e699ec3866f73f129f7a4ffffdcfc196" 9 file://src/calendar/libecal/e-cal.h;endline=24;md5=e699ec3866f73f129f7a4ffffdcfc196"
10 10
11DEPENDS = " \ 11DEPENDS = " \
12 intltool-native gperf-native \ 12 intltool-native gperf-native glib-2.0-native \
13 glib-2.0 gtk+3 gconf libgnome-keyring libgdata \ 13 glib-2.0 gtk+3 gconf libgnome-keyring libgdata libcanberra icu \
14 dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \ 14 dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \
15" 15"
16 16
@@ -22,11 +22,11 @@ SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}
22 file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \ 22 file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
23 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \ 23 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
24 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ 24 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
25 file://0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch \
25 file://iconv-detect.h \ 26 file://iconv-detect.h \
26 file://0004-Use-recommended-way-to-handle-the-icu-namespace.patch \
27 " 27 "
28SRC_URI[archive.md5sum] = "ae7bbf543b2c3ff79af27e0edea5d472" 28SRC_URI[archive.md5sum] = "57820f3f88fc554e1a58665a52e12c05"
29SRC_URI[archive.sha256sum] = "e43aa1847ddc02965f560261ef88d18fb8704eddaa55555bf96b884a33e510ec" 29SRC_URI[archive.sha256sum] = "83f67cb4b680e892b22b51bcde64c788b7ac63e92a99de401fb347e3794f4c7f"
30 30
31LKSTRFTIME = "HAVE_LKSTRFTIME=ON" 31LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
32LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF" 32LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
@@ -59,6 +59,16 @@ do_configure_append () {
59 59
60do_compile_prepend() { 60do_compile_prepend() {
61 export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs" 61 export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
62 # CMake does not support building native binaries when cross compiling. As result
63 # it always cross compiles them for the target and then aborts when they fail to run.
64 # To work around this manually build required tools and patch cmake targets to use
65 # those native binaries we built here.
66 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -I${B} ${S}/src/camel/camel-gen-tables.c \
67 -o ${B}/src/camel/camel-gen-tables-native
68 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} -I${B} $(pkg-config-native --cflags glib-2.0) \
69 ${S}/src/addressbook/libebook-contacts/gen-western-table.c \
70 -o ${B}/src/addressbook/libebook-contacts/gen-western-table-native \
71 $(pkg-config-native --libs glib-2.0)
62} 72}
63 73
64 74