summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-04-04 01:15:33 +0200
committerKhem Raj <raj.khem@gmail.com>2019-04-06 08:22:22 -0700
commite195e7e372b8fd1b8e9f849aa7d5794fb6f40993 (patch)
treecd99c800de1de40f6bfde3d644914f33ca772d85 /meta-gnome
parentf044b936d6986185a890bc82f681b13d19ec3e9a (diff)
downloadmeta-openembedded-e195e7e372b8fd1b8e9f849aa7d5794fb6f40993.tar.gz
gvfs: Fix missing executable permission flags for files in libexec
At least XFCE sessions turned into unusable state [1] [1] http://lists.openembedded.org/pipermail/openembedded-devel/2019-April/199010.html Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
index 7b9a16e9e..df9fd50ea 100644
--- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
+++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.40.0.bb
@@ -61,8 +61,16 @@ PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse"
61# libcdio-paranoia recipe doesn't exist yet 61# libcdio-paranoia recipe doesn't exist yet
62PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" 62PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia"
63 63
64# Fix up permissions on polkit rules.d to work with rpm4 constraints
65do_install_append() { 64do_install_append() {
65 # Fix up permissions on polkit rules.d to work with rpm4 constraints
66 chmod 700 ${D}/${datadir}/polkit-1/rules.d 66 chmod 700 ${D}/${datadir}/polkit-1/rules.d
67 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d 67 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
68
69 # After rebuilds (not from scracth) it can happen that the executables in
70 # libexec ar missing executable permission flag. Not sure but it came up
71 # during transition to meson. Looked into build files and logs but could
72 # not find suspicious
73 for exe in `find ${D}/${libexec}`; do
74 chmod +x $exe
75 done
68} 76}