summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-04-24 16:32:43 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 10:00:33 +0200
commit81e1b91d81f93b39cc0731f696cee7f9031a1414 (patch)
treebcee789f2ecd5cbb2d5b99ab24a2f94b02f48c9e /meta-gnome
parentdefabe7408915c10b6df520247fa966ad0260846 (diff)
downloadmeta-openembedded-81e1b91d81f93b39cc0731f696cee7f9031a1414.tar.gz
gnome-keyring: add (from oe-core)
This was previously in oe-core but nothing there was actually using it in an image. As it's part of GNOME, move it meta-gnome. The custom service file is dropped, as upstream is now shipping and installing this file (and has been for some time). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
new file mode 100644
index 000000000..72f272257
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Password and keyring managing daemon"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://gcr/gcr.h;endline=22;md5=a272df1e633e27ecf35e74fb5576250e \
8 file://egg/egg-dbus.h;endline=25;md5=eb6f531af37165dc53420c073d774e61 \
9 file://gp11/gp11.h;endline=24;md5=bd8c7a8a21d6c28d40536d96a35e3469 \
10 file://pkcs11/pkcs11i.h;endline=24;md5=e72cfbb718389b76a4dae838d1c1f439"
11
12SECTION = "x11/gnome"
13
14PR = "r12"
15
16inherit autotools gnome gtk-doc pkgconfig gsettings
17
18DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
19RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
20
21EXTRA_OECONF = "${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
22
23SRC_URI[archive.md5sum] = "9a8aa74e03361676f29d6e73155786fc"
24SRC_URI[archive.sha256sum] = "31fecec1430a97f59a6159a5a2ea8d6a1b44287f1e9e595b3594df46bf7f18f9"
25
26FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
27
28
29FILES_${PN}-dev += "${libdir}/${BPN}/devel/*.la \
30 ${libdir}/${BPN}/devel/*${SOLIBSDEV} \
31 ${libdir}/${BPN}/standalone/*.la \
32 ${base_libdir}/security/*.la \
33 ${base_libdir}/security/*${SOLIBSDEV}"
34
35FILES_${PN}-dbg += "${libdir}/${BPN}/standalone/.debug/ \
36 ${libdir}/${BPN}/devel/.debug/ \
37 ${base_libdir}/security/.debug/"