summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorYoann Congal <yoann.congal@smile.fr>2024-09-13 00:42:51 +0200
committerKhem Raj <raj.khem@gmail.com>2024-09-12 18:25:29 -0700
commitaa88276c26b465039b45281b8c206dd5d7baa58e (patch)
tree8d14a34bc3cb65bed30b97aeb0e4a903286715e0 /meta-gnome
parentc3a115891782265654e69b041dbcccde1f7efdc2 (diff)
downloadmeta-openembedded-aa88276c26b465039b45281b8c206dd5d7baa58e.tar.gz
grilo: fix buildpaths QA error
grl-type-builtins.* are generated by glib-mkenums which leave full paths in comment and #include directives. Rewrite those before *-src packaging. Previous fix did not correct the .c file and did not work in the "devtool modify" case. Fix these errors: ERROR: grilo-0.3.16-r0 do_package_qa: QA Issue: File /usr/src/debug/grilo/0.3.16/src/grl-type-builtins.c in package grilo-src contains reference to TMPDIR [buildpaths] ERROR: grilo-0.3.16-r0 do_package_qa: QA Issue: File /usr/src/debug/grilo/0.3.16/src/grl-type-builtins.h in package grilo-src contains reference to TMPDIR [buildpaths] ERROR: grilo-0.3.16-r0 do_package_qa: Fatal QA errors were found, failing task. Signed-off-by: Yoann Congal <yoann.congal@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb b/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
index 14e1ca9fe..b6ac75dd8 100644
--- a/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
+++ b/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
@@ -26,5 +26,14 @@ PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 l
26EXTRA_OEMESON = "-Denable-grl-pls=false" 26EXTRA_OEMESON = "-Denable-grl-pls=false"
27 27
28do_compile:append() { 28do_compile:append() {
29 sed -i -e 's,${B}/../,,' ${B}/src/grl-type-builtins.h 29 # grl-type-builtins.* are generated by glib-mkenums which leave full paths
30 # in comment and #include directives. Rewrite those before *-src packaging.
31
32 # Path can be relative to B or WORKDIR in devtool modify
33 for base in ${B} ${WORKDIR} ; do
34 relpath="$(realpath --relative-to="$base" "${S}")"
35 sed -i -e "s,$base/$relpath/src/,," \
36 ${B}/src/grl-type-builtins.h \
37 ${B}/src/grl-type-builtins.c
38 done
30} 39}