diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-07-25 21:52:59 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-07-25 21:53:53 -0700 |
commit | 9cc350b4550d07555c43afafe37b7eae45f1b248 (patch) | |
tree | ded23284dad5d2c78bd9c48ac74409a981c6dcbd /meta-gnome | |
parent | 30e64975d302d69c54e56dee964e73da633e2aa9 (diff) | |
download | meta-openembedded-9cc350b4550d07555c43afafe37b7eae45f1b248.tar.gz |
sysprof: Fix build with llvm libunwind
Update status of the patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
3 files changed, 31 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch new file mode 100644 index 000000000..2dca95dac --- /dev/null +++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From a3316e607db2a64e030df8551455c5700b5ddfcf Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 25 Jul 2024 20:18:17 -0700 | ||
4 | Subject: [PATCH] libsysprof: Check for unw_set_caching_policy before using | ||
5 | |||
6 | llvm libunwind does not implement unw_cache_* functions yet | ||
7 | |||
8 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/libsysprof/preload/backtrace-helper.h | 2 ++ | ||
12 | 1 file changed, 2 insertions(+) | ||
13 | |||
14 | diff --git a/src/libsysprof/preload/backtrace-helper.h b/src/libsysprof/preload/backtrace-helper.h | ||
15 | index 88dc194..5c23ad3 100644 | ||
16 | --- a/src/libsysprof/preload/backtrace-helper.h | ||
17 | +++ b/src/libsysprof/preload/backtrace-helper.h | ||
18 | @@ -32,7 +32,9 @@ static void | ||
19 | backtrace_init (void) | ||
20 | { | ||
21 | #ifdef ENABLE_LIBUNWIND | ||
22 | +# ifdef UNW_CACHE_PER_THREAD | ||
23 | unw_set_caching_policy (unw_local_addr_space, UNW_CACHE_PER_THREAD); | ||
24 | +# endif | ||
25 | # ifdef HAVE_UNW_SET_CACHE_SIZE | ||
26 | unw_set_cache_size (unw_local_addr_space, 1024, 0); | ||
27 | #endif | ||
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch index 1082fe4ff..ea9bdb2eb 100644 --- a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch +++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch | |||
@@ -6,7 +6,7 @@ Subject: [PATCH] meson: Check for libunwind instead of libunwind-generic | |||
6 | This helps it to use llvm unwinder since libunwind-generic is specific | 6 | This helps it to use llvm unwinder since libunwind-generic is specific |
7 | to nongnu libunwind. | 7 | to nongnu libunwind. |
8 | 8 | ||
9 | Upstream-Status: Pending | 9 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95] |
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
11 | --- | 11 | --- |
12 | meson.build | 2 +- | 12 | meson.build | 2 +- |
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb index bf4ee7a73..fccca1d8f 100644 --- a/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb +++ b/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb | |||
@@ -15,7 +15,9 @@ DEPENDS += " \ | |||
15 | " | 15 | " |
16 | 16 | ||
17 | SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \ | 17 | SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \ |
18 | file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch " | 18 | file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch \ |
19 | file://0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch \ | ||
20 | " | ||
19 | SRC_URI[archive.sha256sum] = "07d9081a66cf2fb52753f48ff2b85ada75c60ff1bc1af1bd14d8aeb627972168" | 21 | SRC_URI[archive.sha256sum] = "07d9081a66cf2fb52753f48ff2b85ada75c60ff1bc1af1bd14d8aeb627972168" |
20 | 22 | ||
21 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd', '', d)} \ | 23 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd', '', d)} \ |