diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2015-09-08 17:42:59 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-23 15:37:16 +0200 |
commit | 3fc7af6b12210ff9e39ea61d93a903c6050bcc49 (patch) | |
tree | d0a67f9534d89231d8853f3395e98464d7953118 /meta-gnome | |
parent | ce03697c02ddd214745c51ce7ed35a9a9bdd3fc6 (diff) | |
download | meta-openembedded-3fc7af6b12210ff9e39ea61d93a903c6050bcc49.tar.gz |
gnome-settings-daemon: fix build for libnotify > 0.7.x
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch | 81 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb | 5 |
2 files changed, 85 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch new file mode 100644 index 000000000..6dd33f351 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/files/0001-Require-libnotify-0.6.0.patch | |||
@@ -0,0 +1,81 @@ | |||
1 | From e1ab570b0dce479ba235e5542ea07d1b5bafc4c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: William Jon McCann <jmccann@redhat.com> | ||
3 | Date: Mon, 11 Oct 2010 23:35:45 -0400 | ||
4 | Subject: [PATCH] Require libnotify 0.6.0 | ||
5 | |||
6 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
7 | |||
8 | Upstream-Status: Backport | ||
9 | |||
10 | --- | ||
11 | configure.ac | 2 +- | ||
12 | plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c | 8 ++------ | ||
13 | plugins/xrandr/gsd-xrandr-manager.c | 13 +++---------- | ||
14 | 3 files changed, 6 insertions(+), 17 deletions(-) | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 8a90053..8624b2a 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -54,7 +54,7 @@ GTK_REQUIRED_VERSION=2.91.0 | ||
21 | GCONF_REQUIRED_VERSION=2.6.1 | ||
22 | GIO_REQUIRED_VERSION=2.17.3 | ||
23 | GNOME_DESKTOP_REQUIRED_VERSION=2.29.92 | ||
24 | -LIBNOTIFY_REQUIRED_VERSION=0.4.3 | ||
25 | +LIBNOTIFY_REQUIRED_VERSION=0.6.1 | ||
26 | |||
27 | EXTRA_COMPILE_WARNINGS(yes) | ||
28 | |||
29 | diff --git a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c | ||
30 | index 9ca820a..f5964b9 100644 | ||
31 | --- a/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c | ||
32 | +++ b/plugins/a11y-keyboard/gsd-a11y-keyboard-manager.c | ||
33 | @@ -608,9 +608,7 @@ ax_slowkeys_warning_post_bubble (GsdA11yKeyboardManager *manager, | ||
34 | gsd_a11y_keyboard_manager_ensure_status_icon (manager); | ||
35 | manager->priv->notification = notify_notification_new (title, | ||
36 | message, | ||
37 | - "preferences-desktop-accessibility", | ||
38 | - NULL); | ||
39 | - notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon); | ||
40 | + "preferences-desktop-accessibility"); | ||
41 | notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000); | ||
42 | |||
43 | notify_notification_add_action (manager->priv->notification, | ||
44 | @@ -747,9 +745,7 @@ ax_stickykeys_warning_post_bubble (GsdA11yKeyboardManager *manager, | ||
45 | gsd_a11y_keyboard_manager_ensure_status_icon (manager); | ||
46 | manager->priv->notification = notify_notification_new (title, | ||
47 | message, | ||
48 | - "preferences-desktop-accessibility", | ||
49 | - NULL); | ||
50 | - notify_notification_attach_to_status_icon (manager->priv->notification, manager->priv->status_icon); | ||
51 | + "preferences-desktop-accessibility"); | ||
52 | notify_notification_set_timeout (manager->priv->notification, NOTIFICATION_TIMEOUT * 1000); | ||
53 | |||
54 | notify_notification_add_action (manager->priv->notification, | ||
55 | diff --git a/plugins/xrandr/gsd-xrandr-manager.c b/plugins/xrandr/gsd-xrandr-manager.c | ||
56 | index 02536a3..ef57d5b 100644 | ||
57 | --- a/plugins/xrandr/gsd-xrandr-manager.c | ||
58 | +++ b/plugins/xrandr/gsd-xrandr-manager.c | ||
59 | @@ -1084,16 +1084,9 @@ error_message (GsdXrandrManager *mgr, const char *primary_text, GError *error_to | ||
60 | |||
61 | g_assert (error_to_display == NULL || secondary_text == NULL); | ||
62 | |||
63 | - if (priv->status_icon) | ||
64 | - notification = notify_notification_new_with_status_icon (primary_text, | ||
65 | - error_to_display ? error_to_display->message : secondary_text, | ||
66 | - GSD_XRANDR_ICON_NAME, | ||
67 | - priv->status_icon); | ||
68 | - else | ||
69 | - notification = notify_notification_new (primary_text, | ||
70 | - error_to_display ? error_to_display->message : secondary_text, | ||
71 | - GSD_XRANDR_ICON_NAME, | ||
72 | - NULL); | ||
73 | + notification = notify_notification_new (primary_text, | ||
74 | + error_to_display ? error_to_display->message : secondary_text, | ||
75 | + GSD_XRANDR_ICON_NAME); | ||
76 | |||
77 | notify_notification_show (notification, NULL); /* NULL-GError */ | ||
78 | #else | ||
79 | -- | ||
80 | 2.1.0 | ||
81 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb index e06c5f91c..f8ece3721 100644 --- a/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb +++ b/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_2.32.1.bb | |||
@@ -8,7 +8,10 @@ DEPENDS = "intltool libxxf86misc libsndfile1 libxtst glib-2.0 polkit gtk+ gconf | |||
8 | 8 | ||
9 | inherit gnome | 9 | inherit gnome |
10 | 10 | ||
11 | SRC_URI = "git://git.gnome.org/gnome-settings-daemon;branch=gnome-2-32" | 11 | SRC_URI = " \ |
12 | git://git.gnome.org/gnome-settings-daemon;branch=gnome-2-32 \ | ||
13 | file://0001-Require-libnotify-0.6.0.patch \ | ||
14 | " | ||
12 | SRCREV = "0160f6725cfb872e017f3958f108792c3b882872" | 15 | SRCREV = "0160f6725cfb872e017f3958f108792c3b882872" |
13 | 16 | ||
14 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |