diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2019-11-02 00:26:21 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-01 17:23:21 -0700 |
commit | 39d717de36f6bc2bc99b0fc4c18bb7fa9e611d13 (patch) | |
tree | 745bc857630a22106eca6c09fa639f71e584730d /meta-gnome | |
parent | 9429dba394182d69babe3326f78211cbd2d695ba (diff) | |
download | meta-openembedded-39d717de36f6bc2bc99b0fc4c18bb7fa9e611d13.tar.gz |
ibus: initial add 1.5.21
It is a depency for gnome-shell
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
4 files changed, 146 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/ibus/ibus-native.bb b/meta-gnome/recipes-support/ibus/ibus-native.bb new file mode 100644 index 000000000..ca65114c4 --- /dev/null +++ b/meta-gnome/recipes-support/ibus/ibus-native.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | inherit native | ||
4 | |||
5 | DEPENDS += " \ | ||
6 | glib-2.0-native \ | ||
7 | dbus-native \ | ||
8 | iso-codes \ | ||
9 | " | ||
10 | |||
11 | PACKAGECONFIG = "" | ||
12 | |||
13 | # for allarch iso-codes | ||
14 | EXTRA_NATIVE_PKGCONFIG_PATH = ":${RECIPE_SYSROOT}${datadir_native}/pkgconfig" | ||
15 | # for allarch unicode-ucd - just to make configure happy | ||
16 | EXTRA_OECONF += "--with-ucd-dir=${RECIPE_SYSROOT}${datadir_native}/unicode/ucd" | ||
17 | |||
18 | do_compile() { | ||
19 | cd src | ||
20 | # seems by moving to src we break dependency tracking so build what's | ||
21 | # necessary step by step | ||
22 | oe_runmake ibusenumtypes.h | ||
23 | oe_runmake ibusmarshalers.h | ||
24 | oe_runmake ibusenumtypes.c | ||
25 | oe_runmake unicode-parser | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | install -d ${D}/${libdir} | ||
30 | install -m 755 ${S}/src/.libs/libibus-*.so* ${D}/${libdir} | ||
31 | |||
32 | install -d ${D}/${bindir} | ||
33 | install -m 755 ${S}/src/.libs/unicode-parser ${D}/${bindir} | ||
34 | } | ||
diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb new file mode 100644 index 000000000..caec455b6 --- /dev/null +++ b/meta-gnome/recipes-support/ibus/ibus.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | DEPENDS += " \ | ||
4 | ${BPN}-native \ | ||
5 | glib-2.0-native \ | ||
6 | glib-2.0 \ | ||
7 | dbus \ | ||
8 | iso-codes \ | ||
9 | " | ||
10 | |||
11 | inherit gtk-icon-cache bash-completion | ||
12 | |||
13 | # for unicode-ucd | ||
14 | EXTRA_OECONF += "--with-ucd-dir=${STAGING_DATADIR}/unicode/ucd" | ||
15 | |||
16 | PACKAGECONFIG ??= " \ | ||
17 | dconf vala \ | ||
18 | ${@bb.utils.contains_any('DISTRO_FEATURES', [ 'wayland', 'x11' ], 'gtk3', '', d)} \ | ||
19 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \ | ||
20 | " | ||
21 | |||
22 | do_configure_prepend() { | ||
23 | # run native unicode-parser | ||
24 | sed -i 's:$(builddir)/unicode-parser:unicode-parser:g' ${S}/src/Makefile.am | ||
25 | } | ||
26 | |||
27 | FILES_${PN} += " \ | ||
28 | ${datadir}/dbus-1 \ | ||
29 | ${datadir}/GConf \ | ||
30 | ${datadir}/glib-2.0 \ | ||
31 | ${libdir}/gtk-3.0 \ | ||
32 | " | ||
33 | |||
34 | FILES_${PN}-dev += " \ | ||
35 | ${datadir}/gettext \ | ||
36 | " | ||
37 | |||
diff --git a/meta-gnome/recipes-support/ibus/ibus.inc b/meta-gnome/recipes-support/ibus/ibus.inc new file mode 100644 index 000000000..0f4ae7d04 --- /dev/null +++ b/meta-gnome/recipes-support/ibus/ibus.inc | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "Intelligent Input Bus for Linux/Unix" | ||
2 | HOMEPAGE = "https://github.com/ibus/ibus/wiki" | ||
3 | LICENSE = "LGPLv2.1" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
5 | |||
6 | inherit autotools-brokensep pkgconfig gobject-introspection gettext gtk-doc vala | ||
7 | |||
8 | PV = "1.5.21" | ||
9 | |||
10 | DEPENDS = "unicode-ucd" | ||
11 | |||
12 | SRC_URI = " \ | ||
13 | git://github.com/ibus/ibus.git \ | ||
14 | file://0001-Do-not-try-to-start-dbus-we-do-not-have-dbus-lauch.patch \ | ||
15 | " | ||
16 | SRCREV = "ae0040c73466bb6e78fce5e669a55fcce6ffd16d" | ||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | PACKAGECONFIG[appindicator] = "--enable-appindicator,--disable-appindicator,qtbase" | ||
20 | PACKAGECONFIG[dconf] = "--enable-dconf,--disable-dconf,dconf" | ||
21 | PACKAGECONFIG[gtk2] = "--enable-gtk2,--disable-gtk2,gtk+" | ||
22 | PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3" | ||
23 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland" | ||
24 | PACKAGECONFIG[vala] = "--enable-vala,--disable-vala" | ||
25 | PACKAGECONFIG[x11] = "--enable-xim --enable-ui,--disable-xim --disable-ui,virtual/libx11" | ||
26 | |||
27 | EXTRA_OECONF = " \ | ||
28 | --disable-tests \ | ||
29 | --disable-emoji-dict \ | ||
30 | --disable-python2 \ | ||
31 | " | ||
32 | |||
33 | do_configure_prepend() { | ||
34 | touch ${S}/ChangeLog | ||
35 | touch ${S}/ABOUT-NLS | ||
36 | } | ||
diff --git a/meta-gnome/recipes-support/ibus/ibus/0001-Do-not-try-to-start-dbus-we-do-not-have-dbus-lauch.patch b/meta-gnome/recipes-support/ibus/ibus/0001-Do-not-try-to-start-dbus-we-do-not-have-dbus-lauch.patch new file mode 100644 index 000000000..3701d19f5 --- /dev/null +++ b/meta-gnome/recipes-support/ibus/ibus/0001-Do-not-try-to-start-dbus-we-do-not-have-dbus-lauch.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From f567bcbc2108d722faa90afeb03d3a3bcdf5f58b Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Fri, 10 May 2019 14:30:08 +0200 | ||
4 | Subject: [PATCH] Do not try to start dbus - we do not have dbus-lauch | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE specific] | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | data/dconf/make-dconf-override-db.sh | 6 ------ | ||
14 | 1 file changed, 6 deletions(-) | ||
15 | |||
16 | diff --git a/data/dconf/make-dconf-override-db.sh b/data/dconf/make-dconf-override-db.sh | ||
17 | index 9c650e97..02fbf059 100755 | ||
18 | --- a/data/dconf/make-dconf-override-db.sh | ||
19 | +++ b/data/dconf/make-dconf-override-db.sh | ||
20 | @@ -12,10 +12,6 @@ export XDG_CACHE_HOME="$TMPDIR/cache" | ||
21 | export GSETTINGS_SCHEMA_DIR="$TMPDIR/schemas" | ||
22 | mkdir -p $XDG_CONFIG_HOME $XDG_CACHE_HOME $GSETTINGS_SCHEMA_DIR | ||
23 | |||
24 | -eval `dbus-launch --sh-syntax` | ||
25 | - | ||
26 | -trap 'rm -rf $TMPDIR; kill $DBUS_SESSION_BUS_PID' ERR | ||
27 | - | ||
28 | # in case that schema is not installed on the system | ||
29 | glib-compile-schemas --targetdir "$GSETTINGS_SCHEMA_DIR" "$PWD" | ||
30 | |||
31 | @@ -46,5 +42,3 @@ for schema in $schemas; do | ||
32 | done | ||
33 | |||
34 | rm -rf $TMPDIR | ||
35 | - | ||
36 | -kill $DBUS_SESSION_BUS_PID | ||
37 | -- | ||
38 | 2.20.1 | ||
39 | |||