diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2014-08-01 15:34:56 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-05 12:02:41 +0200 |
commit | 33cf1670425ea9d7667f1cc358a86568846b3648 (patch) | |
tree | 2425eaa078ac2ed99a9f23c1016b8276ad3a2960 /meta-gnome | |
parent | d35ade7045b019504cc445e9d751cef71ebbf0c9 (diff) | |
download | meta-openembedded-33cf1670425ea9d7667f1cc358a86568846b3648.tar.gz |
libgnomeprint: use pkgconfig for freetype support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomeprint/0001-configure-use-pkgconfig-for-freetype.patch | 37 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb | 5 |
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint/0001-configure-use-pkgconfig-for-freetype.patch b/meta-gnome/recipes-gnome/gnome/libgnomeprint/0001-configure-use-pkgconfig-for-freetype.patch new file mode 100644 index 000000000..174985a7e --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint/0001-configure-use-pkgconfig-for-freetype.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From ed31fd89f4c77d89390774d29427898a85b25ab1 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 1 Aug 2014 13:58:36 +0200 | ||
4 | Subject: [PATCH] configure: use pkgconfig for freetype | ||
5 | |||
6 | Upstream-status: Pending | ||
7 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
8 | --- | ||
9 | configure.in | 12 +++++------- | ||
10 | 1 file changed, 5 insertions(+), 7 deletions(-) | ||
11 | |||
12 | diff --git a/configure.in b/configure.in | ||
13 | index 729278d..e569429 100644 | ||
14 | --- a/configure.in | ||
15 | +++ b/configure.in | ||
16 | @@ -164,13 +164,11 @@ dnl Checking for freetype2 | ||
17 | dnl ================================= | ||
18 | FREETYPE_LIBS= | ||
19 | FREETYPE_CFLAGS= | ||
20 | -AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no) | ||
21 | -if test "x$FREETYPE_CONFIG" = "xno" ; then | ||
22 | - AC_MSG_ERROR(You need FreeType2 (freetype-devel v 2.x package) for this version of libgnomeprint) | ||
23 | -else | ||
24 | - FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags` | ||
25 | - FREETYPE_LIBS=`$FREETYPE_CONFIG --libs` | ||
26 | -fi | ||
27 | +PKG_CHECK_MODULES(FREETYPE2, freetype2, | ||
28 | + FREETYPE_CFLAGS="$CFLAGS $FREETYPE2_CFLAGS" | ||
29 | + FREETYPE_LIBS="$LIBS $FREETYPE2_LIBS", | ||
30 | + AC_MSG_ERROR([*** Unable to find FreeType2 library (http://www.freetype.org/)]) | ||
31 | +) | ||
32 | |||
33 | libgnomeprint_save_ldflags=$LDFLAGS | ||
34 | LDFLAGS="$LDFLAGS $FREETYPE_LIBS" | ||
35 | -- | ||
36 | 1.9.0 | ||
37 | |||
diff --git a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb index c5fd15258..15e513a78 100644 --- a/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb +++ b/meta-gnome/recipes-gnome/gnome/libgnomeprint_2.18.8.bb | |||
@@ -1,10 +1,6 @@ | |||
1 | LICENSE = "GPLv2" | 1 | LICENSE = "GPLv2" |
2 | SECTION = "x11/gnome/libs" | 2 | SECTION = "x11/gnome/libs" |
3 | 3 | ||
4 | # | checking for freetype-config... no | ||
5 | # | configure: error: You need FreeType2 (freetype-devel v 2.x package) for this version of libgnomeprint | ||
6 | PNBLACKLIST[libgnomeprint] = "Broken without freetype-config" | ||
7 | |||
8 | DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype" | 4 | DEPENDS = "libxml2 libgnomecups glib-2.0 pango libart-lgpl fontconfig popt gnome-common freetype" |
9 | 5 | ||
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
@@ -13,6 +9,7 @@ inherit pkgconfig gnomebase | |||
13 | 9 | ||
14 | SRC_URI += "file://fix.includes.patch \ | 10 | SRC_URI += "file://fix.includes.patch \ |
15 | file://freetype.patch \ | 11 | file://freetype.patch \ |
12 | file://0001-configure-use-pkgconfig-for-freetype.patch \ | ||
16 | " | 13 | " |
17 | SRC_URI[archive.md5sum] = "63b05ffb5386e131487c6af30f4c56ac" | 14 | SRC_URI[archive.md5sum] = "63b05ffb5386e131487c6af30f4c56ac" |
18 | SRC_URI[archive.sha256sum] = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691" | 15 | SRC_URI[archive.sha256sum] = "1034ec8651051f84d2424e7a1da61c530422cc20ce5b2d9e107e1e46778d9691" |