diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-02 09:32:57 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-11 01:52:53 +0100 |
commit | 2d44b0925ea368ddbee790925e9a432356a8eedd (patch) | |
tree | c40acfe670818edf4392389c10ec7dfe23c77423 /meta-gnome | |
parent | 8c9b3585d955b22ce810a639f50ce094c5e49572 (diff) | |
download | meta-openembedded-2d44b0925ea368ddbee790925e9a432356a8eedd.tar.gz |
epdfview: move from meta-efl to meta-gnome
* as suggested in http://lists.linuxtogo.org/pipermail/openembedded-devel/2012-November/042449.html
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
5 files changed, 117 insertions, 0 deletions
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch b/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch new file mode 100644 index 000000000..75e45e0ab --- /dev/null +++ b/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/Config.cxx b/src/Config.cxx | ||
6 | index 28f37ab..bc58819 100644 | ||
7 | --- a/src/Config.cxx | ||
8 | +++ b/src/Config.cxx | ||
9 | @@ -22,7 +22,7 @@ | ||
10 | using namespace ePDFView; | ||
11 | |||
12 | // Constants | ||
13 | -static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "firefox %s"; | ||
14 | +static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "x-www-browser %s"; | ||
15 | static const gchar *DEFAULT_OPEN_FILE_FOLDER = NULL; | ||
16 | static const gchar *DEFAULT_SAVE_FILE_FOLDER = NULL; | ||
17 | static const gboolean DEFAULT_SHOW_STATUSBAR = TRUE; | ||
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch b/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch new file mode 100644 index 000000000..8ad5b97ca --- /dev/null +++ b/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/gtk/MainView.cxx b/src/gtk/MainView.cxx | ||
6 | index b983bff..f87de28 100644 | ||
7 | --- a/src/gtk/MainView.cxx | ||
8 | +++ b/src/gtk/MainView.cxx | ||
9 | @@ -634,8 +634,9 @@ MainView::showErrorMessage (const gchar *title, const gchar *body) | ||
10 | GTK_DIALOG_DESTROY_WITH_PARENT, | ||
11 | GTK_MESSAGE_ERROR, | ||
12 | GTK_BUTTONS_OK, | ||
13 | + "%s", | ||
14 | title); | ||
15 | - gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), | ||
16 | + gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), "%s", | ||
17 | body); | ||
18 | gtk_dialog_run (GTK_DIALOG (errorDialog)); | ||
19 | gtk_widget_destroy (errorDialog); | ||
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch b/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch new file mode 100644 index 000000000..84a491386 --- /dev/null +++ b/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/gtk/StockIcons.h b/src/gtk/StockIcons.h | ||
6 | index c142a7a..58fcf2e 100644 | ||
7 | --- a/src/gtk/StockIcons.h | ||
8 | +++ b/src/gtk/StockIcons.h | ||
9 | @@ -18,7 +18,7 @@ | ||
10 | #if !defined (__STOCK_ICONS_H__) | ||
11 | #define __STOCK_ICONS_H__ | ||
12 | |||
13 | -#include <glib/gmacros.h> | ||
14 | +#include <glib.h> | ||
15 | |||
16 | G_BEGIN_DECLS | ||
17 | |||
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch b/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch new file mode 100644 index 000000000..282bfb184 --- /dev/null +++ b/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | Index: trunk/src/PDFDocument.cxx | ||
6 | =================================================================== | ||
7 | --- trunk/src/PDFDocument.cxx (revision 361) | ||
8 | +++ trunk/src/PDFDocument.cxx (revision 367) | ||
9 | @@ -21,4 +21,5 @@ | ||
10 | #include <poppler.h> | ||
11 | #include <unistd.h> | ||
12 | +#include <algorithm> | ||
13 | #include "epdfview.h" | ||
14 | |||
15 | @@ -33,4 +34,22 @@ | ||
16 | static PageMode convertPageMode (gint pageMode); | ||
17 | static gchar *getAbsoluteFileName (const gchar *fileName); | ||
18 | + | ||
19 | +namespace | ||
20 | +{ | ||
21 | + void | ||
22 | + convert_bgra_to_rgba (guint8 *data, int width, int height) | ||
23 | + { | ||
24 | + using std::swap; | ||
25 | + | ||
26 | + for (int y = 0; y < height; y++) | ||
27 | + { | ||
28 | + for (int x = 0; x < width; x++) | ||
29 | + { | ||
30 | + swap(data[0], data[2]); | ||
31 | + data += 4; | ||
32 | + } | ||
33 | + } | ||
34 | + } | ||
35 | +} | ||
36 | |||
37 | /// | ||
38 | @@ -651,4 +670,5 @@ | ||
39 | cairo_destroy(context); | ||
40 | cairo_surface_destroy (surface); | ||
41 | + convert_bgra_to_rgba(renderedPage->getData (), width, height); | ||
42 | #else // !HAVE_POPPLER_0_17_0 | ||
43 | // Create the pixbuf from the data and render to it. | ||
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb b/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb new file mode 100644 index 000000000..53951e1d2 --- /dev/null +++ b/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "A lightweight PDF viewer based on gtk and poppler" | ||
2 | HOMEPAGE = "http://www.emma-soft.com/projects/epdfview/" | ||
3 | LICENSE = "GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
5 | SECTION = "x11/applications" | ||
6 | DEPENDS = "gtk+ poppler" | ||
7 | |||
8 | PR = "r3" | ||
9 | |||
10 | EXTRA_OECONF += "--without-cups" | ||
11 | |||
12 | inherit autotools gettext | ||
13 | |||
14 | SRC_URI = "http://www.emma-soft.com/projects/${BPN}/chrome/site/releases/${BP}.tar.bz2 \ | ||
15 | file://browser_command.patch \ | ||
16 | file://fix-format.patch \ | ||
17 | file://glib-single-include.patch \ | ||
18 | file://swap-colors.patch \ | ||
19 | " | ||
20 | SRC_URI[md5sum] = "e50285b01612169b2594fea375f53ae4" | ||
21 | SRC_URI[sha256sum] = "948648ae7c9d7b3b408d738bd4f48d87375b1196cae1129d6b846a8de0f2f8f0" | ||