summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-01-17 09:34:11 +0100
committerArmin Kuster <akuster808@gmail.com>2018-01-22 19:40:02 -0800
commitdb39cbcd42d523892012935f3d6972f62e4b0a35 (patch)
tree4b6b3336b8b8c58b34a32f63c8ce6348463e743b /meta-gnome
parent8742b94ae895b58d0b179f6bb106a26cc2cb25ef (diff)
downloadmeta-openembedded-db39cbcd42d523892012935f3d6972f62e4b0a35.tar.gz
evolution-data-server: update 3.2.3 -> 3.26.3
In recent meta-universe 3.2.3 started to fail with: | camel-enumtypes.c:42:7: error: expected expression at end of input | { 512, "CAMEL_FOLDER_SHARED_BY_ME", "shared-by-me" }, | ^ Instead of cleaning I decided to update. The following changed: * eds builds with cmake instead of autotools * musl: I checked src/time/strftime.c and it seems strftime does not support '%l' / '%k'. musl-case was added to be a good boy but was not tested. * remove 0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch: src/camel/providers/imapx/camel-imapx-tokens.txt has text-only format these days * remove 0002-Fix-for-automake-1.12.x.patch: autotools was replaced by cmake * remove 0003-Disable-Werror-for-automake.patch: autotools was replaced by cmake * remove 0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch: autotools was replaced by cmake * remove 0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch: src/calendar/backends/caldav/e-cal-backend-caldav.c was reworked competely * remove 0006-configure.ac-do-not-overwrite-localedir.patch: autotools was replaced by cmake Tested: abiword build and run Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch39
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch33
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch53
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch32
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch97
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch)21
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch39
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch77
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch34
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb)84
10 files changed, 144 insertions, 365 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
new file mode 100644
index 000000000..a821a14ab
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
@@ -0,0 +1,39 @@
1From 131b88a81aba3d72d566bc8a9d968941a98e0007 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Tue, 19 Dec 2017 16:37:20 +0100
4Subject: [PATCH] CMakeLists.txt: Remove TRY_RUN for iconv
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9| CMake Error: TRY_RUN() invoked in cross-compiling mode, please set the following cache variables appropriately:
10| _correct_iconv_EXITCODE (advanced)
11
12Upstream-Status: Inappropriate [OE specific]
13
14Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
15---
16 CMakeLists.txt | 5 -----
17 1 file changed, 5 deletions(-)
18
19diff --git a/CMakeLists.txt b/CMakeLists.txt
20index 8d07772..a2396f2 100644
21--- a/CMakeLists.txt
22+++ b/CMakeLists.txt
23@@ -521,13 +521,8 @@ if(NOT HAVE_ICONV)
24 endif(NOT HAVE_ICONV)
25
26 set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS})
27-CHECK_C_SOURCE_RUNS("#include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv)
28 unset(CMAKE_REQUIRED_LIBRARIES)
29
30-if(NOT _correct_iconv)
31- message(FATAL_ERROR "You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv")
32-endif(NOT _correct_iconv)
33-
34 # ******************************
35 # Backtraces for debugging
36 # ******************************
37--
382.14.3
39
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
deleted file mode 100644
index f82a76df3..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 0e10e976025b21d12df099e82951f759024ad649 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 24 Aug 2017 22:04:56 -0700
4Subject: [PATCH] imapx: Fix signature for imapx_tokenise_struct()
5
6clang complains about different signature for this patch
7
8Fixes
9camel/providers/imapx/camel-imapx-tokens.txt:56:1: error: conflicting types for 'imapx_tokenise_struct'
10| imapx_tokenise_struct (register const char *str, register size_t len)
11| ^
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 camel/providers/imapx/camel-imapx-tokens.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/camel/providers/imapx/camel-imapx-tokens.txt b/camel/providers/imapx/camel-imapx-tokens.txt
19index d48501865..994c368c0 100644
20--- a/camel/providers/imapx/camel-imapx-tokens.txt
21+++ b/camel/providers/imapx/camel-imapx-tokens.txt
22@@ -1,7 +1,7 @@
23 /* This contains all of the keywords we care about. These
24 can be converted to an id very efficiently */
25 struct _imapx_keyword {const gchar *name; camel_imapx_id_t id; };
26-struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register unsigned int len);
27+struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register size_t len);
28 %%
29 ALERT, IMAPX_ALERT
30 APPENDUID, IMAPX_APPENDUID
31--
322.14.1
33
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
new file mode 100644
index 000000000..c8dc7e12c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
@@ -0,0 +1,53 @@
1From 210b204d9edd71202454ff04013cc52b23c598e4 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Tue, 19 Dec 2017 16:55:13 +0100
4Subject: [PATCH] CMakeLists.txt: remove CHECK_C_SOURCE_RUNS check
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9* TRY_RUN: does not work for OE
10* HAVE_LKSTRFTIME is set by recipe as configure option
11
12Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
13---
14 CMakeLists.txt | 23 -----------------------
15 1 file changed, 23 deletions(-)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index a2396f2..f3b271b 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -573,29 +573,6 @@ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
22 CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
23 int main(void) { char *detail = nl_langinfo (_NL_ADDRESS_COUNTRY_AB2); return 0; }" HAVE__NL_ADDRESS_COUNTRY_AB2)
24
25-# *******************************************************
26-# Check to see if strftime supports the use of %l and %k
27-# *******************************************************
28-
29-CHECK_C_SOURCE_RUNS("
30- #include <stdlib.h>
31- #include <string.h>
32- #include <time.h>
33- int main(int argc, char **argv) {
34- char buf[10];
35- time_t rawtime;
36- struct tm *timeinfo;
37-
38- time(&rawtime);
39- timeinfo=localtime(&rawtime);
40- buf[0] = 0;
41- strftime(buf, 10, \"%lx%k\", timeinfo);
42-
43- if (!buf[0] || buf[0] == 'x' || strstr(buf, \"l\") || strstr(buf, \"k\"))
44- return 1;
45- return 0;
46- }" HAVE_LKSTRFTIME)
47-
48 # ******************************
49 # system mail stuff
50 # ******************************
51--
522.14.3
53
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch
deleted file mode 100644
index 5f222aeaa..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From f46423c9e4b8b19eda27b307456a717de79b75f3 Mon Sep 17 00:00:00 2001
2From: Nitin A Kamble <nitin.a.kamble@intel.com>
3Date: Sun, 4 Aug 2013 09:15:43 +0200
4Subject: [PATCH 2/5] Fix for automake-1.12.x
5
6Fixed these kinds if warning-errors
7
8warning: 'libebookbackendfile.la': linking libtool libraries using a non-POSIX archiver requires 'AM_PROG_AR' in 'configure.ac'
9
10Upstream-Status: Pending
11
12Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
13Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
14---
15 configure.ac | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/configure.ac b/configure.ac
19index 9bd97db..49d7506 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -31,6 +31,7 @@ AC_LANG(C)
23
24 dnl Automake 1.11 - Silent Build Rules
25 m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
26+m4_ifdef([AM_PROG_AR], [AM_PROG_AR]) # required by automake 1.12
27
28 dnl Required Package Versions
29 m4_define([glib_minimum_version], [2.28])
30--
311.8.3.2
32
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch
deleted file mode 100644
index a182d4d5e..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch
+++ /dev/null
@@ -1,97 +0,0 @@
1From 37b227cff78fd4c652651662dafd71537280824e Mon Sep 17 00:00:00 2001
2From: Nitin A Kamble <nitin.a.kamble@intel.com>
3Date: Sun, 4 Aug 2013 09:16:59 +0200
4Subject: [PATCH 3/5] Disable Werror for automake
5
6Avoid these warning-errors
7
8automake: warnings are treated as errors
9Makefile.am:15: warning: '%'-style pattern rules are a GNU make extension
10Makefile.am:21: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
11addressbook/backends/file/Makefile.am: installing './depcomp'
12addressbook/libebook/Makefile.am:55: warning: '%'-style pattern rules are a GNU make extension
13addressbook/libebook/Makefile.am:65: warning: '%'-style pattern rules are a GNU make extension
14addressbook/libebook/Makefile.am:66: warning: subst -,_,$*: non-POSIX variable name
15addressbook/libebook/Makefile.am:66: (probably a GNU make extension)
16addressbook/libebook/Makefile.am:72: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
17addressbook/libedata-book/Makefile.am:2: warning: '%'-style pattern rules are a GNU make extension
18addressbook/libedata-book/Makefile.am:3: warning: subst -,_,$*: non-POSIX variable name
19addressbook/libedata-book/Makefile.am:3: (probably a GNU make extension)
20glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
21addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
22glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
23addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
24glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
25addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
26glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
27addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
28glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
29addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
30glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
31addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
32addressbook/libedata-book/Makefile.am:86: warning: '%'-style pattern rules are a GNU make extension
33addressbook/libedata-book/Makefile.am:101: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
34calendar/backends/weather/Makefile.am:44: warning: '%'-style pattern rules are a GNU make extension
35calendar/libecal/Makefile.am:53: warning: '%'-style pattern rules are a GNU make extension
36calendar/libecal/Makefile.am:61: warning: '%'-style pattern rules are a GNU make extension
37calendar/libecal/Makefile.am:62: warning: subst -,_,$*: non-POSIX variable name
38calendar/libecal/Makefile.am:62: (probably a GNU make extension) calendar/libecal/Makefile.am:68: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
39calendar/libedata-cal/Makefile.am:5: warning: '%'-style pattern rules are a GNU make extension
40calendar/libedata-cal/Makefile.am:6: warning: subst -,_,$*: non-POSIX variable name
41calendar/libedata-cal/Makefile.am:6: (probably a GNU make extension)
42glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
43calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
44glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
45calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
46glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
47calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
48glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
49calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
50glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
51calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
52glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
53calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
54calendar/libedata-cal/Makefile.am:71: warning: '%'-style pattern rules are a GNU make extension
55calendar/libedata-cal/Makefile.am:86: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
56camel/Makefile.am:17: warning: '%'-style pattern rules are a GNU make extension
57libebackend/Makefile.am:35: warning: '%'-style pattern rules are a GNU make extension
58libebackend/Makefile.am:41: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
59libedataserver/Makefile.am:91: warning: '%'-style pattern rules are a GNU make extension
60libedataserver/Makefile.am:97: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
61libedataserverui/Makefile.am:108: warning: '%'-style pattern rules are a GNU make extension
62libedataserverui/Makefile.am:118: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
63servers/google/libgdata-google/Makefile.am:27: warning: '%'-style pattern rules are a GNU make extension
64servers/google/libgdata-google/Makefile.am:33: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
65servers/google/libgdata/Makefile.am:31: warning: '%'-style pattern rules are a GNU make extension
66servers/google/libgdata/Makefile.am:37: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
67servers/groupwise/Makefile.am:85: warning: '%'-style pattern rules are a GNU make extension
68servers/groupwise/Makefile.am:91: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
69autoreconf: automake failed with exit status: 1
70
71Upstream-Status: Inappropriate [embedded specific]
72
73Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
74Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
75
76Conflicts:
77 configure.ac
78---
79 configure.ac | 2 +-
80 1 file changed, 1 insertion(+), 1 deletion(-)
81
82diff --git a/configure.ac b/configure.ac
83index 49d7506..1c802ff 100644
84--- a/configure.ac
85+++ b/configure.ac
86@@ -21,7 +21,7 @@ m4_define([api_version], [1.2])
87 dnl Autoconf / Automake Initialization
88 AC_PREREQ(2.62)
89 AC_INIT([evolution-data-server],[eds_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution-Data-Server])
90-AM_INIT_AUTOMAKE([gnu 1.10 tar-ustar dist-xz no-dist-gzip -Wall -Wno-portability -Werror foreign])
91+AM_INIT_AUTOMAKE([gnu 1.10 tar-ustar dist-xz no-dist-gzip -Wall -Wno-portability foreign])
92 AC_CONFIG_MACRO_DIR([m4])
93 AC_CONFIG_SRCDIR(README)
94 AC_CONFIG_HEADERS(config.h)
95--
961.8.3.2
97
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
index b77e7b9bd..3cdfa8b6f 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
@@ -7,26 +7,13 @@ Subject: [PATCH 1/5] contact: Replace the Novell sample contact with something
7Upstream-Status: Inappropriate [configuration] 7Upstream-Status: Inappropriate [configuration]
8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> 8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
9--- 9---
10 addressbook/backends/file/Makefile.am | 1 + 10 src/addressbook/libedata-book/ximian-vcard.h | 179 ++++++++++++++++++-------------
11 addressbook/libedata-book/ximian-vcard.h | 179 ++++++++++++++++++-------------
12 2 files changed, 103 insertions(+), 77 deletions(-) 11 2 files changed, 103 insertions(+), 77 deletions(-)
13 12
14diff --git a/addressbook/backends/file/Makefile.am b/addressbook/backends/file/Makefile.am 13diff --git a/src/addressbook/libedata-book/ximian-vcard.h b/src/addressbook/libedata-book/ximian-vcard.h
15index 08cf58f..17e7149 100644
16--- a/addressbook/backends/file/Makefile.am
17+++ b/addressbook/backends/file/Makefile.am
18@@ -2,6 +2,7 @@ ebook_backend_LTLIBRARIES = libebookbackendfile.la
19
20 libebookbackendfile_la_CPPFLAGS = \
21 $(AM_CPPFLAGS) \
22+ -DCREATE_DEFAULT_VCARD \
23 -DG_LOG_DOMAIN=\"libebookbackend\" \
24 -I$(top_srcdir) \
25 -I$(top_builddir) \
26diff --git a/addressbook/libedata-book/ximian-vcard.h b/addressbook/libedata-book/ximian-vcard.h
27index 782d37b..5b0b250 100644 14index 782d37b..5b0b250 100644
28--- a/addressbook/libedata-book/ximian-vcard.h 15--- a/src/addressbook/libedata-book/ximian-vcard.h
29+++ b/addressbook/libedata-book/ximian-vcard.h 16+++ b/src/addressbook/libedata-book/ximian-vcard.h
30@@ -1,80 +1,105 @@ 17@@ -1,80 +1,105 @@
31 #define XIMIAN_VCARD \ 18 #define XIMIAN_VCARD \
32 "BEGIN:VCARD\n" \ 19 "BEGIN:VCARD\n" \
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch
deleted file mode 100644
index 138334798..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 2c73b588b9018cb59c666eae3a15fa1af42c56be Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 4 Aug 2013 10:57:08 +0200
4Subject: [PATCH 4/5] configure: Fix libical pkg-config trying to use host
5 paths
6
7Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
8---
9 calendar/libecal/libecal.pc.in | 2 +-
10 configure.ac | 3 ++-
11 2 files changed, 3 insertions(+), 2 deletions(-)
12
13diff --git a/calendar/libecal/libecal.pc.in b/calendar/libecal/libecal.pc.in
14index fc6b359..d3435bb 100644
15--- a/calendar/libecal/libecal.pc.in
16+++ b/calendar/libecal/libecal.pc.in
17@@ -12,4 +12,4 @@ Description: Client library for evolution calendars
18 Version: @VERSION@
19 Requires: libical >= @LIBICAL_REQUIRED@ libedataserver-1.2 gio-2.0
20 Libs: -L${libdir} -lecal-1.2
21-Cflags: -I${privincludedir} @LIBICAL_EXTRA_CFLAGS@
22+Cflags: -I${privincludedir}
23diff --git a/configure.ac b/configure.ac
24index 1c802ff..f1d4ce8 100644
25--- a/configure.ac
26+++ b/configure.ac
27@@ -1351,7 +1351,8 @@ dnl to differentiate between <libical/ical.h> and <ical.h>
28 dnl We have fixed all our instances to use <libical/ical.h>. Until the .pc from
29 dnl libical is fixed, we have to work-around the buggy CFlags.
30 dnl *****
31- LIBICAL_EXTRA_CFLAGS=" -I`$PKG_CONFIG --variable=includedir libical` "
32+ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
33+ LIBICAL_EXTRA_CFLAGS=" -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=includedir libical` "
34 LIBICAL_EXTRA_LIBS=""
35 AC_SUBST(LIBICAL_EXTRA_CFLAGS)
36 AC_SUBST(LIBICAL_EXTRA_LIBS)
37--
381.8.3.2
39
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
deleted file mode 100644
index addf2ee8d..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1From ac95e89749a01618f98b554a98e78d7c988bfc10 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 27 Nov 2012 08:46:51 +0100
4Subject: [PATCH 5/5] soup: adapt to new libxml2 API from 2.9.0
5
6* for more info see
7 https://mail.gnome.org/archives/xml/2012-August/msg00005.html
8
9Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
10---
11 calendar/backends/caldav/e-cal-backend-caldav.c | 21 +++++++++++++++++++++
12 1 file changed, 21 insertions(+)
13
14diff --git a/calendar/backends/caldav/e-cal-backend-caldav.c b/calendar/backends/caldav/e-cal-backend-caldav.c
15index 12f8f22..5555a3e 100644
16--- a/calendar/backends/caldav/e-cal-backend-caldav.c
17+++ b/calendar/backends/caldav/e-cal-backend-caldav.c
18@@ -1172,8 +1172,13 @@ check_calendar_changed_on_server (ECalBackendCalDAV *cbdav)
19 soup_message_set_request (message,
20 "application/xml",
21 SOUP_MEMORY_COPY,
22+#ifdef LIBXML2_NEW_BUFFER
23+ (gchar *) xmlOutputBufferGetContent(buf),
24+ xmlOutputBufferGetSize(buf));
25+#else
26 (gchar *) buf->buffer->content,
27 buf->buffer->use);
28+#endif
29
30 /* Send the request now */
31 send_and_handle_redirection (priv->session, message, NULL);
32@@ -1321,8 +1326,13 @@ caldav_server_list_objects (ECalBackendCalDAV *cbdav,
33 soup_message_set_request (message,
34 "application/xml",
35 SOUP_MEMORY_COPY,
36+#ifdef LIBXML2_NEW_BUFFER
37+ (gchar *) xmlOutputBufferGetContent(buf),
38+ xmlOutputBufferGetSize(buf));
39+#else
40 (gchar *) buf->buffer->content,
41 buf->buffer->use);
42+#endif
43
44 /* Send the request now */
45 send_and_handle_redirection (priv->session, message, NULL);
46@@ -1715,8 +1725,14 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
47 soup_message_set_request (message,
48 "application/xml",
49 SOUP_MEMORY_COPY,
50+#ifdef LIBXML2_NEW_BUFFER
51+ (gchar *) xmlOutputBufferGetContent(buf),
52+ xmlOutputBufferGetSize(buf));
53+#else
54 (gchar *) buf->buffer->content,
55 buf->buffer->use);
56+#endif
57+
58
59 /* Send the request now */
60 send_and_handle_redirection (priv->session, message, NULL);
61@@ -1765,8 +1781,13 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
62 soup_message_set_request (message,
63 "application/xml",
64 SOUP_MEMORY_COPY,
65+#ifdef LIBXML2_NEW_BUFFER
66+ (gchar *) xmlOutputBufferGetContent(buf),
67+ xmlOutputBufferGetSize(buf));
68+#else
69 (gchar *) buf->buffer->content,
70 buf->buffer->use);
71+#endif
72
73 /* Send the request now */
74 send_and_handle_redirection (priv->session, message, NULL);
75--
761.8.3.2
77
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch
deleted file mode 100644
index 741e5e97d..000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 3feaea8e84b3ad8dc2d551e42224f3b4a9413e7d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 3 Sep 2015 11:14:24 +0200
4Subject: [PATCH] configure.ac: do not overwrite localedir
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Backport [1]
10
11[1] https://git.gnome.org/browse/evolution-data-server/tree/configure.ac#n298
12
13Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
14---
15 configure.ac | 3 ---
16 1 file changed, 3 deletions(-)
17
18diff --git a/configure.ac b/configure.ac
19index f1d4ce8..cee847f 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -257,9 +257,6 @@ GETTEXT_PACKAGE=evolution-data-server-$BASE_VERSION
23 AC_SUBST(GETTEXT_PACKAGE)
24 AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Package name for gettext])
25
26-localedir='$(prefix)/$(DATADIRNAME)/locale'
27-AC_SUBST(localedir)
28-
29 dnl ******************************
30 dnl Initialize libtool
31 dnl ******************************
32--
332.1.0
34
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb
index aadc4b5e3..2d410e246 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.26.3.bb
@@ -4,58 +4,70 @@ BUGTRACKER = "https://bugzilla.gnome.org/"
4 4
5LICENSE = "LGPLv2 & LGPLv2+" 5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \ 6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://camel/camel.h;endline=24;md5=b02175c88f821224746b347a89731a2b \ 7 file://src/camel/camel.h;endline=24;md5=342fc5e9357254bc30c24e43ae47d9a1 \
8 file://libedataserver/e-data-server-util.h;endline=20;md5=934502f03c84523aa059d4825887b380 \ 8 file://src/libedataserver/e-data-server-util.h;endline=20;md5=8f21a9c80ea82a4fb80b5f959f672543 \
9 file://calendar/libecal/e-cal.h;endline=24;md5=5d496b9b6fd2a4fdbbfc31ef9455c9d0" 9 file://src/calendar/libecal/e-cal.h;endline=24;md5=e699ec3866f73f129f7a4ffffdcfc196"
10 10
11DEPENDS = "intltool-native glib-2.0 gtk+3 gconf dbus db virtual/libiconv zlib libsoup-2.4 libglade libical libgnome-keyring gperf-native libgdata nss" 11DEPENDS = " \
12 12 intltool-native gperf-native \
13SRCREV = "a9e4e74ec4473a4fd09e56b690bd4fa72f686687" 13 glib-2.0 gtk+3 gconf libgnome-keyring libgdata \
14 14 dbus db virtual/libiconv zlib libsoup-2.4 libglade libical nss libsecret \
15# 3.4 series needs libgdata-0.10*, 3.8 series needs also libsecret instead of gnome-keyring 15"
16PV = "3.2.3+git${SRCPV}" 16
17 17inherit gnomebase cmake gtk-doc gettext gobject-introspection perlnative pythonnative
18SRC_URI = "git://git.gnome.org/evolution-data-server;branch=gnome-3-2 \ 18
19 file://0001-contact-Replace-the-Novell-sample-contact-with-somet.patch \ 19SRC_URI += " \
20 file://0002-Fix-for-automake-1.12.x.patch \ 20 file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
21 file://0003-Disable-Werror-for-automake.patch \ 21 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
22 file://0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch \ 22 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
23 file://0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch \ 23 file://iconv-detect.h \
24 file://0006-configure.ac-do-not-overwrite-localedir.patch \ 24"
25 file://iconv-detect.h \ 25SRC_URI[archive.md5sum] = "568a21a4df4e0ec985c849b38fc66908"
26 file://0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch \ 26SRC_URI[archive.sha256sum] = "63b1ae5f76be818862f455bf841b5ebb1ec3e1f4df6d3a16dc2be348b7e0a1c5"
27 " 27
28 28LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
29S = "${WORKDIR}/git" 29LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
30 30
31inherit autotools gtk-doc pkgconfig gettext gobject-introspection 31EXTRA_OECMAKE = " \
32 -DWITH_KRB5=OFF \
33 -DENABLE_GOA=OFF \
34 -DENABLE_UOA=OFF \
35 -DENABLE_GOOGLE_AUTH=OFF \
36 -DENABLE_WEATHER=OFF \
37 -D${LKSTRFTIME} \
38"
39
40PACKAGECONFIG ??= ""
41PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
42
43EXTRA_OECONF = "--with-libdb=${STAGING_DIR_HOST}${prefix} \
44 --disable-nntp --disable-gtk-doc"
32 45
33# -ldb needs this on some platforms 46# -ldb needs this on some platforms
34LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0" 47LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
35 48
36# Parallel make shows many issues with this source code.
37# Current problems seem to be duplicate execution of the calander/backends
38# directories by make resulting in truncated/corrupt .la files
39#PARALLEL_MAKE = ""
40
41do_configure_append () { 49do_configure_append () {
42 cp ${WORKDIR}/iconv-detect.h ${S} 50 cp ${WORKDIR}/iconv-detect.h ${S}/src
51
52 # fix native perl shebang
53 sed -i 's:${STAGING_BINDIR_NATIVE}/perl-native:${bindir}:' ${B}/src/tools/addressbook-export/csv2vcard
43} 54}
44 55
45do_compile_prepend() { 56do_compile_prepend() {
46 export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs" 57 export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
47} 58}
48 59
49EXTRA_OECONF = "--without-openldap \
50 --with-libdb=${STAGING_DIR_HOST}${prefix} \
51 --disable-nntp --disable-goa --disable-weather --disable-gtk-doc"
52 60
53PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \ 61PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
54 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \ 62 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \
55 libedataserver libedataserver-dev \ 63 libedataserver libedataserver-dev \
56 libedataserverui libedataserverui-dev" 64 libedataserverui libedataserverui-dev"
57 65
58FILES_${PN} =+ "${datadir}/evolution-data-server-*/ui/" 66FILES_${PN} =+ "${systemd_user_unitdir} \
67 ${datadir}/dbus-1 \
68 ${datadir}/evolution-data-server-*/ui/"
69RDEPENDS_${PN} += "perl"
70
59FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc" 71FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
60FILES_${PN}-dbg =+ "${libdir}/evolution-data-server*/camel-providers/.debug \ 72FILES_${PN}-dbg =+ "${libdir}/evolution-data-server*/camel-providers/.debug \
61 ${libdir}/evolution-data-server*/calendar-backends/.debug \ 73 ${libdir}/evolution-data-server*/calendar-backends/.debug \