summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-03-05 20:05:58 -0800
committerArmin Kuster <akuster808@gmail.com>2018-03-12 09:58:41 -0700
commitac5aa6245ffc5057fc255b3354b1c70dacee3ed7 (patch)
tree0d8801e2d73a18658ef5057ab753518f617aae6e /meta-gnome
parentaf085dfc247e1c90d6be9aa96dd6822909ffe0ef (diff)
downloadmeta-openembedded-ac5aa6245ffc5057fc255b3354b1c70dacee3ed7.tar.gz
glade3: move from oe to gnome layer
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch62
-rw-r--r--meta-gnome/recipes-devtools/glade/glade3/0001-gnome-doc-utils.make-sysrooted-pkg-config.patch51
-rw-r--r--meta-gnome/recipes-devtools/glade/glade3/0002-fix-gcc-6-build.patch39
-rw-r--r--meta-gnome/recipes-devtools/glade/glade3_%.bbappend1
-rw-r--r--meta-gnome/recipes-devtools/glade/glade3_3.8.5.bb24
5 files changed, 176 insertions, 1 deletions
diff --git a/meta-gnome/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch b/meta-gnome/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch
new file mode 100644
index 000000000..03cb762ce
--- /dev/null
+++ b/meta-gnome/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch
@@ -0,0 +1,62 @@
1From fcf29abe59607b5791f9de18ddb86b9ae3c9b7cc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Aug 2017 23:50:05 -0700
4Subject: [PATCH] Add G_GNUC_PRINTF on functions with format strings
5
6This allows compilation with clang without errors, even when
7-Wformat-nonliteral is active (as long as there are no real cases of
8non literal formatting).
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 gladeui/glade-command.c | 4 ++--
13 gladeui/glade-utils.c | 4 ++--
14 2 files changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/gladeui/glade-command.c b/gladeui/glade-command.c
17index 9819766..4ac40ee 100644
18--- a/gladeui/glade-command.c
19+++ b/gladeui/glade-command.c
20@@ -266,7 +266,7 @@ glade_command_collapse (GladeCommand *command,
21 *
22 * Marks the begining of a group.
23 */
24-void
25+G_GNUC_PRINTF(1, 2) void
26 glade_command_push_group (const gchar *fmt, ...)
27 {
28 va_list args;
29@@ -655,7 +655,7 @@ glade_command_set_properties_list (GladeProject *project, GList *props)
30
31 multiple = g_list_length (me->sdata) > 1;
32 if (multiple)
33- glade_command_push_group (cmd->description);
34+ glade_command_push_group ("%s", cmd->description);
35
36
37 glade_command_check_group (GLADE_COMMAND (me));
38diff --git a/gladeui/glade-utils.c b/gladeui/glade-utils.c
39index ae52501..c51ae59 100644
40--- a/gladeui/glade-utils.c
41+++ b/gladeui/glade-utils.c
42@@ -197,7 +197,7 @@ glade_utils_get_pspec_from_funcname (const gchar *funcname)
43 * selected "OK", True if the @type was GLADE_UI_YES_OR_NO and
44 * the user selected "YES"; False otherwise.
45 */
46-gint
47+G_GNUC_PRINTF(4, 5) gint
48 glade_util_ui_message (GtkWidget *parent,
49 GladeUIMessageType type,
50 GtkWidget *widget,
51@@ -320,7 +320,7 @@ remove_message_timeout (FlashInfo * fi)
52 *
53 * Flash a temporary message on the statusbar.
54 */
55-void
56+G_GNUC_PRINTF(3, 4) void
57 glade_util_flash_message (GtkWidget *statusbar, guint context_id, gchar *format, ...)
58 {
59 va_list args;
60--
612.14.1
62
diff --git a/meta-gnome/recipes-devtools/glade/glade3/0001-gnome-doc-utils.make-sysrooted-pkg-config.patch b/meta-gnome/recipes-devtools/glade/glade3/0001-gnome-doc-utils.make-sysrooted-pkg-config.patch
new file mode 100644
index 000000000..1b24c39ce
--- /dev/null
+++ b/meta-gnome/recipes-devtools/glade/glade3/0001-gnome-doc-utils.make-sysrooted-pkg-config.patch
@@ -0,0 +1,51 @@
1From aed002cd9ff9e8f972120fbac33b4a65aba952e1 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Tue, 25 Sep 2012 10:28:33 +0200
4Subject: [PATCH] gnome-doc-utils.make: sysrooted pkg-config
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9same approach as used used in gnome-disk-utility:
10
11In cross environment we have to prepend the sysroot to the path found by
12pkgconfig since the path returned from pkgconfig does not have sysroot prefixed
13it ends up using the files from host system. Now usually people have gnome installed
14so the build succeeds but if you dont have gnome installed on build host then
15it wont find the files on host system and packages using gnome-doc-utils wont
16compile.
17
18This should work ok with non sysrooted builds too since in those cases PKG_CONFIG_SYSROOT_DIR
19will be empty
20
21Upstream-Status: pending
22
23Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
24---
25 gnome-doc-utils.make | 10 +++++-----
26 1 files changed, 5 insertions(+), 5 deletions(-)
27
28diff --git a/gnome-doc-utils.make b/gnome-doc-utils.make
29index 42d9df3..f71bbfa 100644
30--- a/gnome-doc-utils.make
31+++ b/gnome-doc-utils.make
32@@ -133,11 +133,11 @@ _DOC_ABS_SRCDIR = @abs_srcdir@
33 _xml2po ?= `which xml2po`
34 _xml2po_mode = $(if $(DOC_ID),mallard,docbook)
35
36-_db2html ?= `$(PKG_CONFIG) --variable db2html gnome-doc-utils`
37-_db2omf ?= `$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
38-_chunks ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
39-_credits ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
40-_ids ?= $(shell $(PKG_CONFIG) --variable xmldir gnome-doc-utils)/gnome/xslt/docbook/utils/ids.xsl
41+_db2html ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2html gnome-doc-utils`
42+_db2omf ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
43+_chunks ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
44+_credits ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
45+_ids ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/ids.xsl
46
47 if ENABLE_SK
48 _ENABLE_SK = true
49--
501.7.6.5
51
diff --git a/meta-gnome/recipes-devtools/glade/glade3/0002-fix-gcc-6-build.patch b/meta-gnome/recipes-devtools/glade/glade3/0002-fix-gcc-6-build.patch
new file mode 100644
index 000000000..f735ff819
--- /dev/null
+++ b/meta-gnome/recipes-devtools/glade/glade3/0002-fix-gcc-6-build.patch
@@ -0,0 +1,39 @@
1From 5aa3d2abb905fa8594f6c6572a87809da54c9342 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 5 Sep 2016 11:25:27 +0200
4Subject: [PATCH] fix gcc-6 build
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Pending
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 gladeui/glade-editor-property.c | 3 +++
14 1 file changed, 3 insertions(+)
15
16diff --git a/gladeui/glade-editor-property.c b/gladeui/glade-editor-property.c
17index a0c1039..5e9ac38 100644
18--- a/gladeui/glade-editor-property.c
19+++ b/gladeui/glade-editor-property.c
20@@ -2703,6 +2703,8 @@ glade_eprop_object_view (gboolean radio)
21 }
22
23
24+#pragma GCC diagnostic push
25+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
26 static gchar *
27 glade_eprop_object_dialog_title (GladeEditorProperty *eprop)
28 {
29@@ -2731,6 +2733,7 @@ glade_eprop_object_dialog_title (GladeEditorProperty *eprop)
30 return g_strdup_printf (format, g_type_name
31 (eprop->klass->pspec->value_type));
32 }
33+#pragma GCC diagnostic pop
34
35
36 gboolean
37--
382.5.5
39
diff --git a/meta-gnome/recipes-devtools/glade/glade3_%.bbappend b/meta-gnome/recipes-devtools/glade/glade3_%.bbappend
deleted file mode 100644
index 3abacfb86..000000000
--- a/meta-gnome/recipes-devtools/glade/glade3_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1PACKAGECONFIG ??= "gnome"
diff --git a/meta-gnome/recipes-devtools/glade/glade3_3.8.5.bb b/meta-gnome/recipes-devtools/glade/glade3_3.8.5.bb
new file mode 100644
index 000000000..69162bd2b
--- /dev/null
+++ b/meta-gnome/recipes-devtools/glade/glade3_3.8.5.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Glade - A User Interface Designer"
2HOMEPAGE = "http://www.gnu.org/software/gnash"
3LICENSE = "GPLv2 & LGPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=aabe87591cb8ae0f3c68be6977bb5522 \
5 file://COPYING.GPL;md5=9ac2e7cff1ddaf48b6eab6028f23ef88 \
6 file://COPYING.LGPL;md5=252890d9eee26aab7b432e8b8a616475"
7DEPENDS = "gtk+ gnome-doc-utils gnome-common libxml2 intltool-native"
8
9inherit autotools pkgconfig pythonnative gtk-icon-cache
10
11SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-${PV}.tar.xz \
12 file://0001-gnome-doc-utils.make-sysrooted-pkg-config.patch \
13 file://0002-fix-gcc-6-build.patch \
14 file://0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch \
15 "
16SRC_URI[md5sum] = "4e4b4f5ee34a03e017e4cef97d796c1f"
17SRC_URI[sha256sum] = "58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735"
18
19EXTRA_OECONF += "--disable-scrollkeeper"
20
21PACKAGECONFIG ?= "gnome"
22PACKAGECONFIG[gnome] = "--enable-gnome,--disable-gnome,libbonoboui libgnomeui"
23
24FILES_${PN} += "${datadir}/icons"