summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-14 23:44:28 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-18 10:18:12 +0200
commit04a99d7a1934865e3a30b967d4b16fd165678f55 (patch)
treed7231b4c4da9cb885ba3e5d8d4cc7fd9fe1524d6 /meta-gnome
parent4bd83dd9df75d31c8a302a8e89bf99f1042fc5bc (diff)
downloadmeta-openembedded-04a99d7a1934865e3a30b967d4b16fd165678f55.tar.gz
gnome-keyring: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/musl.patch17
-rw-r--r--meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb4
2 files changed, 20 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/musl.patch b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/musl.patch
new file mode 100644
index 000000000..050b87ab2
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring/musl.patch
@@ -0,0 +1,17 @@
1include sys/select.h for FD_* macros
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Pending
5
6Index: gnome-keyring-2.32.1/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
7===================================================================
8--- gnome-keyring-2.32.1.orig/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
9+++ gnome-keyring-2.32.1/pkcs11/rpc-layer/gkm-rpc-daemon-standalone.c
10@@ -32,6 +32,7 @@
11 #include <unistd.h>
12 #include <stdlib.h>
13 #include <string.h>
14+#include <sys/select.h>
15
16 #include <dlfcn.h>
17 #include <pthread.h>
diff --git a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
index 3b4cbf57f..fd6ca73a4 100644
--- a/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-keyring/gnome-keyring_2.32.1.bb
@@ -15,7 +15,9 @@ PR = "r12"
15 15
16inherit autotools gnome gtk-doc pkgconfig gsettings 16inherit autotools gnome gtk-doc pkgconfig gsettings
17 17
18SRC_URI += "file://egg-asn1x.patch" 18SRC_URI += "file://egg-asn1x.patch \
19 file://musl.patch \
20"
19 21
20DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native" 22DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} intltool-native"
21RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils" 23RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"