summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2017-07-10 19:35:06 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:32 +0200
commit54ca918b6cc562a9719dbb2a4ad40e862155a238 (patch)
tree2ab96b185b6ee38007a259155eebab5233db9153 /meta-gnome
parent0783e2326214521969996bc7f7f64fc309cd0dee (diff)
downloadmeta-openembedded-54ca918b6cc562a9719dbb2a4ad40e862155a238.tar.gz
abiword: update 3.0.1 -> 3.0.2
Patch was a backport now included upstream Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch74
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb (renamed from meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb)5
2 files changed, 2 insertions, 77 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch b/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch
deleted file mode 100644
index 595ee8e5a..000000000
--- a/meta-gnome/recipes-gnome/abiword/abiword/0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch
+++ /dev/null
@@ -1,74 +0,0 @@
1From a83e6f50dbd5efa16fb39efe32b9de370f103130 Mon Sep 17 00:00:00 2001
2From: Hubert Figuiere <hub@figuiere.net>
3Date: Sat, 23 Jan 2016 20:46:02 +0000
4Subject: [PATCH] Bug 13754 - Fix build on gcc-6 (default to C++11).
5
6This is debian bug https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811381
7
8git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/trunk@35182 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
9
10Upstream-Status: Backport
11---
12 plugins/collab/backends/service/xp/RealmProtocol.cpp | 4 ++--
13 plugins/collab/backends/service/xp/soa_soup.cpp | 2 +-
14 plugins/latex/xp/ie_exp_LaTeX.cpp | 2 +-
15 plugins/xslfo/xp/ie_exp_XSL-FO.cpp | 2 +-
16 4 files changed, 5 insertions(+), 5 deletions(-)
17
18diff --git a/plugins/collab/backends/service/xp/RealmProtocol.cpp b/plugins/collab/backends/service/xp/RealmProtocol.cpp
19index fb426eb..347a49c 100644
20--- a/plugins/collab/backends/service/xp/RealmProtocol.cpp
21+++ b/plugins/collab/backends/service/xp/RealmProtocol.cpp
22@@ -6,8 +6,8 @@ namespace protocolv1 {
23
24 #define MAX_PACKET_DATA_SIZE 64*1024*1024
25
26-#define RPV1_PACKET_NONEXISTENT -2
27-#define RPV1_PACKET_VARIABLE -1
28+#define RPV1_PACKET_NONEXISTENT uint32_t(-2)
29+#define RPV1_PACKET_VARIABLE uint32_t(-1)
30
31 static uint32_t body_size[6] = {
32 RPV1_PACKET_NONEXISTENT, /* 0: reserved */
33diff --git a/plugins/collab/backends/service/xp/soa_soup.cpp b/plugins/collab/backends/service/xp/soa_soup.cpp
34index 4b81735..f4f5134 100644
35--- a/plugins/collab/backends/service/xp/soa_soup.cpp
36+++ b/plugins/collab/backends/service/xp/soa_soup.cpp
37@@ -163,7 +163,7 @@ namespace soup_soa {
38
39 static bool _invoke(const std::string& /*url*/, const soa::method_invocation& /*mi*/, SoaSoupSession& sess, std::string& result) {
40 if (!sess.m_session || !sess.m_msg )
41- return soa::GenericPtr();
42+ return false;
43
44 guint status = soup_session_send_message (sess.m_session, sess.m_msg);
45 if (!(SOUP_STATUS_IS_SUCCESSFUL (status) ||
46diff --git a/plugins/latex/xp/ie_exp_LaTeX.cpp b/plugins/latex/xp/ie_exp_LaTeX.cpp
47index 7aaf3a9..8bcc250 100644
48--- a/plugins/latex/xp/ie_exp_LaTeX.cpp
49+++ b/plugins/latex/xp/ie_exp_LaTeX.cpp
50@@ -1330,7 +1330,7 @@ void s_LaTeX_Listener::_outputData(const UT_UCSChar * data, UT_uint32 length)
51 m_pie->write(sBuf.c_str(),sBuf.size());
52 }
53
54-#define SUB(a,who) case a: subst = "\\(\\"who"\\)"; return true;
55+#define SUB(a,who) case a: subst = "\\(\\" who"\\)"; return true;
56 #define SUBd(a,who) case a: subst = who; return true;
57 static bool _convertLettersToSymbols(char c, const char *& subst)
58 {
59diff --git a/plugins/xslfo/xp/ie_exp_XSL-FO.cpp b/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
60index cc5e4e6..957226e 100644
61--- a/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
62+++ b/plugins/xslfo/xp/ie_exp_XSL-FO.cpp
63@@ -1451,7 +1451,7 @@ void s_XSL_FO_Listener::_openSection(PT_AttrPropIndex api)
64 { \
65 UT_UTF8String esc = szValue; \
66 esc.escapeXML(); \
67- buf += " "x"=\""; \
68+ buf += " " x"=\""; \
69 buf += esc.utf8_str(); \
70 buf += "\""; \
71 }
72--
732.5.5
74
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb
index 34fc97d4a..2a13e4839 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb
@@ -28,13 +28,12 @@ RCONFLICTS_${PN} = "${PN}-embedded"
28SRC_URI = " \ 28SRC_URI = " \
29 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ 29 http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
30 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \ 30 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
31 file://0002-Bug-13754-Fix-build-on-gcc-6-default-to-C-11.patch \
32" 31"
33 32
34LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a" 33LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
35 34
36SRC_URI[md5sum] = "f3f8052e7b4979a43b75775a381e6cb8" 35SRC_URI[md5sum] = "cda6dd58c747c133b421cc7eb18f5796"
37SRC_URI[sha256sum] = "e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6" 36SRC_URI[sha256sum] = "afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522"
38 37
39#want 3.x from 3.x.y for the installation directory 38#want 3.x from 3.x.y for the installation directory
40SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" 39SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"