diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-05 18:15:26 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-24 11:00:52 +0200 |
commit | 9db29860a8054f63e32ee548ee11b575902879c2 (patch) | |
tree | bb00e73032401fa6727609d4d9f3535d6db8efcc /meta-gnome | |
parent | d8ce1607c9cb96e02938b4bed7f6fa9f606a5c7e (diff) | |
download | meta-openembedded-9db29860a8054f63e32ee548ee11b575902879c2.tar.gz |
dates: Fix buils with security flags
Update to latest and drop patches which are upstreamed.
Add a patch to fix security warnings
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
4 files changed, 59 insertions, 96 deletions
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/0001-Fix-format-security-warnings.patch b/meta-gnome/recipes-gnome/pimlico/dates/0001-Fix-format-security-warnings.patch new file mode 100644 index 0000000000..4f551a7d8c --- /dev/null +++ b/meta-gnome/recipes-gnome/pimlico/dates/0001-Fix-format-security-warnings.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 687881c5fa342686c8724adcdac0f9d555a351c3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Apr 2017 18:10:57 -0700 | ||
4 | Subject: [PATCH] Fix format security warnings | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/dates_callbacks.c | 2 +- | ||
9 | src/dates_gtk.c | 2 +- | ||
10 | src/gconf-bridge.c | 2 +- | ||
11 | 3 files changed, 3 insertions(+), 3 deletions(-) | ||
12 | |||
13 | diff --git a/src/dates_callbacks.c b/src/dates_callbacks.c | ||
14 | index d704c8f..46b8cb1 100644 | ||
15 | --- a/src/dates_callbacks.c | ||
16 | +++ b/src/dates_callbacks.c | ||
17 | @@ -365,7 +365,7 @@ dates_about_cb (GtkWidget *widget, DatesData *d) | ||
18 | |||
19 | if (!pixb) { | ||
20 | g_assert (error); | ||
21 | - g_warning (error->message); | ||
22 | + g_warning ("%s", error->message); | ||
23 | g_clear_error (&error); | ||
24 | } | ||
25 | |||
26 | diff --git a/src/dates_gtk.c b/src/dates_gtk.c | ||
27 | index 403bc25..fd691d2 100644 | ||
28 | --- a/src/dates_gtk.c | ||
29 | +++ b/src/dates_gtk.c | ||
30 | @@ -1114,7 +1114,7 @@ calendar_do_edit_dialog_response_cb (GtkDialog *dialog, gint response_id, gpoint | ||
31 | GTK_DIALOG_MODAL | GTK_DIALOG_DESTROY_WITH_PARENT, | ||
32 | GTK_MESSAGE_WARNING, | ||
33 | GTK_BUTTONS_NONE, | ||
34 | - prompt); | ||
35 | + "%s", prompt); | ||
36 | |||
37 | g_free (prompt); | ||
38 | |||
39 | diff --git a/src/gconf-bridge.c b/src/gconf-bridge.c | ||
40 | index 49754cf..67d3757 100644 | ||
41 | --- a/src/gconf-bridge.c | ||
42 | +++ b/src/gconf-bridge.c | ||
43 | @@ -1220,7 +1220,7 @@ error_handler (GConfClient *client, | ||
44 | dlg = gtk_message_dialog_new (NULL, 0, | ||
45 | GTK_MESSAGE_ERROR, | ||
46 | GTK_BUTTONS_OK, | ||
47 | - message); | ||
48 | + "%s", message); | ||
49 | g_free (message); | ||
50 | |||
51 | gtk_message_dialog_format_secondary_text | ||
52 | -- | ||
53 | 2.12.2 | ||
54 | |||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch b/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch deleted file mode 100644 index 4550d298d9..0000000000 --- a/meta-gnome/recipes-gnome/pimlico/dates/0001-Update-to-new-evolution-data-server-e_source_-color-.patch +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | From a8ddfc4b91f2ab3d955fe528ddb98ce2c5545795 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Sun, 4 Aug 2013 13:44:50 +0200 | ||
4 | Subject: [PATCH] Update to new evolution-data-server e_source_*color APIs | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | src/dates_gtk.c | 6 +++--- | ||
9 | src/dates_main.c | 2 +- | ||
10 | src/dates_view.c | 6 +++++- | ||
11 | 3 files changed, 9 insertions(+), 5 deletions(-) | ||
12 | |||
13 | diff --git a/src/dates_gtk.c b/src/dates_gtk.c | ||
14 | index 78e71bb..ac539d2 100644 | ||
15 | --- a/src/dates_gtk.c | ||
16 | +++ b/src/dates_gtk.c | ||
17 | @@ -1072,7 +1072,7 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d) | ||
18 | #endif | ||
19 | |||
20 | /* Set the colour */ | ||
21 | - e_source_set_color (source, new_colour); | ||
22 | + e_source_set_color_spec (source, new_colour); | ||
23 | |||
24 | /* Set the group for the source */ | ||
25 | e_source_set_group (source, group); | ||
26 | @@ -1335,7 +1335,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d) | ||
27 | gtk_misc_set_alignment (GTK_MISC (label), 0, 0.5); | ||
28 | |||
29 | /* Get the colour from the the source */ | ||
30 | - e_source_get_color (source, &raw_colour); | ||
31 | + raw_colour = e_source_peek_color_spec (source); | ||
32 | |||
33 | /* Munge this into something usable */ | ||
34 | colour.red = (guint16)(((raw_colour & 0xff0000) >> 16) << 8); | ||
35 | @@ -1459,7 +1459,7 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d) | ||
36 | new_colour <<= 8; | ||
37 | #endif | ||
38 | /* Update the colour */ | ||
39 | - e_source_set_color (source, new_colour); | ||
40 | + e_source_set_color_spec (source, new_colour); | ||
41 | |||
42 | /* And the name */ | ||
43 | e_source_set_name (source, (gtk_entry_get_text (GTK_ENTRY (name_entry)))); | ||
44 | diff --git a/src/dates_main.c b/src/dates_main.c | ||
45 | index ce05fe8..7273c63 100644 | ||
46 | --- a/src/dates_main.c | ||
47 | +++ b/src/dates_main.c | ||
48 | @@ -112,7 +112,7 @@ dates_load_calendars (DatesData *d) | ||
49 | system_source = e_source_new (_("Personal"), "system"); | ||
50 | |||
51 | /* Default Evolution colour */ | ||
52 | - e_source_set_color (system_source, 0xBECEDD); | ||
53 | + e_source_set_color_spec (system_source, 0xBECEDD); | ||
54 | |||
55 | /* Set the group for the source and put it in the group */ | ||
56 | e_source_set_group (system_source, local_group); | ||
57 | diff --git a/src/dates_view.c b/src/dates_view.c | ||
58 | index d65db2f..f8efb9c 100644 | ||
59 | --- a/src/dates_view.c | ||
60 | +++ b/src/dates_view.c | ||
61 | @@ -4876,7 +4880,7 @@ dates_view_add_calendar (DatesView *view, ECal *ecal) | ||
62 | cal->text_gc = gdk_gc_new ( | ||
63 | GDK_DRAWABLE (priv->main->window)); | ||
64 | |||
65 | - if (e_source_get_color (source, &colour)) { | ||
66 | + if (colour = e_source_peek_color_spec (source)) { | ||
67 | GdkColor gcolour, dgcolour, tgcolour; | ||
68 | gcolour.red = ((colour & 0xFF0000) >> 16) * 0x101; | ||
69 | gcolour.green = ((colour & 0xFF00) >> 8) * 0x101; | ||
70 | -- | ||
71 | 1.8.3.2 | ||
72 | |||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch b/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch deleted file mode 100644 index fad3c5826e..0000000000 --- a/meta-gnome/recipes-gnome/pimlico/dates/make-382.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | Make 3.82 is offended by the use of spaces instead of tabs. This has been fixed | ||
2 | in upstream git. | ||
3 | |||
4 | JL - 15/12/10 | ||
5 | |||
6 | Upstream-Status: Accepted | ||
7 | |||
8 | Index: git/Makefile.am | ||
9 | =================================================================== | ||
10 | --- git.orig/Makefile.am | ||
11 | +++ git/Makefile.am | ||
12 | @@ -7,5 +7,5 @@ DISTCLEANFILES = intltool-extract intlto | ||
13 | MAINTAINERCLEANFILES = $(DISTCLEANFILES) aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh Makefile.in missing | ||
14 | |||
15 | snapshot: | ||
16 | - $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"` | ||
17 | + $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"` | ||
18 | |||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates_git.bb b/meta-gnome/recipes-gnome/pimlico/dates_git.bb index a4a572f85f..14965e94f7 100644 --- a/meta-gnome/recipes-gnome/pimlico/dates_git.bb +++ b/meta-gnome/recipes-gnome/pimlico/dates_git.bb | |||
@@ -5,15 +5,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | |||
5 | file://src/dates_hildon.c;endline=19;md5=63938904198b25de429abb65fbdbdb8a \ | 5 | file://src/dates_hildon.c;endline=19;md5=63938904198b25de429abb65fbdbdb8a \ |
6 | file://src/gconf-bridge.c;endline=22;md5=ad7626c6daf4aec590474a243f4912fa" | 6 | file://src/gconf-bridge.c;endline=22;md5=ad7626c6daf4aec590474a243f4912fa" |
7 | 7 | ||
8 | SRCREV = "514185dc1f6588085fda41eb59898b93d0487dd4" | 8 | SRCREV = "c8e30fa3211dcdfcda48184f4c57746a552b9c7a" |
9 | PV = "0.4.11+git${SRCPV}" | 9 | PV = "0.4.11+git${SRCPV}" |
10 | PR = "r9" | 10 | PR = "r9" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | SRC_URI = "git://git.gnome.org/${BPN} \ | 14 | SRC_URI = "git://git.gnome.org/${BPN} \ |
15 | file://make-382.patch \ | 15 | file://dso_linking_change_build_fix.patch \ |
16 | file://dso_linking_change_build_fix.patch \ | 16 | file://uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch \ |
17 | file://uclibc-NL_TIME_FIRST_WEEKDAY-absent.patch \ | 17 | file://0001-Fix-format-security-warnings.patch \ |
18 | file://0001-Update-to-new-evolution-data-server-e_source_-color-.patch \ | 18 | " |
19 | " | ||