summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-07-31 04:15:04 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-08 13:46:49 +0200
commitdb97c329c23df9da06d2deb0e628c1ea01293326 (patch)
tree72ae469ceaed2b125637e40da61757a7b5fab8e5 /meta-gnome
parent2ed31c7ebbc86a9fbbdd60c2f5ef10821a81cbc5 (diff)
downloadmeta-openembedded-db97c329c23df9da06d2deb0e628c1ea01293326.tar.gz
gedit: remove blacklist caused by gtksourceview2 / fix/cleanup build
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gedit/files/0002-suppress-string-format-literal-warning-to-fix-build-.patch38
-rw-r--r--meta-gnome/recipes-gnome/gedit/gedit_2.30.4.bb11
2 files changed, 44 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/gedit/files/0002-suppress-string-format-literal-warning-to-fix-build-.patch b/meta-gnome/recipes-gnome/gedit/files/0002-suppress-string-format-literal-warning-to-fix-build-.patch
new file mode 100644
index 000000000..a5d231012
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gedit/files/0002-suppress-string-format-literal-warning-to-fix-build-.patch
@@ -0,0 +1,38 @@
1From 4ebdf8023f763f75a7e1b548894de2e8b784f4a8 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Fri, 29 Jul 2016 23:19:40 +0200
4Subject: [PATCH] suppress string format literal warning to fix build with gcc6
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Pending
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 plugins/time/gedit-time-plugin.c | 3 +++
14 1 file changed, 3 insertions(+)
15
16diff --git a/plugins/time/gedit-time-plugin.c b/plugins/time/gedit-time-plugin.c
17index d2ffdb9..441d9f9 100644
18--- a/plugins/time/gedit-time-plugin.c
19+++ b/plugins/time/gedit-time-plugin.c
20@@ -473,12 +473,15 @@ get_time (const gchar* format)
21 clock = time (NULL);
22 now = localtime (&clock);
23
24+#pragma GCC diagnostic push
25+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
26 do
27 {
28 out_length += 255;
29 out = g_realloc (out, out_length);
30 }
31 while (strftime (out, out_length, locale_format, now) == 0);
32+#pragma GCC diagnostic pop
33
34 g_free (locale_format);
35
36--
372.5.5
38
diff --git a/meta-gnome/recipes-gnome/gedit/gedit_2.30.4.bb b/meta-gnome/recipes-gnome/gedit/gedit_2.30.4.bb
index 7e6b343a8..a6c68d383 100644
--- a/meta-gnome/recipes-gnome/gedit/gedit_2.30.4.bb
+++ b/meta-gnome/recipes-gnome/gedit/gedit_2.30.4.bb
@@ -3,13 +3,16 @@ SECTION = "x11/gnome"
3LICENSE = "GPLv2+" 3LICENSE = "GPLv2+"
4PR = "r2" 4PR = "r2"
5 5
6DEPENDS = "gvfs enchant gconf gnome-doc-utils glib-2.0 gtk+ gtksourceview2 iso-codes" 6DEPENDS = "gvfs enchant gconf gnome-doc-utils glib-2.0 gtk+ gtksourceview2 iso-codes intltool-native"
7 7
8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 8LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
9 9
10inherit gnome gettext pythonnative 10inherit gnome gettext pythonnative
11SRC_URI+= "file://0001-workaround-void-pointer-arithmetic.patch \ 11SRC_URI+= " \
12 file://0001-Remove-help-directory-from-build.patch" 12 file://0001-workaround-void-pointer-arithmetic.patch \
13 file://0001-Remove-help-directory-from-build.patch \
14 file://0002-suppress-string-format-literal-warning-to-fix-build-.patch \
15"
13SRC_URI[archive.md5sum] = "e1eecb0a92a1a363b3d375ec5ac0fb3b" 16SRC_URI[archive.md5sum] = "e1eecb0a92a1a363b3d375ec5ac0fb3b"
14SRC_URI[archive.sha256sum] = "a561fe3dd1d199baede1bd07c4ee65f06fc7c494dd4d3327117f04149a608e3c" 17SRC_URI[archive.sha256sum] = "a561fe3dd1d199baede1bd07c4ee65f06fc7c494dd4d3327117f04149a608e3c"
15GNOME_COMPRESS_TYPE="bz2" 18GNOME_COMPRESS_TYPE="bz2"
@@ -19,5 +22,3 @@ EXTRA_OECONF = "--disable-scrollkeeper \
19 22
20FILES_${PN} += "${libdir}/gedit-2/plugin* ${datadir}/gedit-2" 23FILES_${PN} += "${libdir}/gedit-2/plugin* ${datadir}/gedit-2"
21FILES_${PN}-dbg += "${libdir}/gedit-2/plugin-loaders/.debug ${libdir}/gedit-2/plugins/.debug" 24FILES_${PN}-dbg += "${libdir}/gedit-2/plugin-loaders/.debug ${libdir}/gedit-2/plugins/.debug"
22
23PNBLACKLIST[gedit] ?= "Depends on broken gtksourceview2"