summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2016-05-24 13:43:11 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-27 15:39:14 +0200
commit5adc7db356071e22219d652e11911b98d9f8bf6e (patch)
tree6e8fca3f17b91d3f225068f7c807b0188f25086c /meta-gnome
parent5cc904be9d6551f6e9a6465e990df1e2de940004 (diff)
downloadmeta-openembedded-5adc7db356071e22219d652e11911b98d9f8bf6e.tar.gz
florence: move to latest GTK2 version 0.5.4
The latest GTK2 version is 0.5.4, which contains several bug fixes. Noteable, it fixes an issue where the SVG keys have not been displayed with recent versions of its dependencies. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch30
-rw-r--r--meta-gnome/recipes-support/florence/florence_0.5.4.bb (renamed from meta-gnome/recipes-support/florence/florence_0.5.1.bb)12
2 files changed, 36 insertions, 6 deletions
diff --git a/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch b/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch
new file mode 100644
index 000000000..0bb5dee80
--- /dev/null
+++ b/meta-gnome/recipes-support/florence/files/fix-no-atspi-compile.patch
@@ -0,0 +1,30 @@
1diff --git a/src/florence.c b/src/florence.c
2index b27c31b..feadefe 100644
3--- a/src/florence.c
4+++ b/src/florence.c
5@@ -44,12 +44,6 @@
6 /* exit signal */
7 static int flo_exit=FALSE;
8
9-#ifdef ENABLE_AT_SPI2
10-void flo_check_show (struct florence *florence, AtspiAccessible *obj);
11-#else
12-void flo_check_show (struct florence *florence, Accessible *obj);
13-#endif
14-
15 /* Called on destroy event (systray quit or close window) */
16 void flo_destroy (void)
17 {
18@@ -61,6 +55,12 @@ void flo_destroy (void)
19 }
20
21 #ifdef AT_SPI
22+#ifdef ENABLE_AT_SPI2
23+void flo_check_show (struct florence *florence, AtspiAccessible *obj);
24+#else
25+void flo_check_show (struct florence *florence, Accessible *obj);
26+#endif
27+
28 /* Called to destroy the icon */
29 void flo_icon_destroy (GtkWidget *widget, gpointer user_data)
30 {
diff --git a/meta-gnome/recipes-support/florence/florence_0.5.1.bb b/meta-gnome/recipes-support/florence/florence_0.5.4.bb
index 71014f087..dfdb6bdb8 100644
--- a/meta-gnome/recipes-support/florence/florence_0.5.1.bb
+++ b/meta-gnome/recipes-support/florence/florence_0.5.4.bb
@@ -8,13 +8,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8 8
9PR = "r1" 9PR = "r1"
10 10
11DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify" 11DEPENDS = "gtk+ libxml2 libglade librsvg libxtst gconf cairo intltool-native gnome-doc-utils libnotify gstreamer"
12 12
13SRC_URI = "${SOURCEFORGE_MIRROR}/florence/florence/${PV}/florence-${PV}.tar.bz2 \ 13SRC_URI = "${SOURCEFORGE_MIRROR}/florence/florence/${PV}-gtk2/florence-${PV}.tar.bz2 \
14 file://0001-Fix-glib-includes.patch" 14 file://fix-no-atspi-compile.patch"
15SRC_URI[md5sum] = "56d12e5b47c100d9df172aa5ddc0f609" 15SRC_URI[md5sum] = "8d5c2367a28485bfcf577650b0badab7"
16SRC_URI[sha256sum] = "7b06ed84ef2b7b22d8d2cf0c7d013a05409bd82028240ac8719a68b192d5bc62" 16SRC_URI[sha256sum] = "26d33aa20d5fbf34ceeded4c41cb922d2988b6082e33d9acc46dd7bfe56d31a1"
17 17
18inherit gettext autotools gconf pkgconfig 18inherit gettext autotools gconf pkgconfig
19 19
20EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet" 20EXTRA_OECONF = "--disable-scrollkeeper --without-docs --without-at-spi --without-panelapplet --without-xrecord"