summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:37 +0200
commit558d935806365784794edc2c8473dffcc1db6b86 (patch)
treeb24d5b6ef2834c6544eb6310aa6675f3867064ca /meta-gnome
parent3fd61331a4c22377dd5a46ff37a9ef20fc381aa5 (diff)
downloadmeta-openembedded-558d935806365784794edc2c8473dffcc1db6b86.tar.gz
libbonobo: Fix missing dep on orbit2-native and build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo.inc2
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch26
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb1
3 files changed, 28 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
index e0f616869..60a85974e 100644
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
@@ -3,7 +3,7 @@ LICENSE = "GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
4 file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34" 4 file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
5SECTION = "x11/gnome/libs" 5SECTION = "x11/gnome/libs"
6DEPENDS = "glib-2.0 orbit2 intltool-native libxml2 dbus dbus-glib" 6DEPENDS = "glib-2.0 orbit2-native orbit2 intltool-native libxml2 dbus dbus-glib"
7 7
8inherit gnomebase gtk-doc lib_package 8inherit gnomebase gtk-doc lib_package
9 9
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
new file mode 100644
index 000000000..20db671e0
--- /dev/null
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch
@@ -0,0 +1,26 @@
1This checks whether the format string is a literal on the calling function. As bonobo_debug_print()
2takes already a va_list, we specify the format on the functions that call it
3The second number, which is 0 here, should then be the argument index of the variadic argument
4
5Fixed warning with clang
6
7| ../../libbonobo-2.32.1/bonobo/bonobo-debug.c:58:32: error: format string is not a string literal [-Werror,-Wformat-nonliteral]
8| vfprintf (_bonobo_debug_file, fmt, args);
9| ^~~
10| 1 error generated.
11
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14
15Index: libbonobo-2.32.1/bonobo/bonobo-debug.c
16===================================================================
17--- libbonobo-2.32.1.orig/bonobo/bonobo-debug.c
18+++ libbonobo-2.32.1/bonobo/bonobo-debug.c
19@@ -47,6 +47,7 @@ bonobo_debug_init(void)
20 _bonobo_debug_file = stderr;
21 }
22
23+__attribute__((__format__ (printf, 2, 0)))
24 void
25 bonobo_debug_print (const char *name, char *fmt, ...)
26 {
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
index fd4d81210..8e00eb4d2 100644
--- a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb
@@ -2,6 +2,7 @@ require libbonobo.inc
2 2
3SRC_URI += "file://0001-Remove-use-of-G_DISABLE_DEPRECATED.patch \ 3SRC_URI += "file://0001-Remove-use-of-G_DISABLE_DEPRECATED.patch \
4 file://do-not-use-srcdir-variable.patch \ 4 file://do-not-use-srcdir-variable.patch \
5 file://fix-nonliteral-in-string.patch \
5 " 6 "
6SRC_URI[archive.md5sum] = "27fa902d4fdf6762ee010e7053aaf77b" 7SRC_URI[archive.md5sum] = "27fa902d4fdf6762ee010e7053aaf77b"
7SRC_URI[archive.sha256sum] = "9160d4f277646400d3bb6b4fa73636cc6d1a865a32b9d0760e1e9e6ee624976b" 8SRC_URI[archive.sha256sum] = "9160d4f277646400d3bb6b4fa73636cc6d1a865a32b9d0760e1e9e6ee624976b"