summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-08 13:55:43 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 11:00:51 +0200
commit4210d1a3eacbdc6fa34c2beffb9b6a79bf9ef0c0 (patch)
treec371e97419e6861b305b4c0493d558ddaad0f12a /meta-gnome
parentf93fcdc4f10d4c8bacf76e36ac6ff2e271560c61 (diff)
downloadmeta-openembedded-4210d1a3eacbdc6fa34c2beffb9b6a79bf9ef0c0.tar.gz
evince: Upgrade to 3.24.0
Fix build with security flags Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/evince/evince/0001-Add-format-attribute-to-_synctex_malloc.patch27
-rw-r--r--meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch39
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_3.24.0.bb (renamed from meta-gnome/recipes-gnome/evince/evince_3.18.2.bb)29
3 files changed, 48 insertions, 47 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince/0001-Add-format-attribute-to-_synctex_malloc.patch b/meta-gnome/recipes-gnome/evince/evince/0001-Add-format-attribute-to-_synctex_malloc.patch
new file mode 100644
index 000000000..de739c5b3
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evince/evince/0001-Add-format-attribute-to-_synctex_malloc.patch
@@ -0,0 +1,27 @@
1From 3776fd0b42e473fe51d3678bf26cdaa37e1d8e0d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 8 Apr 2017 13:36:12 -0700
4Subject: [PATCH] Add format attribute to _synctex_malloc
5
6Helps in avoiding compile errors about formating with clang
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 cut-n-paste/synctex/synctex_parser_utils.c | 1 +
11 1 file changed, 1 insertion(+)
12
13diff --git a/cut-n-paste/synctex/synctex_parser_utils.c b/cut-n-paste/synctex/synctex_parser_utils.c
14index f8a9f6f..9459b2d 100644
15--- a/cut-n-paste/synctex/synctex_parser_utils.c
16+++ b/cut-n-paste/synctex/synctex_parser_utils.c
17@@ -78,6 +78,7 @@ void *_synctex_malloc(size_t size) {
18 return (void *)ptr;
19 }
20
21+__attribute__((__format__ (__printf__, 1, 0)))
22 int _synctex_error(const char * reason,...) {
23 va_list arg;
24 int result;
25--
262.12.2
27
diff --git a/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch b/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch
deleted file mode 100644
index b8e30f7d9..000000000
--- a/meta-gnome/recipes-gnome/evince/evince/0002-fix-gcc6-errors.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1--- evince-3.18.2/backend/comics/comics-document.c.orig 2016-06-22 20:08:01.789805750 +0000
2+++ evince-3.18.2/backend/comics/comics-document.c 2016-06-22 20:07:00.817804688 +0000
3@@ -241,6 +241,8 @@
4 /* This function shows how to use the choosen command for decompressing a
5 * comic book file. It modifies fields of the ComicsDocument struct with
6 * this information */
7+#pragma GCC diagnostic push
8+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
9 static gboolean
10 comics_generate_command_lines (ComicsDocument *comics_document,
11 GError **error)
12@@ -296,6 +298,7 @@
13 }
14
15 }
16+#pragma GCC diagnostic pop
17
18 /* This function chooses an external command for decompressing a comic
19 * book based on its mime tipe. */
20--- evince-3.18.2/libdocument/ev-document-misc.c.orig 2016-06-22 20:01:49.205799262 +0000
21+++ evince-3.18.2/libdocument/ev-document-misc.c 2016-06-22 20:02:27.233799924 +0000
22@@ -519,7 +519,8 @@
23
24 return (dp / di);
25 }
26-
27+#pragma GCC diagnostic push
28+#pragma GCC diagnostic ignored "-Wformat-y2k"
29 /* Returns a locale specific date and time representation */
30 gchar *
31 ev_document_misc_format_date (GTime utime)
32@@ -542,6 +543,7 @@
33
34 return g_locale_to_utf8 (s, -1, NULL, NULL, NULL);
35 }
36+#pragma GCC diagnostic pop
37
38 void
39 ev_document_misc_get_pointer_position (GtkWidget *widget,
diff --git a/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb b/meta-gnome/recipes-gnome/evince/evince_3.24.0.bb
index 4e3e0f05c..2b75244fe 100644
--- a/meta-gnome/recipes-gnome/evince/evince_3.18.2.bb
+++ b/meta-gnome/recipes-gnome/evince/evince_3.24.0.bb
@@ -5,16 +5,16 @@ SECTION = "x11/office"
5DEPENDS = "gtk+3 libsecret gnome-desktop3 poppler gstreamer1.0-plugins-base orc adwaita-icon-theme intltool-native gnome-common-native" 5DEPENDS = "gtk+3 libsecret gnome-desktop3 poppler gstreamer1.0-plugins-base orc adwaita-icon-theme intltool-native gnome-common-native"
6PR = "r5" 6PR = "r5"
7 7
8inherit gnome pkgconfig gtk-icon-cache gsettings gobject-introspection distro_features_check 8inherit gnome pkgconfig gtk-icon-cache gsettings gobject-introspection distro_features_check systemd
9 9
10REQUIRED_DISTRO_FEATURES = "x11" 10REQUIRED_DISTRO_FEATURES = "x11"
11 11
12SRC_URI[archive.md5sum] = "c39af6b8b1c44d4393ef8ac9dab99c0b" 12SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
13SRC_URI[archive.sha256sum] = "42ad6c7354d881a9ecab136ea84ff867acb942605bcfac48b6c12e1c2d8ecb17" 13 file://0001-help-remove-YELP-macro.patch \
14 14 file://0001-Add-format-attribute-to-_synctex_malloc.patch \
15SRC_URI += "file://0001-help-remove-YELP-macro.patch \ 15 "
16 file://0002-fix-gcc6-errors.patch \ 16SRC_URI[archive.md5sum] = "3fb65ff46de191dc49c481f1fc66201c"
17" 17SRC_URI[archive.sha256sum] = "043895af7bbd6f1b57f9ab8778e78cf9c0af5dfcc347eaa94a17bf864c04dc8f"
18 18
19EXTRA_OECONF = " --enable-thumbnailer \ 19EXTRA_OECONF = " --enable-thumbnailer \
20" 20"
@@ -25,22 +25,35 @@ do_compile_prepend() {
25 25
26 26
27do_install_append() { 27do_install_append() {
28 install -d install -d ${D}${datadir}/pixmaps 28 install -d ${D}${datadir}/pixmaps
29 install -m 0755 ${S}/data/icons/48x48/apps/evince.png ${D}${datadir}/pixmaps/ 29 install -m 0755 ${S}/data/icons/48x48/apps/evince.png ${D}${datadir}/pixmaps/
30 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}
31 then
32 install -d ${D}${systemd_unitdir}/system
33 mv ${D}${libdir}/systemd/user/evince.service ${D}${systemd_unitdir}/system/evince.service
34 else
35 rm -rf ${D}${libdir}/systemd/user/evince.service
36 fi
37 rmdir --ignore-fail-on-non-empty ${D}${libdir}/systemd/user
38 rmdir --ignore-fail-on-non-empty ${D}${libdir}/systemd
30} 39}
31 40
32PACKAGECONFIG ??= "" 41PACKAGECONFIG ??= ""
33PACKAGECONFIG[nautilus] = "--enable-nautilus,--disable-nautilus,nautilus" 42PACKAGECONFIG[nautilus] = "--enable-nautilus,--disable-nautilus,nautilus"
34PACKAGECONFIG[browser-plugin] = "--enable-browser-plugin,--disable-browser-plugin," 43PACKAGECONFIG[browser-plugin] = "--enable-browser-plugin,--disable-browser-plugin,"
35 44
45SYSTEMD_SERVICE_${PN} = "evince.service"
46
36RDEPENDS_${PN} += "glib-2.0-utils" 47RDEPENDS_${PN} += "glib-2.0-utils"
37RRECOMMMENDS_${PN} = "adwaita-icon-theme" 48RRECOMMMENDS_${PN} = "adwaita-icon-theme"
38 49
39PACKAGES =+ "${PN}-nautilus-extension" 50PACKAGES =+ "${PN}-nautilus-extension"
40PACKAGES =+ "${PN}-browser-plugin" 51PACKAGES =+ "${PN}-browser-plugin"
52
41FILES_${PN} += "${datadir}/dbus-1 \ 53FILES_${PN} += "${datadir}/dbus-1 \
42 ${datadir}/appdata \ 54 ${datadir}/appdata \
43 ${datadir}/thumbnailers \ 55 ${datadir}/thumbnailers \
56 ${systemd_unitdir}/systemd/user/evince.service \
44 " 57 "
45FILES_${PN}-dbg += "${libdir}/*/*/.debug \ 58FILES_${PN}-dbg += "${libdir}/*/*/.debug \
46 ${libdir}/*/*/*/.debug" 59 ${libdir}/*/*/*/.debug"