diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-09-17 12:04:40 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-09-26 08:29:11 +0200 |
commit | 64a63fccef7fc1cf9ca63553c683d984a7d32b1e (patch) | |
tree | cdd4282a8d7302be382e9939b495beb38b36d234 /meta-gnome | |
parent | e3a2814c70370129770896ea7d3d9f5edd5e9e7a (diff) | |
download | meta-openembedded-64a63fccef7fc1cf9ca63553c683d984a7d32b1e.tar.gz |
gvfs: update to 1.28.3
* patch was applied upstream
* inherit bash-completion instead of reinventing
* add systemd PACKAGECONFIG enabled for systemd in DISTRO_FEATURE
* add gcr PACKAGECONFIG disabled by default
* build tested with all except cdda and none in PACKAGECONFIG
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gvfs/files/0001-Add-support-for-libsystemd.patch | 49 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gvfs/gvfs_1.28.3.bb (renamed from meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb) | 18 |
2 files changed, 7 insertions, 60 deletions
diff --git a/meta-gnome/recipes-gnome/gvfs/files/0001-Add-support-for-libsystemd.patch b/meta-gnome/recipes-gnome/gvfs/files/0001-Add-support-for-libsystemd.patch deleted file mode 100644 index 7ec950558..000000000 --- a/meta-gnome/recipes-gnome/gvfs/files/0001-Add-support-for-libsystemd.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 39be8b277c666db21965d54d5b72418ce57a450b Mon Sep 17 00:00:00 2001 | ||
2 | From: Michael Biebl <biebl@debian.org> | ||
3 | Date: Tue, 19 May 2015 23:38:11 +0200 | ||
4 | Subject: [PATCH] Add support for libsystemd | ||
5 | |||
6 | In systemd v209 the various libsystemd-* libraries were merged into a | ||
7 | single libsystemd library. So first check for this library and fall back | ||
8 | to libsystemd-login if not found. | ||
9 | |||
10 | Bug: https://bugzilla.gnome.org/show_bug.cgi?id=749603 | ||
11 | Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779766 | ||
12 | |||
13 | Upstream-Status: Applied | ||
14 | --- | ||
15 | configure.ac | 10 ++++++---- | ||
16 | 1 file changed, 6 insertions(+), 4 deletions(-) | ||
17 | |||
18 | diff --git a/configure.ac b/configure.ac | ||
19 | index ee3475d..bd5c043 100644 | ||
20 | --- a/configure.ac | ||
21 | +++ b/configure.ac | ||
22 | @@ -264,18 +264,20 @@ dnl ********************************** | ||
23 | dnl *** Check for libsystemd-login *** | ||
24 | dnl ********************************** | ||
25 | |||
26 | -AC_ARG_ENABLE(libsystemd_login, AS_HELP_STRING([--disable-libsystemd-login],[build without liblibsystemd-login])) | ||
27 | +AC_ARG_ENABLE(libsystemd_login, AS_HELP_STRING([--disable-libsystemd-login],[build without libsystemd-login])) | ||
28 | msg_libsystemd_login=no | ||
29 | LIBSYSTEMD_LOGIN_LIBS= | ||
30 | LIBSYSTEMD_LOGIN_CFLAGS= | ||
31 | LIBSYSTEMD_LOGIN_REQUIRED=44 | ||
32 | |||
33 | if test "x$enable_libsystemd_login" != "xno"; then | ||
34 | - PKG_CHECK_EXISTS([libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED], msg_libsystemd_login=yes) | ||
35 | + PKG_CHECK_EXISTS([libsystemd], [msg_libsystemd_login=yes], | ||
36 | + [PKG_CHECK_EXISTS([libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED], msg_libsystemd_login=yes)]) | ||
37 | |||
38 | if test "x$msg_libsystemd_login" = "xyes"; then | ||
39 | - PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED]) | ||
40 | - AC_DEFINE(HAVE_LIBSYSTEMD_LOGIN, 1, [Define to 1 if liblibsystemd_login is available]) | ||
41 | + PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd],, | ||
42 | + [PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],[libsystemd-login >= $LIBSYSTEMD_LOGIN_REQUIRED])]) | ||
43 | + AC_DEFINE(HAVE_LIBSYSTEMD_LOGIN, 1, [Define to 1 if libsystemd_login is available]) | ||
44 | fi | ||
45 | fi | ||
46 | |||
47 | -- | ||
48 | 2.5.0 | ||
49 | |||
diff --git a/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb b/meta-gnome/recipes-gnome/gvfs/gvfs_1.28.3.bb index aa6207019..fde57c1bf 100644 --- a/meta-gnome/recipes-gnome/gvfs/gvfs_1.24.2.bb +++ b/meta-gnome/recipes-gnome/gvfs/gvfs_1.28.3.bb | |||
@@ -2,15 +2,12 @@ DESCRIPTION = "gvfs is a userspace virtual filesystem" | |||
2 | LICENSE = "LGPLv2" | 2 | LICENSE = "LGPLv2" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
4 | 4 | ||
5 | inherit gnome | 5 | inherit gnome bash-completion |
6 | 6 | ||
7 | DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2" | 7 | DEPENDS += "libsecret glib-2.0 gconf intltool-native libgudev udisks2" |
8 | 8 | ||
9 | SRC_URI[archive.md5sum] = "83ed317eb2a5264715d4273e90a5cfd8" | 9 | SRC_URI[archive.md5sum] = "d2399a1a217dd5030e8830c7e7c813c2" |
10 | SRC_URI[archive.sha256sum] = "0949eaedd1df7175f8d7ee2700df8210d1f854b8ee37d963bc32ee7091eeb228" | 10 | SRC_URI[archive.sha256sum] = "458c4cb68570f6ef4a9e152995c62d0057c3e0a07ed64d84c7200cdd22f0bd17" |
11 | SRC_URI += " \ | ||
12 | file://0001-Add-support-for-libsystemd.patch \ | ||
13 | " | ||
14 | 11 | ||
15 | EXTRA_OECONF = " \ | 12 | EXTRA_OECONF = " \ |
16 | --disable-gdu \ | 13 | --disable-gdu \ |
@@ -28,6 +25,7 @@ FILES_${PN} += " \ | |||
28 | ${datadir}/dbus-1/services \ | 25 | ${datadir}/dbus-1/services \ |
29 | ${libdir}/gio/modules/*.so \ | 26 | ${libdir}/gio/modules/*.so \ |
30 | ${libdir}/tmpfiles.d \ | 27 | ${libdir}/tmpfiles.d \ |
28 | ${systemd_user_unitdir} \ | ||
31 | " | 29 | " |
32 | RDEPENDS_${PN} = "udisks2" | 30 | RDEPENDS_${PN} = "udisks2" |
33 | 31 | ||
@@ -40,20 +38,18 @@ FILES_gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.moun | |||
40 | 38 | ||
41 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" | 39 | RRECOMMENDS_gvfsd-ftp += "openssh-sftp openssh-ssh" |
42 | 40 | ||
43 | PACKAGES += "${PN}-bash-completion" | 41 | PACKAGECONFIG ?= "libgphoto2 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
44 | FILES_${PN}-bash-completion = "${datadir}/bash-completion" | ||
45 | RDEPENDS_${PN}-bash-completion = "bash-completion" | ||
46 | |||
47 | PACKAGECONFIG ?= "libgphoto2" | ||
48 | 42 | ||
49 | PACKAGECONFIG[afc] = "--enable-afc, --disable-afc, libimobiledevice libplist" | 43 | PACKAGECONFIG[afc] = "--enable-afc, --disable-afc, libimobiledevice libplist" |
50 | PACKAGECONFIG[archive] = "--enable-archive, --disable-archive, libarchive" | 44 | PACKAGECONFIG[archive] = "--enable-archive, --disable-archive, libarchive" |
51 | PACKAGECONFIG[avahi] = "--enable-avahi, --disable-avahi, avahi" | 45 | PACKAGECONFIG[avahi] = "--enable-avahi, --disable-avahi, avahi" |
46 | PACKAGECONFIG[gcr] = "--enable-gcr, --disable-gcr, gcr" | ||
52 | PACKAGECONFIG[gtk] = "--enable-gtk, --disable-gtk, gtk+3" | 47 | PACKAGECONFIG[gtk] = "--enable-gtk, --disable-gtk, gtk+3" |
53 | PACKAGECONFIG[http] = "--enable-http, --disable-http, libsoup-2.4" | 48 | PACKAGECONFIG[http] = "--enable-http, --disable-http, libsoup-2.4" |
54 | PACKAGECONFIG[libmtp] = "--enable-libmtp, --disable-libmtp, libmtp" | 49 | PACKAGECONFIG[libmtp] = "--enable-libmtp, --disable-libmtp, libmtp" |
55 | PACKAGECONFIG[libgphoto2] = "--enable-gphoto2, --disable-gphoto2, libgphoto2" | 50 | PACKAGECONFIG[libgphoto2] = "--enable-gphoto2, --disable-gphoto2, libgphoto2" |
56 | PACKAGECONFIG[samba] = "--enable-samba, --disable-samba, samba" | 51 | PACKAGECONFIG[samba] = "--enable-samba, --disable-samba, samba" |
52 | PACKAGECONFIG[systemd] = "--with-systemduserunitdir=${systemd_user_unitdir},--without-systemduserunitdir,systemd" | ||
57 | 53 | ||
58 | # needs meta-filesystems | 54 | # needs meta-filesystems |
59 | PACKAGECONFIG[fuse] = "--enable-fuse, --disable-fuse, fuse" | 55 | PACKAGECONFIG[fuse] = "--enable-fuse, --disable-fuse, fuse" |