diff options
author | Joshua Lock <joshua.g.lock@intel.com> | 2016-11-25 15:28:52 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-12-02 09:16:17 +0100 |
commit | efd3696e70a6603f1a45faa4a172433514f0a487 (patch) | |
tree | b72751ba93b050391db05a8e1be7506836b6d515 /meta-gnome | |
parent | 761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff) | |
download | meta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz |
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True
option from getVar() calls with a regex search and replace.
Search made with the following regex: getVar ?\(( ?[^,()]*), True\)
Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb | 4 |
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb index 5052b36fc..ec17c75e3 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb | |||
@@ -111,7 +111,7 @@ python populate_packages_prepend () { | |||
111 | d.setVar('FILES_' + metapkg, "") | 111 | d.setVar('FILES_' + metapkg, "") |
112 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] | 112 | blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ] |
113 | metapkg_rdepends = [] | 113 | metapkg_rdepends = [] |
114 | packages = d.getVar('PACKAGES', 1).split() | 114 | packages = d.getVar('PACKAGES').split() |
115 | for pkg in packages[1:]: | 115 | for pkg in packages[1:]: |
116 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): | 116 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): |
117 | print("Modifying %s" % pkg) | 117 | print("Modifying %s" % pkg) |
diff --git a/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb b/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb index c0ac911a6..90ed5a464 100644 --- a/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb +++ b/meta-gnome/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb | |||
@@ -41,8 +41,8 @@ ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" | |||
41 | UPSTREAM_CHECK_REGEX = "(?P<pver>2\.([0-8]*[02468])+(\.\d+)+)" | 41 | UPSTREAM_CHECK_REGEX = "(?P<pver>2\.([0-8]*[02468])+(\.\d+)+)" |
42 | 42 | ||
43 | python populate_packages_prepend() { | 43 | python populate_packages_prepend() { |
44 | engines_root = os.path.join(d.getVar('libdir', True), "gtk-2.0/2.10.0/engines") | 44 | engines_root = os.path.join(d.getVar('libdir'), "gtk-2.0/2.10.0/engines") |
45 | themes_root = os.path.join(d.getVar('datadir', True), "themes") | 45 | themes_root = os.path.join(d.getVar('datadir'), "themes") |
46 | 46 | ||
47 | do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='') | 47 | do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='') |
48 | do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='') | 48 | do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='') |