diff options
author | Andreas Müller <schnitzeltony@gmail.com> | 2018-03-19 21:29:01 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-29 16:48:44 -0700 |
commit | be12b88bebc3107e45c954016744789200f74981 (patch) | |
tree | 571bdfb4de2f4f01da81206aac0c30b8b67b40eb /meta-gnome | |
parent | ca32e26cc853a3124400928c704983e7d699717c (diff) | |
download | meta-openembedded-be12b88bebc3107e45c954016744789200f74981.tar.gz |
libbonobo: remove
project is dead last release was 2011
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-gnome')
7 files changed, 0 insertions, 362 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.m4 b/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.m4 deleted file mode 100644 index 3ec41666b..000000000 --- a/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.m4 +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | dnl -*- mode: autoconf -*- | ||
2 | |||
3 | # serial 1 | ||
4 | |||
5 | dnl Usage: | ||
6 | dnl GTK_DOC_CHECK([minimum-gtk-doc-version]) | ||
7 | AC_DEFUN([GTK_DOC_CHECK], | ||
8 | [ | ||
9 | AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first | ||
10 | AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first | ||
11 | dnl for overriding the documentation installation directory | ||
12 | AC_ARG_WITH(html-dir, | ||
13 | AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),, | ||
14 | [with_html_dir='${datadir}/gtk-doc/html']) | ||
15 | HTML_DIR="$with_html_dir" | ||
16 | AC_SUBST(HTML_DIR) | ||
17 | |||
18 | dnl enable/disable documentation building | ||
19 | AC_ARG_ENABLE(gtk-doc, | ||
20 | AC_HELP_STRING([--enable-gtk-doc], | ||
21 | [use gtk-doc to build documentation [default=no]]),, | ||
22 | enable_gtk_doc=no) | ||
23 | |||
24 | have_gtk_doc=no | ||
25 | if test -z "$PKG_CONFIG"; then | ||
26 | AC_PATH_PROG(PKG_CONFIG, pkg-config, no) | ||
27 | fi | ||
28 | if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then | ||
29 | have_gtk_doc=yes | ||
30 | fi | ||
31 | |||
32 | dnl do we want to do a version check? | ||
33 | ifelse([$1],[],, | ||
34 | [gtk_doc_min_version=$1 | ||
35 | if test "$have_gtk_doc" = yes; then | ||
36 | AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version]) | ||
37 | if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then | ||
38 | AC_MSG_RESULT(yes) | ||
39 | else | ||
40 | AC_MSG_RESULT(no) | ||
41 | have_gtk_doc=no | ||
42 | fi | ||
43 | fi | ||
44 | ]) | ||
45 | if test x$enable_gtk_doc = xyes; then | ||
46 | if test "$have_gtk_doc" != yes; then | ||
47 | enable_gtk_doc=no | ||
48 | fi | ||
49 | fi | ||
50 | |||
51 | AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes) | ||
52 | AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL") | ||
53 | ]) | ||
diff --git a/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.make b/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.make deleted file mode 100644 index 354ffb7c6..000000000 --- a/meta-gnome/recipes-gnome/bonobo/files/gtk-doc.make +++ /dev/null | |||
@@ -1,173 +0,0 @@ | |||
1 | # -*- mode: makefile -*- | ||
2 | |||
3 | #################################### | ||
4 | # Everything below here is generic # | ||
5 | #################################### | ||
6 | |||
7 | if GTK_DOC_USE_LIBTOOL | ||
8 | GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) | ||
9 | GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) | ||
10 | else | ||
11 | GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) | ||
12 | GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) | ||
13 | endif | ||
14 | |||
15 | # We set GPATH here; this gives us semantics for GNU make | ||
16 | # which are more like other make's VPATH, when it comes to | ||
17 | # whether a source that is a target of one rule is then | ||
18 | # searched for in VPATH/GPATH. | ||
19 | # | ||
20 | GPATH = $(srcdir) | ||
21 | |||
22 | TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE) | ||
23 | |||
24 | EXTRA_DIST = \ | ||
25 | $(content_files) \ | ||
26 | $(HTML_IMAGES) \ | ||
27 | $(DOC_MAIN_SGML_FILE) \ | ||
28 | $(DOC_MODULE)-sections.txt \ | ||
29 | $(DOC_MODULE)-overrides.txt | ||
30 | |||
31 | DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \ | ||
32 | $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp | ||
33 | |||
34 | SCANOBJ_FILES = \ | ||
35 | $(DOC_MODULE).args \ | ||
36 | $(DOC_MODULE).hierarchy \ | ||
37 | $(DOC_MODULE).interfaces \ | ||
38 | $(DOC_MODULE).prerequisites \ | ||
39 | $(DOC_MODULE).signals | ||
40 | |||
41 | REPORT_FILES = \ | ||
42 | $(DOC_MODULE)-undocumented.txt \ | ||
43 | $(DOC_MODULE)-undeclared.txt \ | ||
44 | $(DOC_MODULE)-unused.txt | ||
45 | |||
46 | CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS) | ||
47 | |||
48 | if ENABLE_GTK_DOC | ||
49 | all-local: html-build.stamp | ||
50 | else | ||
51 | all-local: | ||
52 | endif | ||
53 | |||
54 | docs: html-build.stamp | ||
55 | |||
56 | #### scan #### | ||
57 | |||
58 | scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB) | ||
59 | @echo 'gtk-doc: Scanning header files' | ||
60 | @-chmod -R u+w $(srcdir) | ||
61 | cd $(srcdir) && \ | ||
62 | gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES) | ||
63 | if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \ | ||
64 | CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \ | ||
65 | else \ | ||
66 | cd $(srcdir) ; \ | ||
67 | for i in $(SCANOBJ_FILES) ; do \ | ||
68 | test -f $$i || touch $$i ; \ | ||
69 | done \ | ||
70 | fi | ||
71 | touch scan-build.stamp | ||
72 | |||
73 | $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp | ||
74 | @true | ||
75 | |||
76 | #### templates #### | ||
77 | |||
78 | tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt | ||
79 | @echo 'gtk-doc: Rebuilding template files' | ||
80 | @-chmod -R u+w $(srcdir) | ||
81 | cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS) | ||
82 | touch tmpl-build.stamp | ||
83 | |||
84 | tmpl.stamp: tmpl-build.stamp | ||
85 | @true | ||
86 | |||
87 | tmpl/*.sgml: | ||
88 | @true | ||
89 | |||
90 | |||
91 | #### xml #### | ||
92 | |||
93 | sgml-build.stamp: tmpl.stamp $(HFILE_GLOB) $(CFILE_GLOB) $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files) | ||
94 | @echo 'gtk-doc: Building XML' | ||
95 | @-chmod -R u+w $(srcdir) | ||
96 | cd $(srcdir) && \ | ||
97 | gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS) | ||
98 | touch sgml-build.stamp | ||
99 | |||
100 | sgml.stamp: sgml-build.stamp | ||
101 | @true | ||
102 | |||
103 | #### html #### | ||
104 | |||
105 | html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files) | ||
106 | @echo 'gtk-doc: Building HTML' | ||
107 | @-chmod -R u+w $(srcdir) | ||
108 | rm -rf $(srcdir)/html | ||
109 | mkdir $(srcdir)/html | ||
110 | cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE) | ||
111 | test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html ) | ||
112 | @echo 'gtk-doc: Fixing cross-references' | ||
113 | cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS) | ||
114 | touch html-build.stamp | ||
115 | |||
116 | ############## | ||
117 | |||
118 | clean-local: | ||
119 | rm -f *~ *.bak | ||
120 | rm -rf .libs | ||
121 | |||
122 | distclean-local: | ||
123 | cd $(srcdir) && \ | ||
124 | rm -rf xml $(REPORT_FILES) \ | ||
125 | $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt | ||
126 | |||
127 | maintainer-clean-local: clean | ||
128 | cd $(srcdir) && rm -rf xml html | ||
129 | |||
130 | install-data-local: | ||
131 | -installfiles=`echo $(srcdir)/html/*`; \ | ||
132 | if test "$$installfiles" = '$(srcdir)/html/*'; \ | ||
133 | then echo '-- Nothing to install' ; \ | ||
134 | else \ | ||
135 | $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \ | ||
136 | for i in $$installfiles; do \ | ||
137 | echo '-- Installing '$$i ; \ | ||
138 | $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \ | ||
139 | done; \ | ||
140 | echo '-- Installing $(srcdir)/html/index.sgml' ; \ | ||
141 | $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \ | ||
142 | which gtkdoc-rebase >/dev/null && \ | ||
143 | gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \ | ||
144 | fi | ||
145 | |||
146 | |||
147 | uninstall-local: | ||
148 | rm -f $(DESTDIR)$(TARGET_DIR)/* | ||
149 | |||
150 | # | ||
151 | # Require gtk-doc when making dist | ||
152 | # | ||
153 | if ENABLE_GTK_DOC | ||
154 | dist-check-gtkdoc: | ||
155 | else | ||
156 | dist-check-gtkdoc: | ||
157 | @echo "*** gtk-doc must be installed and enabled in order to make dist" | ||
158 | @false | ||
159 | endif | ||
160 | |||
161 | dist-hook: dist-check-gtkdoc dist-hook-local | ||
162 | mkdir $(distdir)/tmpl | ||
163 | mkdir $(distdir)/xml | ||
164 | mkdir $(distdir)/html | ||
165 | -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl | ||
166 | -cp $(srcdir)/xml/*.xml $(distdir)/xml | ||
167 | cp $(srcdir)/html/* $(distdir)/html | ||
168 | -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/ | ||
169 | -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/ | ||
170 | cd $(distdir) && rm -f $(DISTCLEANFILES) | ||
171 | -gtkdoc-rebase --online --relative --html-dir=$(distdir)/html | ||
172 | |||
173 | .PHONY : dist-hook-local docs | ||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc deleted file mode 100644 index e4759a87c..000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | DESCRIPTION = "Bonobo CORBA interfaces library" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
4 | file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34" | ||
5 | SECTION = "x11/gnome/libs" | ||
6 | DEPENDS = "gnome-common-native glib-2.0 orbit2-native orbit2 intltool-native libxml2 dbus dbus-glib" | ||
7 | |||
8 | inherit gnomebase gtk-doc lib_package | ||
9 | |||
10 | EXTRA_OECONF += "'PERL_PATH=${USRBINPATH}/env perl'" | ||
11 | ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2" | ||
12 | |||
13 | RDEPENDS_${PN}-bin = "${PN} perl" | ||
14 | FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so" | ||
15 | FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug \ | ||
16 | ${libdir}/bonobo-2.0/samples/.debug ${libdir}/orbit-2.0/.debug" | ||
17 | FILES_${PN}-dev += "${libdir}/orbit-2.0/*.la ${libdir}/bonobo/monikers/*.la ${libdir}/bonobo-2.0/samples" | ||
18 | FILES_${PN}-staticdev += "${libdir}/orbit-2.0/*.a ${libdir}/bonobo/monikers/*.a" | ||
19 | |||
20 | LEAD_SONAME = "libbonobo-2.so" | ||
21 | |||
22 | PARALLEL_MAKE = "" | ||
23 | |||
24 | do_compile() { | ||
25 | oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install | ||
30 | } | ||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch deleted file mode 100644 index 44cf1f9fa..000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonobo/0001-Remove-use-of-G_DISABLE_DEPRECATED.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From fef13a371fc91f6d9b42518126c2a8b459fdf0e8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Colin Walters <walters@verbum.org> | ||
3 | Date: Thu, 2 May 2013 14:17:38 -0400 | ||
4 | Subject: [PATCH] Remove use of G_DISABLE_DEPRECATED | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | This now trips up on GStaticRecMutex; I'm not going to bother to port, | ||
10 | realistically no one is actively maintaining this code anymore. | ||
11 | |||
12 | Upstream-Status: Applied | ||
13 | |||
14 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
15 | --- | ||
16 | activation-server/Makefile.am | 1 - | ||
17 | configure.in | 2 +- | ||
18 | 2 files changed, 1 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/activation-server/Makefile.am b/activation-server/Makefile.am | ||
21 | index efb18a8..ffa90f6 100644 | ||
22 | --- a/activation-server/Makefile.am | ||
23 | +++ b/activation-server/Makefile.am | ||
24 | @@ -17,7 +17,6 @@ INCLUDES= \ | ||
25 | $(SERVER_CFLAGS) \ | ||
26 | $(WARN_CFLAGS) \ | ||
27 | -DSERVER_CONFDIR=\"$(sysconfdir)\" \ | ||
28 | - -DG_DISABLE_DEPRECATED \ | ||
29 | -DG_LOG_DOMAIN=\"Bonobo-Activation-Server\" \ | ||
30 | $(NULL) | ||
31 | |||
32 | diff --git a/configure.in b/configure.in | ||
33 | index 70a4e26..6be2bca 100644 | ||
34 | --- a/configure.in | ||
35 | +++ b/configure.in | ||
36 | @@ -132,7 +132,7 @@ AC_SUBST(SERVER_LIBS) | ||
37 | AC_SUBST(SERVER_CFLAGS) | ||
38 | |||
39 | if test "$enable_maintainer_mode" = "yes"; then | ||
40 | - DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_DEPRECATED -DG_DISABLE_SINGLE_INCLUDES" | ||
41 | + DISABLE_DEPRECATED_CFLAGS="-DG_DISABLE_SINGLE_INCLUDES" | ||
42 | AC_SUBST(DISABLE_DEPRECATED_CFLAGS) | ||
43 | fi | ||
44 | |||
45 | -- | ||
46 | 1.7.6.5 | ||
47 | |||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch deleted file mode 100644 index a20edda84..000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonobo/do-not-use-srcdir-variable.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | | tests/Makefile.am:55: error: using '$(srcdir)' in TESTS is currently broken: '$(srcdir)/te | ||
2 | st-properties.sh' | ||
3 | | tests/test-activation/Makefile.am:76: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS | ||
4 | ' (or '*_CPPFLAGS') | ||
5 | | utils/Makefile.am:9: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS | ||
6 | ') | ||
7 | | autoreconf: automake failed with exit status: 1 | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | Upstream-Status: Not Submitted | ||
11 | |||
12 | Index: libbonobo-2.32.1/tests/Makefile.am | ||
13 | =================================================================== | ||
14 | --- libbonobo-2.32.1.orig/tests/Makefile.am 2010-08-29 04:56:00.000000000 -0700 | ||
15 | +++ libbonobo-2.32.1/tests/Makefile.am 2014-04-25 15:38:22.024744384 -0700 | ||
16 | @@ -55,7 +55,7 @@ | ||
17 | MODELS_DIR="$(srcdir)/models" | ||
18 | |||
19 | TESTS = test-moniker$(EXEEXT) test-event-source$(EXEEXT) test-object$(EXEEXT) \ | ||
20 | - test-stream-mem$(EXEEXT) $(srcdir)/test-properties.sh test-storage-mem$(EXEEXT) \ | ||
21 | + test-stream-mem$(EXEEXT) test-properties.sh test-storage-mem$(EXEEXT) \ | ||
22 | test-main-loop$(EXEEXT) | ||
23 | |||
24 | # TESTS += test-generic-factory.sh | ||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch deleted file mode 100644 index 20db671e0..000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonobo/fix-nonliteral-in-string.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | This checks whether the format string is a literal on the calling function. As bonobo_debug_print() | ||
2 | takes already a va_list, we specify the format on the functions that call it | ||
3 | The second number, which is 0 here, should then be the argument index of the variadic argument | ||
4 | |||
5 | Fixed warning with clang | ||
6 | |||
7 | | ../../libbonobo-2.32.1/bonobo/bonobo-debug.c:58:32: error: format string is not a string literal [-Werror,-Wformat-nonliteral] | ||
8 | | vfprintf (_bonobo_debug_file, fmt, args); | ||
9 | | ^~~ | ||
10 | | 1 error generated. | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | |||
15 | Index: libbonobo-2.32.1/bonobo/bonobo-debug.c | ||
16 | =================================================================== | ||
17 | --- libbonobo-2.32.1.orig/bonobo/bonobo-debug.c | ||
18 | +++ libbonobo-2.32.1/bonobo/bonobo-debug.c | ||
19 | @@ -47,6 +47,7 @@ bonobo_debug_init(void) | ||
20 | _bonobo_debug_file = stderr; | ||
21 | } | ||
22 | |||
23 | +__attribute__((__format__ (printf, 2, 0))) | ||
24 | void | ||
25 | bonobo_debug_print (const char *name, char *fmt, ...) | ||
26 | { | ||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb deleted file mode 100644 index 8e00eb4d2..000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.32.1.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | require libbonobo.inc | ||
2 | |||
3 | SRC_URI += "file://0001-Remove-use-of-G_DISABLE_DEPRECATED.patch \ | ||
4 | file://do-not-use-srcdir-variable.patch \ | ||
5 | file://fix-nonliteral-in-string.patch \ | ||
6 | " | ||
7 | SRC_URI[archive.md5sum] = "27fa902d4fdf6762ee010e7053aaf77b" | ||
8 | SRC_URI[archive.sha256sum] = "9160d4f277646400d3bb6b4fa73636cc6d1a865a32b9d0760e1e9e6ee624976b" | ||
9 | GNOME_COMPRESS_TYPE="bz2" | ||