diff options
author | Zoltán Böszörményi <zboszor@gmail.com> | 2021-08-29 07:36:23 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-29 09:11:16 -0700 |
commit | 7e435caa8e3f1cb1f1034cad76b75575328ba511 (patch) | |
tree | 9f938fd361033b3dde624bd52d4f4cf63b1111ec /meta-gnome | |
parent | 91c63809461659b11b5af2ded5f928ab0e800118 (diff) | |
download | meta-openembedded-7e435caa8e3f1cb1f1034cad76b75575328ba511.tar.gz |
metacity: Add a patch to create build/src/core before moving generated sources to it
Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/metacity/metacity/0001-fix-build-with-disable-dependency-tracking.patch | 65 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/metacity/metacity_3.40.0.bb | 5 |
2 files changed, 69 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/metacity/metacity/0001-fix-build-with-disable-dependency-tracking.patch b/meta-gnome/recipes-gnome/metacity/metacity/0001-fix-build-with-disable-dependency-tracking.patch new file mode 100644 index 000000000..864d0baa2 --- /dev/null +++ b/meta-gnome/recipes-gnome/metacity/metacity/0001-fix-build-with-disable-dependency-tracking.patch | |||
@@ -0,0 +1,65 @@ | |||
1 | From 632670273cc880917e78a152a3ae39e209b57864 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Zolt=C3=A1n=20B=C3=B6sz=C3=B6rm=C3=A9nyi?= | ||
3 | <zboszor@gmail.com> | ||
4 | Date: Sat, 28 Aug 2021 05:58:25 +0200 | ||
5 | Subject: [PATCH] fix build with --disable-dependency-tracking | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | With split build and source directories AND --disable-dependency-tracking | ||
11 | (like the way Yocto builds are done) there's a reproducible make | ||
12 | failure on my Fedora 33 build host: | ||
13 | |||
14 | | Making all in src | ||
15 | | make[2]: Entering directory '.../metacity/1_3.40.0-r0/build/src' | ||
16 | | .../metacity/1_3.40.0-r0/recipe-sysroot-native/usr/bin/glib-mkenums --template ../../metacity-3.40.0/src/core/meta-enum-types.c.in ../../metacity-3.40.0/src/core/window-private.h ../../metacity-3.40.0/src/include/meta-compositor.h > \ | ||
17 | | meta-enum-types.c.tmp && mv meta-enum-types.c.tmp core/meta-enum-types.c | ||
18 | | .../metacity/1_3.40.0-r0/recipe-sysroot-native/usr/bin/glib-mkenums --template ../../metacity-3.40.0/src/core/meta-enum-types.h.in ../../metacity-3.40.0/src/core/window-private.h ../../metacity-3.40.0/src/include/meta-compositor.h > \ | ||
19 | | meta-enum-types.h.tmp && mv meta-enum-types.h.tmp core/meta-enum-types.h | ||
20 | | mv: cannot move 'meta-enum-types.c.tmp' to 'core/meta-enum-types.c'mv: cannot move 'meta-enum-types.h.tmp' to 'core/meta-enum-types.h': No such file or directory | ||
21 | | : No such file or directory | ||
22 | | make[2]: *** [Makefile:2240: core/meta-enum-types.c] Error 1 | ||
23 | |||
24 | https://gitlab.gnome.org/GNOME/metacity/-/merge_requests/24 | ||
25 | |||
26 | Upstream-Status: Pending | ||
27 | |||
28 | Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com> | ||
29 | --- | ||
30 | configure.ac | 1 + | ||
31 | src/Makefile.am | 2 ++ | ||
32 | 2 files changed, 3 insertions(+) | ||
33 | |||
34 | diff --git a/configure.ac b/configure.ac | ||
35 | index ebb00b85..04aafb94 100644 | ||
36 | --- a/configure.ac | ||
37 | +++ b/configure.ac | ||
38 | @@ -139,6 +139,7 @@ dnl ************************************************************************** | ||
39 | AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}") | ||
40 | |||
41 | AC_PROG_CC | ||
42 | +AC_PROG_MKDIR_P | ||
43 | AC_ISC_POSIX | ||
44 | AC_HEADER_STDC | ||
45 | |||
46 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
47 | index f86af600..4aa3fdae 100644 | ||
48 | --- a/src/Makefile.am | ||
49 | +++ b/src/Makefile.am | ||
50 | @@ -204,10 +204,12 @@ ENUM_TYPES = \ | ||
51 | $(NULL) | ||
52 | |||
53 | core/meta-enum-types.c: core/meta-enum-types.c.in $(ENUM_TYPES) Makefile.am | ||
54 | + $(MKDIR_P) core | ||
55 | $(AM_V_GEN) $(GLIB_MKENUMS) --template $(srcdir)/core/meta-enum-types.c.in $(ENUM_TYPES) > \ | ||
56 | meta-enum-types.c.tmp && mv meta-enum-types.c.tmp core/meta-enum-types.c | ||
57 | |||
58 | core/meta-enum-types.h: core/meta-enum-types.h.in $(ENUM_TYPES) Makefile.am | ||
59 | + $(MKDIR_P) core | ||
60 | $(AM_V_GEN) $(GLIB_MKENUMS) --template $(srcdir)/core/meta-enum-types.h.in $(ENUM_TYPES) > \ | ||
61 | meta-enum-types.h.tmp && mv meta-enum-types.h.tmp core/meta-enum-types.h | ||
62 | |||
63 | -- | ||
64 | 2.31.1 | ||
65 | |||
diff --git a/meta-gnome/recipes-gnome/metacity/metacity_3.40.0.bb b/meta-gnome/recipes-gnome/metacity/metacity_3.40.0.bb index a5c704740..e7570ec59 100644 --- a/meta-gnome/recipes-gnome/metacity/metacity_3.40.0.bb +++ b/meta-gnome/recipes-gnome/metacity/metacity_3.40.0.bb | |||
@@ -24,7 +24,10 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
24 | inherit gnomebase gsettings gettext upstream-version-is-even features_check | 24 | inherit gnomebase gsettings gettext upstream-version-is-even features_check |
25 | 25 | ||
26 | SRC_URI[archive.sha256sum] = "224c1f65487eac21f0c1d9856152343768ee726c48b1a8a2835a46a8ad9015b5" | 26 | SRC_URI[archive.sha256sum] = "224c1f65487eac21f0c1d9856152343768ee726c48b1a8a2835a46a8ad9015b5" |
27 | SRC_URI += "file://0001-drop-zenity-detection.patch" | 27 | SRC_URI += " \ |
28 | file://0001-drop-zenity-detection.patch \ | ||
29 | file://0001-fix-build-with-disable-dependency-tracking.patch \ | ||
30 | " | ||
28 | 31 | ||
29 | PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama" | 32 | PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama" |
30 | # enable as neccessary until new warnings are dealt with | 33 | # enable as neccessary until new warnings are dealt with |