diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-01-15 13:23:30 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-15 20:54:22 -0800 |
commit | 42ec7b02e81f47adec8b8fda3f72daa21cc415f7 (patch) | |
tree | f72c3720648659aeea307dd8bcfee6c4eea651fe /meta-gnome | |
parent | df61601333bf2fc8cb003f14e440a7de1582fd82 (diff) | |
download | meta-openembedded-42ec7b02e81f47adec8b8fda3f72daa21cc415f7.tar.gz |
sysprof: avoid namesapace conflict with glibc headers
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch | 63 | ||||
-rw-r--r-- | meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb | 5 |
2 files changed, 66 insertions, 2 deletions
diff --git a/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch b/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch new file mode 100644 index 000000000..1e2b3c92b --- /dev/null +++ b/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From 4bd0d5d5dd6841fbac8385527617d18e7731244d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 15 Jan 2020 13:17:58 -0800 | ||
4 | Subject: [PATCH] libsysprof-ui: Rename environ to sys_environ | ||
5 | |||
6 | This helps avoid namesapace conflict with glibc headers | ||
7 | |||
8 | Fixes | ||
9 | /usr/include/unistd.h:545:15: note: previous declaration is here | ||
10 | |||
11 | extern char **environ; | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | src/libsysprof-ui/sysprof-profiler-assistant.c | 10 +++++----- | ||
17 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
18 | |||
19 | diff --git a/src/libsysprof-ui/sysprof-profiler-assistant.c b/src/libsysprof-ui/sysprof-profiler-assistant.c | ||
20 | index 22e3e24..c55d551 100644 | ||
21 | --- a/src/libsysprof-ui/sysprof-profiler-assistant.c | ||
22 | +++ b/src/libsysprof-ui/sysprof-profiler-assistant.c | ||
23 | @@ -235,7 +235,7 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self, | ||
24 | { | ||
25 | g_auto(GStrv) argv = NULL; | ||
26 | g_auto(GStrv) env = NULL; | ||
27 | - SysprofEnviron *environ; | ||
28 | + SysprofEnviron *sys_environ; | ||
29 | const gchar *command; | ||
30 | gint argc; | ||
31 | |||
32 | @@ -245,8 +245,8 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self, | ||
33 | sysprof_profiler_set_spawn (profiler, TRUE); | ||
34 | sysprof_profiler_set_spawn_argv (profiler, (const gchar * const *)argv); | ||
35 | |||
36 | - environ = sysprof_environ_editor_get_environ (self->environ_editor); | ||
37 | - env = sysprof_environ_get_environ (environ); | ||
38 | + sys_environ = sysprof_environ_editor_get_environ (self->environ_editor); | ||
39 | + env = sysprof_environ_get_environ (sys_environ); | ||
40 | sysprof_profiler_set_spawn_env (profiler, (const gchar * const *)env); | ||
41 | |||
42 | sysprof_profiler_set_spawn_inherit_environ (profiler, | ||
43 | @@ -405,7 +405,7 @@ sysprof_profiler_assistant_class_init (SysprofProfilerAssistantClass *klass) | ||
44 | static void | ||
45 | sysprof_profiler_assistant_init (SysprofProfilerAssistant *self) | ||
46 | { | ||
47 | - g_autoptr(SysprofEnviron) environ = sysprof_environ_new (); | ||
48 | + g_autoptr(SysprofEnviron) sys_environ = sysprof_environ_new (); | ||
49 | |||
50 | gtk_widget_init_template (GTK_WIDGET (self)); | ||
51 | |||
52 | @@ -445,7 +445,7 @@ sysprof_profiler_assistant_init (SysprofProfilerAssistant *self) | ||
53 | self, | ||
54 | G_CONNECT_SWAPPED); | ||
55 | |||
56 | - sysprof_environ_editor_set_environ (self->environ_editor, environ); | ||
57 | + sysprof_environ_editor_set_environ (self->environ_editor, sys_environ); | ||
58 | } | ||
59 | |||
60 | void | ||
61 | -- | ||
62 | 2.25.0 | ||
63 | |||
diff --git a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb index fd1b77ece..920bf10d6 100644 --- a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb +++ b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb | |||
@@ -12,8 +12,9 @@ DEPENDS = "glib-2.0 libxml2-native glib-2.0-native" | |||
12 | SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629" | 12 | SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629" |
13 | SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0" | 13 | SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0" |
14 | SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \ | 14 | SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \ |
15 | file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \ | 15 | file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \ |
16 | " | 16 | file://0001-libsysprof-ui-Rename-environ-to-sys_environ.patch \ |
17 | " | ||
17 | 18 | ||
18 | PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}" | 19 | PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}" |
19 | PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle" | 20 | PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle" |